Nowe posty

Autor Wątek: Zamieszanie z systemami dźwięku  (Przeczytany 7251 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 25
    • Zobacz profil
Zamieszanie z systemami dźwięku
« dnia: 2009-07-18, 13:31:47 »
Pewnego razu standardowo uruchomiłem OpenSuse 11.1 i chciałem posłuchać muzyki. Nie działało. To dziwne, bo nic ostatnio z systemem nie robiłem.
Pierwsze, co zrobiłem, to usunąłem PulseAudio i zainstalowałem ESD. ESD się niby łączy, ale dźwięk dalej nie działał.
Zacząłem kombinować z JACKiem. Udało mi się raz z jackd uruchomić OSS, ale dźwięk był marnej jakości.
Spróbowałem to samo na roocie... No, ALSA i OSS tam też same nie działają, ale magicznie JACK (z qjackctl!) działał z oboma systemami.
To w sumie fajnie, bo zawsze na Ubuntu mi ten Jack "pierdział", i byłbym w stanie go używać, gdyby działał na zwykłym użytkowniku (choć lepiej by było, jakby wszystko działało, bo MilkyTracker coś ma z Jackiem problemy - zawsze najlepiej działał z SDLAudio)

A oto parę wypasionych logów, które tak kochacie:
speaktrap@host-89-228-105-99:~> jackd -d oss
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
OSS: failed to open device /dev/dsp: oss_driver.c@549, errno=16
cannot start driver
Naruszenie ochrony pamięci
speaktrap@host-89-228-105-99:~> jackd -d oss
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
oss_driver: /dev/dsp : 0x10/2/48000 (4096)
oss_driver: indevbuf 4096 B, outdevbuf 4096 B
oss_driver: using barrier mode, (dual thread)

To na górze działa, ale pierdzi. Z Realtime natomiast ten sam log, ale nie chce działać. Teraz ALSA.
speaktrap@host-89-228-105-99:~> jackd -d alsa
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
control open "hw:0" (Permission denied)
ALSA lib pcm_hw.c:1429:(_snd_pcm_hw_open) Invalid value for card
ALSA lib pcm_hw.c:1429:(_snd_pcm_hw_open) Invalid value for card
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
cannot load driver module alsa
no message buffer overruns
speaktrap@host-89-228-105-99:~>

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Zamieszanie z systemami dźwięku
« Odpowiedź #1 dnia: 2009-07-18, 14:26:41 »
A nie wystarczy ci sama ALSA? Mi nic więcej do szczęścia nie trzeba...
Masz swojego użytkownika dodanego do grupy audio ?

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 25
    • Zobacz profil
Zamieszanie z systemami dźwięku
« Odpowiedź #2 dnia: 2009-07-18, 18:44:03 »
ALSA nie działa, tzn. działa przez JACKa, i to tylko na roocie.

Hm... nie wiem, jak to mam sprawdzić (jakoś nigdy nie miałem potrzeby), ale zawsze działało, dopiero przedwczoraj odmówiło posłuszeństwa. OSS tak samo.

EDIT: A to mi wyskakuje w konsoli, po naciśnięciu Play w XMMS

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Brak dostępu

oraz

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: Brak dostępu
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: Brak dostępu
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: Brak dostępu
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: Brak dostępu
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM default

** WARNING **: alsa_setup(): Failed to open pcm device (default): Brak dostępu

a to z roota:

** WARNING **: alsa_setup(): Failed to open pcm device (default): Urządzenie lub zasoby zajęte

Czemu nie mam dostępu do tych urządzeń?

Offline Krzysztof Wnuk

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 280
    • Zobacz profil
Zamieszanie z systemami dźwięku
« Odpowiedź #3 dnia: 2009-07-18, 18:56:02 »
Musisz dodać usera do grupy audio żeby miał dostęp do pliku /dev/dsp
gpasswd -a nazwausera audio
nie wszystko czego nie możesz zrozumieć, jest złem które trzeba zniszczyć...
Kłodzka strona linuksa       Spontaniczny.EU.ORG - Free Shell Accounts     Android.EU.ORG

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 25
    • Zobacz profil
Zamieszanie z systemami dźwięku
« Odpowiedź #4 dnia: 2009-07-18, 19:41:00 »
gpasswd: invalid option -- 'a'???
No, w każdym razie zrobiłem to przez YaSTa, ale nie przyniosło efektów.
EDIT: Po restarcie (wymuszonym, bo się zwiesił całkiem.. a mówią, że pingwin się nie wiesza, ale firefox spowodował domino) zaczęło działać.
Temat uważam za zamknięty, i powinien służyć Guglowcom!

Offline Krzysztof Wnuk

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 280
    • Zobacz profil
Zamieszanie z systemami dźwięku
« Odpowiedź #5 dnia: 2009-07-18, 20:04:03 »
No właśnie zapomniałem ci dodać że musisz się przelogować żeby zaczęło działać.
nie wszystko czego nie możesz zrozumieć, jest złem które trzeba zniszczyć...
Kłodzka strona linuksa       Spontaniczny.EU.ORG - Free Shell Accounts     Android.EU.ORG

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 25
    • Zobacz profil
Zamieszanie z systemami dźwięku
« Odpowiedź #6 dnia: 2009-07-19, 00:00:22 »
Dziękuję bardzo, respect+ 4 u =)