Nowe posty

Autor Wątek: Mandriva 2009 xtreme 3 zawiesza się...  (Przeczytany 6831 razy)

freq86

  • Gość
Mandriva 2009 xtreme 3 zawiesza się...
« dnia: 2009-04-10, 18:50:37 »
...przynajmniej tak to wygląda.

Po uruchomieniu systemu w przeciągu kilku- kilkunastu minut system staje w miejscu, klawiatura nie reaguje - jedynie kursor myszy mogę sobie przesuwać w zwolnionym tempie, ok 10fps. I tylko przesuwać.

Na dysku mam windowsa xp(pierwsza partycja), 2 partycje ntfs z danymi a na ostatniej zainstalowałem linuksa - 20giga na system(chyba za dużo) i 40 na swap.

Sempron 2200
512 mb ddr
asus a7v600-f (chipset VIA kt600)
ATI radeon 9250
Samsung 250GB ATA

Będę wdzięczny za pomoc.

PS. przy okazji pod linuksem nie mam dostępu do partycji E: mimo iż jest taka sama jak pozostałe C: i D: (ntfs).

arctgx

  • Gość
Mandriva 2009 xtreme 3 zawiesza się...
« Odpowiedź #1 dnia: 2009-04-10, 19:15:10 »
Warto by rozróżnić czy to wiecha spowodowana błędem programu lub sprzętu, czy może zbyt dużym obciążeniem. Skoro regularnie po kilkunastu minutach dzieje się to, odpal jakiś terminal i klepnij w nim polecenie top podglądając liderów w zużyciu procesora i pamięci (to drugie sortowanie daje klawisz M). Na górze ekranu topa, ponad listą procesu, znajduje się też niepozorna wartość wa (iowait, % CPU na operacje wejścia/wyjścia). To potrafi prockowi zamieszać czasem mocno. Pewne błędnie napisane programy potrafiły w sztuczny sposób generować takie zajęcie.

Na temat partycji możesz zrobić osobny wątek, by uniknąć bałaganu.

freq86

  • Gość
Mandriva 2009 xtreme 3 zawiesza się...
« Odpowiedź #2 dnia: 2009-04-10, 22:22:56 »
Zrobiłem jak poradziłeś i w top najlepsze miejsce zajmował pulseaudio, nie pamiętam wartości ale wyłączyłem to w ustawieniach dźwięku. Niestety nie pomogło.
Pozostałe procesy na szczycie X,kicker,init i inne zużywały mniej jak 1% CPU i 1-3% ramu.
Wartość wa wynosiła 0%
0.0%wa, 1.0%us, 99%id
Pamięć: zajęta ~350MB; wolna ~160MB; buffers 16MB
swap: zajęte 0; cached ~184MB

Jak włączałem top to system zawieszał się w ok minutę.

A teraz pozwólcie że trochę się rozpisze..

Przy uruchamianiu mandrivy wśród wyników testu na starcie jest:
Checking loopback filesystem: NIEUDANE - ma to coś wspólnego z moim problemem?

Zapomniałem w pierwszym poście napisać myślę że dość istotną informacje odnośnie mojego sprzętu, otóż:
Zawsze po reinstalacji windowsa miałem problemy z płytą główną(ASUSA7V600-F) do której sam producent się nie przyznaje i grafiką(ALASTOR RADEON9250), która jest pomyłką swych twórców. Samoczynne restarty były normą. By działały w miarę sprawnie ze sobą musiałem instalować sterowniki VIA 4in1, następnie Hyperion i na nie znowu 4in1 by wogólę móc zainstalować stery od radeona, które musiały być starsze niż dla niej dedykowane co skutkowało niedostępnością funkcji "Przyspieszenie Teksturowania AGP" i spadkiem wydajności.

Dopiero po takich manewrach system działał bez niespodzianek typu restart.

jolsky

  • Gość
Mandriva 2009 xtreme 3 zawiesza się...
« Odpowiedź #3 dnia: 2009-04-11, 13:20:38 »
Skoro masz komercyjną wersję dystrybucji - Xtreme - to masz prawo do pomocy technicznej. Skorzystaj z niej.

arctgx

  • Gość
Mandriva 2009 xtreme 3 zawiesza się...
« Odpowiedź #4 dnia: 2009-04-11, 14:48:54 »
Jeśli sprzęt ma usterkę, to nie wiem czy i technicy coś pomogą. Sam swoimi doświadczeniami sugerujesz by popróbować jak długo potrafi podziałać system, kiedy pozbawimy go jakichś sterowników, wyłączymy programową obsługę ACPI itd.

Kombinacji jest tyle, że nie sposób wszystkiego wymieniać. Proponowałbym na starcie najprostszą rzecz: zobaczyć jak długo system pożyje w samym środowisku tekstowym, w trybie single z minimalną ilością usług, potem z Xorg na sterze vesa, obecnym sterze bez akceleracji 3D itp.

Jeśli nie wiesz jak to zrobić, zacznij od szukania (np. linux single mode).

freq86

  • Gość
Mandriva 2009 xtreme 3 zawiesza się...
« Odpowiedź #5 dnia: 2009-04-21, 20:01:01 »
W środowisku tekstowym(tryb awaryjny przy wyborze systemu) to działał bez problemu.
Sądzę że problemem mogła być funkcja "Przyspieszenie teksturowania AGP", którą to moja karta obsługiwała lecz sypał się w ten czas cały system.

Niestety nie zdołam już rozwiązać tego problemu, gdyż mój zasilacz(7 letni) spalił się przy okazji częstując pełnym napięciem zasilania wszelkie podzespoły do niego podpięte.

Dziękuję arctgx za pomoc.