Nowe posty

Autor Wątek: Strona www.  (Przeczytany 9093 razy)

Offline mateo86

  • Users
  • Guru
  • *****
  • Wiadomości: 647
    • Zobacz profil
Strona www.
« dnia: 2009-04-02, 01:20:32 »
Czy moglibyście mi wyjaśnić o co chodzi, czy to może jakiś bug przeglądarki czy ja coś źle robię...

Robię znajomemu stronę www i w zależności od tego jak nazwę pliki graficzne to są one wyświetlane bądź nie. Już pokazuję to na palcach:

Przy zastosowaniu takiego kodu html pomimo, że plik baner.png znajduje się w odpowiednim katalogu nie jest wyświetlany :(

Natomiast, jeśli kod wygląda w następujący sposób:
wtedy obrazek tła jest wyświetlany.

Oba pliki są takie same, i znajdują się w katalogu. Oba pliki są odczytywane (tzn. jak ręcznie wprowadzę adres do obrazka, to się wyświetla).

Problem występuje tylko na przeglądarkach Firefox, ale nie wszystkich. Na niektórych jest to poprawnie wyświetlane.

Od czego to może zależeć?

RyszardLin

  • Gość
Strona www.
« Odpowiedź #1 dnia: 2009-04-11, 22:14:48 »
Witam

A wielkość liter jest taka sama w nazwie pliku i odwołaniu do niego? I sprawdź czy nie pojawił się Tobie biały znak w kodzie strony.


Pozdro.

arctgx

  • Gość
Strona www.
« Odpowiedź #2 dnia: 2009-04-11, 22:37:44 »
Dlaczego nadajesz tło i inne wizualne parametry (z rozmiarami włącznie) archaicznymi i niestandardowymi metodami, tzn. przez atrybuty? Nie lepiej skorzystać z poleceń CSS? Nie wiem z drugiej strony czy to wpłynie na rozwiązanie problemu.

Polecam nieśmiertelny kurs Pawła Wimmera: http://webmaster.helion.pl/kurshtml/style/style.htm

Offline mateo86

  • Users
  • Guru
  • *****
  • Wiadomości: 647
    • Zobacz profil
Strona www.
« Odpowiedź #3 dnia: 2009-04-12, 08:13:49 »
@RyszardLin: Wielkość liter jest taka sama

@arctgx: To prosta strona jest, nie warta zachodu na kombinowanie z css. Ot, jedna strona główna i 2 podstrony. Na szybkiego była tworzona i dlatego takie metody.

Próbowałem różnych chwytów, ale nic nie pomaga. Może łańcuch 'baner.jpg' jest zarezerwowany w niektórych wersjach?
Najnowsza wersja FF wyświetla poprawnie, dzieje się to tylko w starszych wersjach.

To wszystko raczej ciekawostka niż problem - przecież zmieniam nazwy plików na inne i po problemie :)

RyszardLin

  • Gość
Strona www.
« Odpowiedź #4 dnia: 2009-04-12, 20:54:23 »
Witam

Oki > a może masz/miałeś filtry co by reklamy sprawdzały:) a nazwa baner kojarzy się z reklamą:)

Pozdro

P.S. Smacznego jajka

Offline mateo86

  • Users
  • Guru
  • *****
  • Wiadomości: 647
    • Zobacz profil
Strona www.
« Odpowiedź #5 dnia: 2009-04-13, 13:45:13 »
No właśnie nie... Sam Firefox, bez żadnych dodatków..

P.S. Dzięki, nawzajem :)
i mokrego dyngusa

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1162
    • Zobacz profil
Strona www.
« Odpowiedź #6 dnia: 2009-04-16, 16:31:07 »
Hmm... coś mi tu nie gra.
Napisz czy strona, którą robisz, główna, nazwijmy ją "index.html" znajduje się po za katalogiem z plikami graficznymi png, czy w tymże też katalogu.
Jeśli strona index jest po za katalogiem to ścieżka powinna przykładowowyglądać gdzieś tak: background="katalog/ baner.png"
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

RyszardLin

  • Gość
Strona www.
« Odpowiedź #7 dnia: 2009-04-16, 22:32:14 »
Witaj

Podaj linka na tą stronę:)

Pozdro

Offline mateo86

  • Users
  • Guru
  • *****
  • Wiadomości: 647
    • Zobacz profil
Strona www.
« Odpowiedź #8 dnia: 2009-04-16, 23:57:50 »
@ Lord Darius: pliki są w tym samym katalogu, btw, wiem jak powinny wyglądać ścieżki do plików :)

@RyszardLin: Jeszcze nie ma tej strony w sieci i nie mam zielonego pojęcia kiedy będzie... Kolega ma problemy z dostawcą miejsca na serwerze...