Nowe posty

Autor Wątek: Realtek charczenie  (Przeczytany 10486 razy)

Maruchin

  • Gość
Realtek charczenie
« dnia: 2009-03-17, 20:22:44 »
Witam

Mam problem z kartą dźwiękową.OS jest świeżo zainstalowany i od razu przy odtwarzaniu muzyki i filmów głośniki mi charczą głośniki to logitech x-230 zestaw 2.1 a karta dźwiękowa to realtek dokładnie nie pamiętam ale coś 97 audio......

Głośniki są wporzo bo teraz gdy to piszę na lapku to słucham z nich muzy i jest ok.
Mandriva używa sterownika snd_hda_intel nie wiem czemu.
Na takich skrótach nie znam się i jestem świerzakiem w linuxie.

Z góry dziękuję za wszelką pomoc

rysban

  • Gość
Realtek charczenie
« Odpowiedź #1 dnia: 2009-03-18, 21:31:52 »
Witam .
Sprzęt na pewno w porządku ? Głośniki może tak . Dźwięk w tym stacjonarnym to AC97. Wszystkie trzaski mogą być powodowane wadą sprzętową .
Pozdrawiam Ryszard

Maruchin

  • Gość
Realtek charczenie
« Odpowiedź #2 dnia: 2009-03-18, 22:02:34 »
Sprzęt był ok bo przed instalką lina, na xp wszystko działało jak należy.
Miałem też tak że coś poklikałem coś zainstalowałem na linie i działało potem znów jakieś pakiety poinstalowałem iz powrotem wróciło charczenie.Wtedy zrobiłem reinstalkę linuxa i znów to mam :/. Karta dźwiękowa jest na pewno dobra

lukaszn

  • Gość
Realtek charczenie
« Odpowiedź #3 dnia: 2009-03-18, 22:09:40 »
Spróbował bym wyciszyć kanały LINE IN, Microphone i inne tym podobne cuda. Z tego co pamiętam to domyślnie w KDE są one włączone.

arctgx

  • Gość
Realtek charczenie
« Odpowiedź #4 dnia: 2009-03-18, 22:14:13 »
U mnie przesterowany bas występuje tylko przy włączonym wzmacnianiu basów i głośności na suwaku WAVE gdzieś ponad 57%. Wprawdzie to nie Realtek, a SB Live, ale i u siebie może poeksperymentuj w alsamikserze z suwakami odpowiadającymi za głośność wyjścia (u mnie są trzy takie) i zobacz czy przestery zdarzają się również przy cichszym odtwarzaniu.

Maruchin

  • Gość
Realtek charczenie
« Odpowiedź #5 dnia: 2009-03-19, 23:03:14 »
Próbuje już 2 godziny to ustawić i lipa.
Wydaję mi się że problem tkwi w tym że linux widzi moją kartę jako via tech. vt1708/a (via high definition audio controller) z tego co wiem to to nie jest realtek a jestem na 100% pewny że mam realtek.I jak wcześniej pisałem używa sterownika snd_hda_intel.

Chyba że to wszystko nie ma znaczenie hehe w co wątpię.

arctgx

  • Gość
Realtek charczenie
« Odpowiedź #6 dnia: 2009-03-19, 23:29:20 »
Na płycie głównej mam układ dźwiękowy, który w handlu zwie się chyba Realtek ALC650, ale sterownik dźwięku i tak jest zwany jak mostek południowy: VT8235 (VIA), bo w jakimś, nie potrafię dokładnie powiedzieć jakim, stopniu mostek ten obsługuje zintegrowany dźwięk. W każdym razie, nie zawsze handlowa nazwa mówi zbyt wiele.

Być może informacje z lspci i dmesg podpowiedzą komuś więcej.

P.S. Moduł snd-hda-intel ma parametr model. Jest też coś w dokumentacji Alsy o niejakim doborze kodeków (nie wiem, na ile moja intuicja trafia, ale źle dobrany kodek kojarzy mi się bardziej z zupełnym szumem niż z jego domieszką zwaną charczeniem ;)). Może w połączeniu z wyżej wspomnianymi wynikami poleceń uda się coś złożyć do kupy i wymusić dobrą konfigurację.

Tu
http://ftp.gnu.org/pub/pub/tmp/linux-libre-fsf2_2.6.28/linux-2.6.28/Documentation/sound/alsa/ALSA-Configuration.txt
przeczytaj dział Module snd-hda-intel.

lemonfire

  • Gość
Realtek charczenie
« Odpowiedź #7 dnia: 2009-03-24, 04:18:09 »
nie pamietam gdzie to znalazlem,  kazdym razie chyba gdzies na googlach...
w kazdym razie ostatnio bawilem sie madriva extreme 3 i na moim notku tez mialem snd -hda-intel i zero dzwieku.
pomoglo dopisanie w /etc/modprobe.conf (w ostatniej linii)

options snd-hda-intel model=toshiba

oczywiscie po tej linii wcisnac enter :)

i zrestartowac system, of course :)

Maruchin

  • Gość
Realtek charczenie
« Odpowiedź #8 dnia: 2009-03-24, 15:10:50 »
Ale ja mam pc i możesz wyjaśnić krok po kroku co gdzie i jak?? :)

arctgx

  • Gość
Realtek charczenie
« Odpowiedź #9 dnia: 2009-03-24, 16:35:57 »
Praktycznie masz podaną linię, którą musisz wkleić. Być może zamiast toshiby u Ciebie trzeba będzie dać inny model.

Podpowiem tylko, że jeśli modprobe.conf nie istnieje, to nie należy go tworzyć, bo nie będą czytane pliki z /etc/modprobe.d i w ten sposób może pojawić się masa kłopotów z ładowaniem sterowników. Wpis na temat opcji trzeba dodać w dowolnym (lub nowym) z plików w /etc/modprobe.d.

Maruchin

  • Gość
Realtek charczenie
« Odpowiedź #10 dnia: 2009-03-24, 17:14:20 »
Udało się hehe całkiem inaczej niż każdy pisał ale jest ok.

To może napiszę co takiego czarodziejskiego zrobiłem że działa.

Zreinstalowałem lina uruchomiłem Kmix wcześniej nie wiem czemu ale nie chciał się uruchamiać i tam cuś poklikałem i jakoś się udało. W pulseaudio przesuwanie suwaków  nie dawało żadnych efektów.

Dzięki za pomoc :)