Nowe posty

xx Mulenie strony [Tylko informacja] (0)
2020-02-25, 16:36:43
xx Film Hakerzy dla wolności 2018 lektor (0)
2020-02-25, 08:47:38
xx Mageia instalacja (1)
2020-02-24, 14:43:32
xx Zlecę skrypt w bashu (0)
2020-02-19, 14:07:39
xx Nadawanie praw katalogom takich, jak nazwa usera (4)
2020-02-17, 14:15:18
xx Fedora na laptopie HP 15-bs152nw brak wifi (44)
2020-02-16, 12:17:18
xx Komputer do nauki linuxa (10)
2020-02-15, 07:03:28
xx Patronat serwisow internetowych. (1)
2020-02-13, 00:13:24
xx Xfce-terminal v 0.8.7.4 - jak ustawić wklejanie skopiowanego tekstu? (3)
2020-02-12, 18:59:24
xx HD ISO, jak odzyskać starsze pliki (6)
2020-02-12, 10:54:31

Autor Wątek: Sprawdzanie pisowni w Kile  (Przeczytany 6954 razy)

Offline Marcin Abram

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Sprawdzanie pisowni w Kile
« dnia: 2009-02-15, 19:24:37 »
Mam zainstalowane Kile na Ubuntu 8.10. Domyślne kodowanie w systemie to utf-8. W programie Kile bez problemów tworze dokumenty po polsku. Występuje jednak błąd przy próbie sprawdzenia poprawności polskiej pisownie ("Narzędzia/Poprawność pisowni..."). Nie rozpoznaje polskich znaków. Również podpowiedzi błędnych wyrazów nie mają polskich czcionek.

Dodam, że w całym systemie wszędzie polskie znaki mam. Mam zainstalowane ipolish, ispell, aspell, wszystkie pakiety polonizacyjne do latexa, kile.

Podejrzewam, że Kile przy sprawdzaniu pisowni odpala ispell (wyrzucenie słownika w ispellu sprawia, że Kile zgłasza błąd, że nie ma dostępu do potrzebnych plików). Sprawdziłem, że słownik do ispella (polish.aff i polish.hash) jest kodowany w ISO. Ściągnąłem z http://www.sjp.pl/slownik/ort/ słownik do ispella. Sprawdziłem, że też jest kodowany w ISO. Zmieniłem więc komendą:
       iconv -f ISO-8859-2 -t UTF-8 polish.all -o polish.all_pl
       iconv -f ISO-8859-2 -t UTF-8 polish.aff -o polish.aff_pl
kodowanie plików na utf8. Probowałem stworzyć plik polish.hash poleceniem:
       buildhash polish.all_pl polish.aff_pl polish.hash
Zgłosiło mi jednak tysiące błędów w stylu:
       Word 'słowo_z_polskim_znakiem' contains illegal characters

Szukałem w internecie, czy można gdzieś pobrać słowniki do ispella w kodowaniu utf-8. Znalazłem jednak tylko w ISO.

Pytanie: w jaki sposób rozwiązać problem ze sprawdzaniem pisowni w Kile? Czy trop, że to wina ispella jest dobry? Jeśli tak to w jaki sposób zmusić ispella do pracy z plikami kodowanym w utf-8. I jak stworzyć słownik polish.hash w kodowaniu utf-8, a nie ISO?