Nowe posty

Autor Wątek: Problem z kodowaniem w KDE 3.5  (Przeczytany 10164 razy)

grzesiekjakistam

  • Gość
Problem z kodowaniem w KDE 3.5
« dnia: 2008-12-30, 20:00:55 »
Witam!

Dzisiaj coś mi się stało z KDE 3.5 otóż zawsze miałem w napisach ęąćźż itd a teraz zamiast tego mam kwadraciki :/ próbowałem w centrum sterowania ustawić kodowanie na cp1250,utf8 ale na nic :/
wciąż mam te "kwadraciki" :/ próbowałem ustawić w Konqueror na "użyj kodowanie domyślne do języka" nic nie dało potem zmienił na cp1250,utf8 i też nic :/ jestem bezradny i nie wiem co robić dalej :/
jeszcze wczoraj było wszystko OK a nigdzie nie grzebałem... problem występuje wszędzie... :/
w centrum sterownia mam język polski (jako domyślnie oczywiście,klawiatura PL)
proszę o pomoc :)
używam sytemu Sidux..

arctgx

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #1 dnia: 2008-12-30, 20:04:44 »
Wygląda na to, że klawiatura jest w porządku, bo angielska nie dawałaby kwadracików. Problem może siedzieć w wyborze czcionki, która nie obsługuje danego kodowania.

W Knoppiksie, w domyślnym KDE, czcionki były bodajże w UTF-8 (locale równe pl_PL.UTF-8), a kodowanie (po wybraniu lang=pl na starcie) w iso-8859-2 (locale pl_PL). Trzeba było pogodzić te dwie rzeczy: albo zmienić locale na unikodowe, albo w kcontrol czcionki środowiska na iso.

grzesiekjakistam

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #2 dnia: 2008-12-30, 20:17:40 »
no już tak próbowałem i na nic :/
może jakiś inny sposób ???

arctgx

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #3 dnia: 2008-12-30, 22:24:28 »
Cytat: grzesiekjakistam
no już tak próbowałem
Jak dokładnie? Podmieniłeś wystarczająco dużo czcionek?

Co mówi locale?

U mnie w kcontrol jest menu Wygląd i motywy > Czcionki.

matulik

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #4 dnia: 2008-12-31, 00:58:50 »
Może spróbuj w centrum sterowania KDE zmienić czcionki na inne. Ja sam nie używam tych które były ustawione standardowo bo mi się trochę krzaczyły.

grzesiekjakistam

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #5 dnia: 2008-12-31, 10:03:26 »
jak ja ustawię nie wiadomo jaką czcionkę to zawsze mam takie same kwadraciki.. tzn. czcionka się w ogóle nie zmienia :/ dziwi mnie że jak wezmę czcionkę bardziej azjatycką to mimo zmiany wciąż mam normalne litery tylko że zamiast ęą itd. mam kwadraciki :/  kombinowanie z tymi czcinkami u mnie nic nie daje :/

matulik

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #6 dnia: 2008-12-31, 11:12:01 »
Pamiętaj że musisz zmienić wszystkie czcionki w centrum sterowania>wygląd i motywy>czcionki.

Przy wybieraniu możesz sprawdzić czy ta czcionka ma akurat polskie znaki. Jest tam bardzo ładny przykład "Zażółć Gęślą Jaźń" który pokaże ci czy wybrana czcionka obsługuje te znaki.

grzesiekjakistam

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #7 dnia: 2009-01-01, 10:45:56 »
"Przy wybieraniu możesz sprawdzić czy ta czcionka ma akurat polskie znaki. Jest tam bardzo ładny przykład "Zażółć Gęślą Jaźń" który pokaże ci czy wybrana czcionka obsługuje te znaki."

jak piszę to niby są polskie znaki a jak zresetuję komputer to znów mam te kwadraciki :/
zmiana czcionek nic nie daje :/

Brix

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #8 dnia: 2009-01-01, 18:59:49 »
W takim razie zrób może absolutnie standardowy test, czyli załóż nowe konto (nowego użytkownika) i zaloguj się na nie (a przy okazji sprawdź, czy np. nie kończy się pojemność dysku). Jeżeli na tym koncie będzie wszystko OK, najprawdopodobniej namieszało się coś w ustawieniach KDE po stronie usera i najprostszym wyjściem jest skasowanie jego ustawień czcionek lub w ogóle wszystkich.

grzesiekjakistam

  • Gość
Problem z kodowaniem w KDE 3.5
« Odpowiedź #9 dnia: 2009-01-02, 11:44:30 »
Witam!

utworzyłem nowe konto i niestety znów miałem te kwadraciki :/
Zainstalowałem najnowszego Siduxa i jest wszystko jest ok ;) przynajmniej jak naradzie :)
widocznie rzeczywiście coś się stało z tym moim KDE :/)
dziękuję za chęć udzielenia mi pomocy ;)
pozdrawiam ;)