Nowe posty

xx Jak usunąć kilka dowiązań twardych jednym poleceniem. (3)
2019-06-14, 12:12:10
xx Skrypt sprawdzający miejsce na dysku (1)
2019-06-13, 13:55:00
xx Samba server (3)
2019-06-10, 17:01:44
xx Skrypt tworzący użytkownika (3)
2019-06-07, 17:11:55
xx Jaki serwis komp. we Wrocławiu (0)
2019-06-06, 12:39:23
xx serwer wydruku (1)
2019-06-04, 13:57:58
xx mod_security i roundcube (0)
2019-05-27, 14:27:03
xx Touchpad po pewnym losowym czasie przestaje reagować (33)
2019-05-27, 10:14:21
xx [ROZWIĄZANY] przygotowanie zeskanowanego pdf do OCR (6)
2019-05-24, 14:46:43
xx Przydatne Linki (1)
2019-05-23, 18:05:04

Autor Wątek: Dziwny problem z karta dzwiekowa.Prosze o pomoc.  (Przeczytany 4482 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Dziwny problem z karta dzwiekowa.Prosze o pomoc.
« dnia: 2008-10-31, 14:57:57 »
siema.Mam problem z dzwiekiem na slacku 12.1.Juz po uruchomieniu kde pojawia sie komunikat o nastepujacej tresci:
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such file or directory)
The sound server will continue, using the null output device.
I to jest dziwne bo w amaroku jest dzwiek i moge smialo sluchac muzy i tylko w amaroku.A tak to dzwiek nie dziala ani w sys ani nigdzie indziej.Konfigurowalem dzwiek na alsaconfig i wszystko poszlo dobrze.Tylko ze dzwieku nie ma i wywala ten powyzszy blad.Po wydaniu komendy lspci  o to co pokazuje mi odnosnie karty dzwiekowej (zintegrowana na plycie):
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
wiec wszystko niby jest dobrze.Wiec gdzie moze byc problem? Prosze  o pomoc.Jak to jakis banal to sie nie smiejcie ze mnie 2 lata nie uzywalem linuksa a z dzwiekiem problemow nigdy nie mialem.

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Dziwny problem z karta dzwiekowa.Prosze o pomoc.
« Odpowiedź #1 dnia: 2008-10-31, 16:19:41 »
Sprawdź jak rzecz wygląda bez serwera (aRts zapewne, skoro to KDE). Wyłącz go np. za pomocą kcontrol. Najprawdopodobniej programy, które swoje wyjście kierowały do serwera, teraz spróbują do domyślnego wejścia karty dźwiękowej.

Sprawdź czy możesz jednocześnie używać dwóch programów dźwiękowych. Jeśli nie, szukaj o dmix i programowym miksowaniu - niedawno był nawet tu taki temat. Może być tak że serwer próbuje otworzyć zajęte już urządzenie dźwiękowe. Ale co na samym starcie mogłoby je blokować?

Zajrzyj do /proc/asound/pcm. Jeśliby aRts używał emulacji OSS, sprawdź czy moduł od niej jest załadowany:
lsmod | grep '^snd.*.oss '
.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Dziwny problem z karta dzwiekowa.Prosze o pomoc.
« Odpowiedź #2 dnia: 2008-11-04, 10:32:28 »
siemka.Po zabawie kmixem i aumixem udalo mi sie po restarcie kompa uruchomic dzwiek.Moja radosc byla niestety krotka gdyz po kolejnym uruchomieniu kompa wszystko wrocilo do "normy",znow pojawila sie ta wiadomosc o errorze i dzwieku nie bylo:(.Tak jak pisales ,wylaczylem dzwiek w kcontrol i tez nic to nie dalo.Jesli chodzi teraz o dzwiek to raz jest a raz go nie ma (Czesciej zdecydowanie nie ma).Mozliwe ze cos blokuje urzedzenie dzwiekowe przy starcie,tylko co o to jest pytanie..

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Dziwny problem z karta dzwiekowa.Prosze o pomoc.
« Odpowiedź #3 dnia: 2008-11-06, 18:37:27 »
Polecenie fuser pokazuje listę procesów używających danego pliku.

fuser -v /dev/snd/pcmC0D* /dev/dsp*
Opcja -v da więcej informacji. W przykładzie wyżej wrzuciłem Tobie potrzebne pliki urządzeń dźwiękowych (z Alsy i OSS). Uruchom najlepiej jako root i zobacz czy jakiś proces je okupuje.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam