Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (7)
Wczoraj o 13:28:28
xx badblocks nie sprawdza dalej. (3)
2019-04-23, 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: Automatyczne rozjaśnianie wyświetkacza LCD w laptopie  (Przeczytany 3603 razy)

Offline roobal

  • Users
  • Guru
  • *****
  • Wiadomości: 2052
    • Zobacz profil
Witam!

Korzystam z Debiana Lenny, kilka dni temu miałem aktualicję systemu, gdzie między innymi zaktualizował się xserwer do wersji

roobal@debian:~$ apt-cache policy xserver-xorg xorg
xserver-xorg:
  Zainstalowana: 1:7.3+12
  Kandydująca: 1:7.3+12
  Tabela wersji:
 *** 1:7.3+12 0
        990 http://ftp.pl.debian.org lenny/main Packages
        100 /var/lib/dpkg/status
xorg:
  Zainstalowana: 1:7.3+12
  Kandydująca: 1:7.3+12
  Tabela wersji:
 *** 1:7.3+12 0
        990 http://ftp.pl.debian.org lenny/main Packages
        100 /var/lib/dpkg/status
roobal@debian:~$
Moim problemem jest to, że ekran rozjaśnia się automatycznie do maksymalnej jasności, np. po zalogowaniu się do systemu i załadowaniu środowiska graficznego (używam GNOME) lub gdy na przykład aktualizuję system i w tym czasie idę sobie coś zjeść, natomiast gdy ruszę tylko myszką ekran rozjaśnia się na maksa, gdy znowu odejdę od komputera ekran się przyciemnia automatycznie, działa to na zasadzie włączania i wyłączania się wygaszacza ekranu lub tak jak w telefonach komórkowych, gdy nic się nie robi wyświetlacz się przyciemnia, gdy tylko wciśnie się dowolny klawisz wyświetlacz się podświetla.

Jest to dla mnie problem, gdyż zawsze jasność ekranu mam na minimum a i tak jest dla mnie za jasny znowu maksymalna jasność strasznie razi po oczach.

Taki sam miałem przypadek, gdy testowałem Ubuntu 8.04 oraz OpenSUSE 11.0, gdzie sa nowsze wersje Xservera i był ten sam efekt i cieszyłem się, że w Debianie tego nie mam i miałem nadzieje, że to nie nastąpi.

Na OpenSUSE używałem KDE 3.5 i znalazłem tam opcję, gdzie można było włączać oraz wyłączać ten efekt automatycznego przyciemniania/rozjaśniania ekranu, ale ta opcja nie bardzo dawała efekt, gdyż pomimo jej wyłączenie dalej było to samo (i właśnie dlatego nie lubię KDE co by się w nim nie zrobiło graficznie to i tak nie zadziała:P:P).

Ponieważ używam GNOME może ktoś wie jak to wyłączyć w GNOME (może zadziała)?

Używam również Fluxboksa i na nim tego efektu nie ma i właśnie dlatego doszukuję się wyłączenia tej funkcji w Gnome.

Wrazie wu jeszcze mój xorg.conf

roobal@debian:~$ cat /etc/X11/xorg.conf 
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
Option "AddARGBGLXVisuals" "On"
Option "XAANoOffscreenPixmaps" "true"
Option "RenderAccel" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Modes "1280x800"
Option "TripleBuffer" "true"
Option "no GLXFBConfig for depth 32"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "true"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
Option "AIGLX" "true"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
roobal@debian:~$
Pozdrawiam!

Offline roobal

  • Users
  • Guru
  • *****
  • Wiadomości: 2052
    • Zobacz profil
Automatyczne rozjaśnianie wyświetkacza LCD w laptopie
« Odpowiedź #1 dnia: 2008-07-22, 21:02:53 »
Problem juz rozwiazany, zeby pozbyc sie tego problemu w Gnome, nalezy wejsc w ustawienia zasilania i tam sa opcje automatycznego przyciemniania.

W KDE bylo to samo ale nie dawalo to zadnego efektu (zreszta jak wszystkjo co w KDE i dlatego pisalem, ze nie lubie KDE:P).

Pozdrawiam!