Nowe posty

Autor Wątek: Źółte i fioletowe pasy przy bootowaniu linuxa  (Przeczytany 5639 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« dnia: 2008-05-25, 22:21:50 »
Nie wiem, jak to opisać, więc od razu zapodam nagrany przeze mnie filmik:

http://pl.youtube.com/watch?v=ZHEHajZ6Jp0

Podobnie zachowuje się bootowalny OpenSUSE 10.3.. :(
Myślałem, że to może wina ubuntu 8.04, więc ściągnąłem OpenSUSE Live CD. 10.3, ale i ta dystrybucja się nie włącza :(
Nawet Ubuntu 8.04 po zainstalowaniu pod windowsem nie daje się uruchomić (no, w trybie awaryjnym działa)..
Mój sprzęt:
Intel Core2 Duo E6300
GeForce 7900GT 256MB
1GBoR

edit:
Wszystkie płyty są sprawne w 100%, na laptopie oba pingwinki startują bez problemu :/

edit:
A tak prezentuje się OpenSUSE
http://img294.imageshack.us/img294/9508/dsc00074zf9.jpg

edit:
Świetnie, 109 wyświetleń i nikt nie potrafi rozwiązać problemu :(
To się linuksem nacieszyłem :/

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #1 dnia: 2008-06-06, 09:57:58 »
Cześć.

To wygląda jakby to był problem ze zbyt dobrą kartą graficzną i zbyt słabym monitorem lub na odwrót. U mnie na starym PC Linux trochę dziwnie wygląda jeśli ustawię rozdzielczość 1280x1024 w 85Hz (jakieś pasy, nie te kolory, rozmazanie) ale aż takie rzeczy się nie dzieją. Grafika to rocznik 2000 a monitor 2003.

Napisz z jakimi rozdzielczościami i częstotliwościami monitora uruchamiałeś Linuksa.
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #2 dnia: 2008-06-06, 19:15:33 »
Pod rozdzielczościami 1024x768 i 800x600 efekt jest ten sam, openSUSE nawet pod VESA (czy jakoś tak) nie startuje :/

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #3 dnia: 2008-06-06, 20:07:49 »
Dzięki załączonemu filmikowi przynajmniej można zobaczyć, na czym polega problem.

Następny taki filmik mógłbyś robić ze statywu lub chociaż kamerką unieruchomioną czymś sztywnym ;)

Pod koniec filmu trudno mi ocenić czy paski są nadal. Jeśli był to obraz, na którym nie widać problemu, to po co nim zaprzątać uwagę...

Gorzej jednak z Twoim opisem, a dziwisz się że nikt nie odpisuje. Co znaczy "pod rozdzielczościami 1024x768 i 800x600"? Czy są to rozdzielczości, które udało Ci się uzyskać i mimo to są paski, czy może zadeklarowałeś je gdzieś (w jaki sposób?) i mimo to nic nie widać? Rozróżnij też działanie sterownika framebuffera, który obsługuje tekstowe komunikaty na starcie od sterownika Xorg, który ładuje się później (rzadko kiedy jest to ten sam sterownik). Obu z nich deklarujesz rozdzielczości w inny sposób.

Zainteresuj się plikiem /etc/X11/xorg.conf, w którym możesz narzucić pewne parametry pracy monitora oraz wybrać jeden z trzech co najmniej sterowników dla Nvidii. Skoro mimo pasków widzisz obraz, możesz edytować ten plik i restartować Xorg (w Ubuntu to chyba invoke-rc.d xdm restart). Nic nie szkodzi, byś eksperymentował bez instalacji, a kopie xorg.conf zapisywał gdzieś na zewnątrz i potem użył dobrej.

Jeśli jesteś początkującym użytkownikiem, poczytaj o montowaniu i edytorach tekstu działających w konsoli, byś wiedział jak pracować.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #4 dnia: 2008-06-06, 20:28:02 »
Cały czas są te pasy, pod koniec filmiku również.
Rozdzielczości ustawiałem przed uruchomieniem systemu z płytki, przy menu Uruchom/hard disk/test cd - czy coś takiego.
Zainstalowany pod windowsem ubuntu też nie działa (też są te pasy)

Kompletnie nie mam dostępu do pliku /etc/X11/xorg.conf.
Ubuntu 8.04 po normalnym zainstalowaniu na twardym dysku też nie daje się uruchomić.

I tak, jestem początkującym, a nawet coś przed tym, bo nie mam jak uruchomić linuksa, żeby się nim zacząć bawić x|

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #5 dnia: 2008-06-06, 23:43:32 »
Obawiam się, że chcąc spróbować Ci wytłumaczyć z wyjaśnieniem, co zrobić i dlaczego, poświęciłbym kawał czasu i nie wiadomo na ile skutecznie. Trochę niefajnie, że na samym początku problem z obsługą lub działaniem sprzętu zmusza Cię do skoku na głęboką wodę. Ja bym spróbował na twoim miejscu jeszcze jakiejś dystrybucji odpalnoej jako live (bez instalacji) w nadziei na to, że przynajmniej w środowisku graficznym (Xorg) sprzęt zostanie prawidłowo skonfigurowany.

Dostęp do konfiga Xorg masz, tylko musisz zrobić to w konsoli. Po uruchomieniu Ubuntu z CD masz (za pomocą F6) dostęp do linii parametrów jądra, która wygląda mniej więcej tak:

file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
Wywal z niej "quiet splash" i wstaw na miejsce tego casper-udeb/runlevel=S, by Ubuntu uruchamiało się bez paska graficznego i w tzw. trybie single, i klepnij Enter.

Nietypowy jest, jak widzę, ten tryb single w Ubuntu. Zamiast konsoli od razu, możesz ją dopiero wybrać z menu (root shell). Wtedy powinieneś dostać konsolę i znak zachęty do wpisania polecenia.

Polecenie
nano /etc/X11/xorg.conf
może być znośnym dla Ciebie sposobem na edycję tego pliku. Ale szczegóły z braku czasu pozostawiam Tobie lub komuś może.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #6 dnia: 2008-06-14, 19:01:05 »
Cytat: arctgx
(...) Po uruchomieniu Ubuntu z CD masz (za pomocą F6) dostęp do linii parametrów jądra, która wygląda mniej więcej tak:

file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
(...)
Kliknąłem F6
Wybrałem
file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
Tapnąłem ENTER i Ubuntu zaczął się ładować, po chwili znowu te same pasy... :(

Linux Zenwalk Llive 5.0.1 nie działa.

Sorry, że dopiero teraz odpowiadam, ale na prawdę nie miałem wcześniej czasu :/

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Źółte i fioletowe pasy przy bootowaniu linuxa
« Odpowiedź #7 dnia: 2008-06-14, 19:25:14 »
Widzę, że i tak nie próbowałeś przeczytać ze zrozumieniem mojego posta, tylko klepnąć widoczny kod i czekać na cud. Nie widzę sensu pisania czegokolwiek dalej. Niech kto inny się potrudzi, jeśli ma ochotę.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam