Nowe posty

Autor Wątek: Kamerka Logitech QuickCam Express Plus  (Przeczytany 3060 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Kamerka Logitech QuickCam Express Plus
« dnia: 2008-05-25, 18:38:29 »
Witam wszystkich
i jako świeżo upieczony użytkownik Linuksa
(z ponad 10-letnimi nawykami z Redmond :(
proszę o pomoc!

Na początek garść szczegółów, które na pewno będą pomocne:

1. uname -a
Linux 2.6.22.17-0.1-default #1 SMP 2008/02/10 20:01:04 UTC i686 i686 i386 GNU/Linux
(openSUSE 10.3)

2. Sterowniki do mojej kamerki, które chcę zainstalować:
USB Quickcam Video Camera driver v. 0.6.6
(qc-usb-0.6.6)

3. lsusb:
Bus 001 Device 002: ID 046d:092f Logitech, Inc.
(Logitech QuickCam Express Plus)

4. /sbin/lsmod | grep -i usb
usbcore               124268  2 uhci_hcd

Z tego co wyczytałem w necie
moja kamerka powinna działać na w/wym. sterach.

Przebieg instalacji wygląda następująco:

darcjo@:~/Desktop/qc-usb-0.6.6> ./quickcam.sh
-=- Logitech QuickCam USB camera driver installer -=-
Hello! I am the (hopefully) easy-to-use, fully automated
qc-usb driver installation script.
At the moment, this is experimental, and if it doesn't work,
don't hesitate to quit this with Ctrl+C and install the
driver manually.

The driver is provided in source code form, so it has to be
compiled. This should happen automatically, but it does mean
that there are some steps required before installation.

You also need to know "root" user password to test and
install the driver.

Basically you need only to keep hitting Enter whenever you
see this prompt: --->. Sometimes you're asked root password.
Pay special attention to lines beginning with [!].
It means that some trouble has been detected.

To most important location is the path to your kernel source
or headers. This can be guessed, but you can specify it by
giving it as an argument to this script like this:
        ./quickcam.sh LINUX_DIR=/usr/src/linux

If you haven't done it yet, now it would be a good moment to
take a look at file README.

Next I'm going to check if you have some important programs installed
and if they and the kernel are of suitable version.
Press Ctrl+C to quit, Enter to continue --->

/home/darcjo/Desktop/qc-usb-0.6.6/quickcam.sh
/usr/bin/whoami
/bin/su
/bin/ls
/bin/cat
/usr/bin/gcc
/usr/bin/gcc
/usr/bin/make
/usr/bin/grep
/usr/bin/egrep
/usr/bin/awk
/usr/bin/sed
/usr/bin/tail
/usr/bin/head
/usr/bin/install
/usr/bin/ld
/bin/uname
/usr/bin/tr
/usr/bin/xawtv
/usr/bin/xdpyinfo
/bin/dmesg
/usr/bin/wc

which: no realpath in (/opt/kde3/bin:/home/darcjo/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
which: no realpath in (/usr/local/bin)

/usr/bin/readlink
gcc version: Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.2.1 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --program-suffix=-4.2 --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=i586-suse-linux
gcc version 4.2.1 (SUSE Linux)
gcc version: Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.2.1 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --program-suffix=-4.2 --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=i586-suse-linux
gcc version 4.2.1 (SUSE Linux)
Make version: GNU Make 3.81
Linker version: GNU ld (GNU Binutils) 2.17.50.20070726-14 (SUSE Linux)
Kernel compiler: gcc version 4.2.1 (SUSE Linux)

[!] Kernel compiler and gcc seem to be different versions.
Instead, they should be the same. If you have many compilers
installed, you can specify the correct one with command (in bash)
        export CC=kgcc
before trying to install the driver. Replace kgcc with the command
required for compiling kernels (kgcc is often used in Red Hat systems).
WARNING: If you press Enter, I'll try to continue anyway,
but this probably will fail. You SHOULD press Ctrl+C now.
Press Ctrl+C to quit, Enter to continue --->


Wciskam Ctrl+C i ... nie wiem co dalej :(

Jak doprowadzić do zgodności wersji "Kernel compiler" i "gcc"?
Co trzeba zrobić (proszę o szczegółową podpowiedź)?

I o co chodzi z "no realpath"?

Z góry dzienx i pzdr!

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Kamerka Logitech QuickCam Express Plus
« Odpowiedź #1 dnia: 2008-05-26, 08:11:45 »
a próbowałeś po prostu wcisnąć ENTER zamiast Ctrl+C ?
Może akurat pójdzie ;-)

Edit:
Osobiście używam tego sterownika ;-)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Kamerka Logitech QuickCam Express Plus
« Odpowiedź #2 dnia: 2008-05-26, 19:22:51 »
Cytat: chmooreck
a próbowałeś po prostu wcisnąć ENTER zamiast Ctrl+C ?
Może akurat pójdzie ;-)
No to spróbowałem :O

Oto dalszy ciąg z terminala:

Press Ctrl+C to quit, Enter to continue --->

więc chmooreck wciskam Enter...

Looking for more necessary programs...
which: no depmod in (/opt/kde3/bin:/home/darcjo/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
Found program /sbin/depmod
which: no insmod in (/opt/kde3/bin:/home/darcjo/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
Found program /sbin/insmod
which: no rmmod in (/opt/kde3/bin:/home/darcjo/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
Found program /sbin/rmmod
which: no modprobe in (/opt/kde3/bin:/home/darcjo/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
Found program /sbin/modprobe
Found program /bin/mount
Found program /usr/bin/lsusb
depmod version: module-init-tools 3.3-pre11
insmod version: module-init-tools version 3.3-pre11
rmmod version: module-init-tools version 3.3-pre11
modprobe version: module-init-tools version 3.3-pre11
Checking whether we're root... darcjo
Checking for driver source code...
Checking for write permission...

Previous round done. Now checking if you have kernel source installed.
Press Ctrl+C to quit, Enter to continue --->

which: no depmod in (/opt/kde3/bin:/home/darcjo/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
awk: linia poleceń:1:
fatalny błąd: nie można otworzyć pliku `/lib/modules/2.6.22.17-0.1-default/build/include/linux/version.h' do czytania (Nie ma takiego pliku ani katalogu)
/bin/sh: line 0: [: -ge: unary operator expected
/bin/sh: line 0: [: -ge: unary operator expected
Kernel source directory: /lib/modules/2.6.22.17-0.1-default/build
[!] Can not find kernel source or even headers.
Make sure that they are installed (install with e.g. rpm or apt-get
if necessary) and ensure that you have read rights to the files.
WARNING: If you press Enter, I'll try to continue anyway,
but this probably will fail. You SHOULD press Ctrl+C now.
Press Ctrl+C to quit, Enter to continue --->


No i co dalej?

Dodam tylko, że instalację systemu przeprowadziłem ze sprawdzonej płyty DVD
nie ingerując w automatyczne ustawienia.
Teraz okazuje się, że jakiś problem ze znalezieniem kernela :O
What's matter?