Nowe posty

Autor Wątek: iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5  (Przeczytany 22519 razy)

kopin

  • Gość
iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5
« Odpowiedź #15 dnia: 2008-06-25, 12:42:23 »
Witam. Ja też miałem problem z modemem Option Icon Globetrotter... kiedyś. Taraz bardzo łatwo łączę się z netem  za pomocą tego modemu... a mianowicie jest taki programik icon_switch, który zmienia tryb pracy modemu (z pamięci USB na modem) a następnie używam programiku GlobalGPRS do połączenia się ze światem zewnętrznym... oczywiście PIN wyłączyłem, gdyż długie oczekiwanie na autoryzację pinu i zalogowanie do sieci powodowało niełączenie się z netem. Zamiast programu GlobalGPRS można użyć innego programiku, ale z kppp miałem problemy.... Pozdrawiam.

kopin

  • Gość
iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5
« Odpowiedź #16 dnia: 2008-06-25, 17:49:47 »
Witam ponownie:) Podepnę się pod wątek bo dotyczy on OPTION ICON. Łącze się z iPlusem tak jak napisałem wcześniej i udostępniam połączenie internetowe na drugiego kompa z XP-kiem. Wszystko jest OK jak najpierw połączę się z iplusem a potem włączę kartę sieciową (czyli wyłączam tryb roamingu i ustawiam IP w Ustawieniach Sieci). Jeżeli natomiast mam włączoną kartę (eth0) i kliknę na łączenie się z iPlusem to pomimo poprawnym połączeniu się - nie mam dostępu do internetu:( - Reasumując - muszę wyłączyć eth0 żeby mieć połączenie z internetem. Może macie jakiś pomysł na ten problem. Pozdrawiam.

Tyszu

  • Gość
iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5
« Odpowiedź #17 dnia: 2008-06-26, 07:20:16 »
Na moje oko zrób tak:

W sytuacji pierwszej jak już uruchomisz net daj jako root nastepujące komendy i wyniki daj tutaj:

1. ip r s
2. cat /etc/resolv.conf

Nastepnie wywołaj sytuację drugą, czyli odpal iplusa z włączonym eth0 i komendy powtórz. Wyniki oczywiscie daj tutaj.

Jak to nic nie pomoże to pokombinujemy dalej :]

kopin

  • Gość
iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5
« Odpowiedź #18 dnia: 2008-06-26, 16:31:02 »
Witam. Właśnie sprawdziłem ustawienia netu i tak:
przy wyłączonej sieciówce i działającym internecie mam:

piotr@stacjonarny ~ $ ip r s
10.64.64.64 dev ppp0  proto kernel  scope link  src 77.115.158.26
default dev ppp0  scope link
piotr@stacjonarny ~ $ cat /etc/resolv.conf
nameserver 212.2.96.51
nameserver 212.2.96.52

natomiast przy włączonej karcie sieciowej otrzymuję:

piotr@stacjonarny ~ $ ip r s
10.64.64.64 dev ppp0  proto kernel  scope link  src 77.113.116.115
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1
169.254.0.0/16 dev eth0  scope link  metric 1000
default via 192.168.1.1 dev eth0  scope link  metric 100
piotr@stacjonarny ~ $ cat /etc/resolv.conf
nameserver 212.2.96.51
nameserver 212.2.96.52

no i net mi nie działa. Nie bardzo wiem jak to zrobić żeby działało.

Tyszu

  • Gość
iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5
« Odpowiedź #19 dnia: 2008-06-27, 07:13:53 »
Kopin , no to mamy jasność, bez włączonej sieciówki domyślna brama jest ustawiona na Iplusa mówi o tym ta linijka:

default dev ppp0  scope link

natomiast jak najpierw włączysz sieciówkę a potem iplusa to bramę masz ustawioną na kartę sieciową:

default via 192.168.1.1 dev eth0  scope link  metric 100


Rozwiązań jest kilka:

1. Jeśli ten GlobalGPRS to jakiś skrypt to musisz gdzieś do niego wstawić te dwie linie:
ip route del defaultl
ip route add default via ppp0

2. Jeśli GlobalGPRS nie jest skryptem to może ustawienia karty sieciowej są konfigurowane jakimś skryptem, wtedy te dwie linie wstawiasz do niego.

3. Nie wiem jakiej dystrybucji uzywasz, ale są spore szanse że w /etc/init.d/  masz plik "network" jeśli tak, to tam też możesz wprowadzić zmiany.


Jak nie czujesz się pewnie, to napisz jakie masz distro i daj wiecej info na temat GlobalGPRS'a.

Pozdrawiam

kopin

  • Gość
iPlus USB Option Icon 225 HSDPA 7,2 +fedora 5
« Odpowiedź #20 dnia: 2008-07-01, 21:59:08 »
Witam ponownie. Rozwiązałem problem z łączeniem iPlusa i brakiem netu przy włączonej sieciówce. Dzięki odpowiedzi "Tyszu" szybko znalazłem mój błąd... a mianowicie w ustawieniach sieci wpisywałem bramę domyślną na 192.168.1.1 - a nie powinienem nic wpisywać :) Dzięki za poświęcony czas.