Nowe posty

Autor Wątek: Problem z Pythonem w Linuxie  (Przeczytany 8339 razy)

linux1224

  • Gość
Problem z Pythonem w Linuxie
« dnia: 2008-05-10, 20:16:06 »
Witam, niedawno zainstalowalem Linuxa Mandrive i probóje korzystac na tym systemie z Pythona. Uruchamiam konsole, pythona ale nie mogę wczytac skryptu nie wiem dla czego.
Jak zacząć pisac program i jak uruchomic go w linuxsie. Na windowsach nie mialem takich problemow,ale chciałbym nauczyc sie korzystac w pelni z Linuxa. Proszę o szybkie odpowiedzi, dzieki.

benyo

  • Gość
Problem z Pythonem w Linuxie
« Odpowiedź #1 dnia: 2008-05-10, 21:32:56 »
piszesz w konsoli:

python nazwaskryptu

lub po prostu

nazwaskryptu

jesli skrypt ma wpisane w pierwszej linii
#!/usr/bin/python
i ustawione odpowiednie prawa plikow czyli do uruchomienia.

Nic wiecej nie potrzeba

linux1224

  • Gość
Problem z Pythonem w Linuxie
« Odpowiedź #2 dnia: 2008-05-10, 21:45:33 »
Oto tekst mojego :
scriptu #!/usr/bin/python
print "Witaj świecie"

A jego nazwa to chmod755 polak.py
W jego prawach dostepu dalem wykonywalny,ale dalej ten sam blad:
/polak.py
  File "", line 1
    ./polak.py
    ^
SyntaxError: invalid syntax

Błagam pomocy co jeszcze moge zrobic czekam na odpowiedzi

52aqir

  • Gość
Problem z Pythonem w Linuxie
« Odpowiedź #3 dnia: 2008-05-10, 22:30:01 »
bo tego nie masz odpalać w konsoli pythona tylko w 'normalnej' konsoli, a mam dziwne wrażenie, że robisz to tak:

$python
>>> ./polak.py
// i tu wywala Ci błąd //

a ma być:
$ ./polak.py - czyli bez wchodzenia do konsoli pythona

linux1224

  • Gość
Problem z Pythonem w Linuxie
« Odpowiedź #4 dnia: 2008-05-11, 07:52:04 »
Dzieki za odpowiedzi cały czas zblizam sie do rozwiazania glupkowatego problemu ale dalej nic.  Teraz gdu uruchamiam plik w konsoli wyskakuje taki bład:
bash: ./wojtek.py: Nie ma takiego pliku ani katalogu

Co teraz może być źle

linux1224

  • Gość
Problem z Pythonem w Linuxie
« Odpowiedź #5 dnia: 2008-05-11, 08:01:37 »
Dobra juz wszystko wiem musiałem przejs konsolom do pulpitu i tam wczytac polaka. Wystarczylo w atrybutach zaznaczyc wykonywalny i wszystko gra dzięki za pomoc. Pozdro