Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (7)
Wczoraj o 13:28:28
xx badblocks nie sprawdza dalej. (3)
2019-04-23, 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: Problem z Kadu  (Przeczytany 5824 razy)

Offline Rafał Lewandowski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 154
    • Zobacz profil
Problem z Kadu
« dnia: 2005-05-25, 12:34:07 »
witam
Nie moge sobie z tym poradzić i proszę Was o pomoc.
Zainstalowałem httpd-2.0.54 + php-4.3.3+ mysql-4.0.23
Do tej pory robiłem stronki korystając z usług dostawcy dawał mi miejsce na ww na baze itd. - no ale ambicja - chce mieć na swoim kompie wszytko. Więc przegrałem stronkę, utworzyłem bazę - tabele odpalam stronę i komunikat:

Warning: message_die(includes/page_header.): failed to open stream: No such file or directory in /home/kampa/public_html/includes/functions.php on line 86

Warning: message_die(): Failed opening \\'includes/page_header.\\' for inclusion (include_path=\\'.:/usr/local/apache2/php/lib/php\\') in /home/kampa/public_html/includes/functions.php on line 86
Blad
 
Proba odwolania do nie istniejacego modulu.
 


Warning: message_die(./include/footer.php): failed to open stream: No such file or directory in /home/kampa/public_html/includes/functions.php on line 176

Warning: message_die(): Failed opening \\'./include/footer.php\\' for inclusion (include_path=\\'.:/usr/local/apache2/php/lib/php\\') in /home/kampa/public_html/includes/functions.php on line 176

tam chyba raczej nie ma błędu bo ta strona chodzi na innym serwerze.
Ktoś mi pomoże?
pozdr

Offline Konrad Zapałowicz

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 160
    • Zobacz profil
Problem z Kadu
« Odpowiedź #1 dnia: 2005-05-25, 20:19:48 »
> Warning: message_die(includes/page_header.): failed to open stream: No such file or directory
 > in /home/kampa/public_html/includes/functions.php on line 86

Coś z pliku functions.php probuje się dobrać do czegoś co nie istnieje - masz podaną linijkę w której to robi więc mozesz sobie sprawdzić o co dokładnie chodzi i naprawić. Skoro strona chodzi na serverze \\"providera\\", a u Ciebie nie to zapewne różnica tkwi w konfiguracji.

> Warning: message_die(): Failed opening \\'includes/page_header.\\' for inclusion
 > (include_path=\\'.:/usr/local/apache2/php/lib/php\\') in
 > /home/kampa/public_html/includes/functions.php on line 86
 
Ja mam tą samą wersję Apache jak Ty i nie mam katalogu apache2/php - mam za to lib i modules. Nie wiem jak było w serii 1.3 Apacha, ale może różnica pomiędzy Twoim serwerem a \\"providera\\" to wersja zainstalowanego Apache?


Na mój gust, to powinieneś przejrzeć sobie dokładnie strukturę katalogów. Potem porób symlinki  do np: apache2/php/lib/php i chyba zadziała.

Pozdrawiam,
Bergo

PS: Nie mam doświadczenia durzego w pracy z Apachem, więc radzę bardziej \\"na czuja\\" jak z \\"doświadczenia\\".

Offline Jakub Zalas

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 534
    • Zobacz profil
Problem z Kadu
« Odpowiedź #2 dnia: 2005-05-26, 14:48:14 »
Php szuka plików w niewłaściwych miejscach. Funkcją ini_set() możesz to zmienić. W zmiennej inlcude_path powinny być miejscą gdzie leżą nieznalezione pliki (functions.php itd).

Przykład:
ini_set(\\'include_path\\', \\"/pierwsza/sciezka\\".PATH_SEPARATOR.\\"../inna/sciezka\\" );


Offline Rafał Lewandowski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 154
    • Zobacz profil
Problem z Kadu
« Odpowiedź #3 dnia: 2005-05-31, 09:59:24 »
2005-05-26 14:48:14 gomath napisał:

> Php szuka plików w niewłaściwych miejscach. Funkcją ini_set() możesz to zmienić. W zmiennej
 > inlcude_path powinny być miejscą gdzie leżą nieznalezione pliki (functions.php itd).
 >
 > Przykład:
 > ini_set(\\'include_path\\',
 > \\"/pierwsza/sciezka\\".PATH_SEPARATOR.\\"../inna/sciezka\\" );
 >
 >
-------------------------------------------
sorry że tak późno, ale nie mogłem wcześniej.
Problem jest dość dziwny, poniważ jak odczekam chwilkę albo zrestartuje apache to problem znika?
Nie kumam tego?

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Problem z Kadu
« Odpowiedź #4 dnia: 2005-05-25, 01:43:58 »
Witam! Mam pewien problem z obsługą komunikatora Kadu. Używam Linuxa Fedora Core 3 z powłoką GNOME. Gdy uruchamiam GNOME'a ikonka ładowania Kadu wyświetla się 2 razy - po uruchomieniu wyskakuje okienko Kadu Lock z zapytaniem czy uruchomić Kadu. Jeśli uruchomię to komunikator działa w tle (pojawiają się "dymki" kiedy ktoś przyśle mi wiadomość), ale nie ma ikonki w tray'u. Dopiero ręczne odpalenie pomaga. Czy jest jakiś sposób by temu zaradzić?

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
Problem z Kadu
« Odpowiedź #5 dnia: 2005-05-25, 10:22:34 »
Prawdopodobnie twoj GNOME proboje dwa razy uruchomic kadu, pytanie tylko dlaczego. Czy nie dodawales gdzies przypadkiem opcji uruchamiania kadu przy starcie X'ow ?
Nie wiem jak u Ciebie (ja uzywam KDE) ale gdy ja zamykam KDE przy wlaczonym kadu, to po ponownym wlaczeniu KDE kadu wstaje samo. Natomiast gdy wylacze KDE gdy nie ma wlaczonego kadu to przy odpaleniu KDE kadu samo nie wstanie. Dlatego nie musze sie zbytni martwic o automatyczne uruchomienie kadu (miedzy innymi).

Moze u ciebie jest podobnie, GNOME zapamietuje ktore aplikacje bylu uruchomione w zamykanej sesji i startujac przywraca je automatycznie. Moze masz gdzies wymuszone otwarcie kadu.

Co sie dzieje gdy przy pytaniu o ponowne uruchomienie kadu nie wybierzesz opcji uruchom tylko porzuc ? U mnie systray zachowuje sie wlasciwie (chyba) poniewaz po wymuszeniu powtornego wlaczenia kadu tworzy kolejna ikone z kadu, przy czym rozlacza wczesniejsza wersje kadu aktywujac nowa, ale dwie ikonki z kadu w systrayu mam. Jezeli dam porzuc to jest OK, kadu dziala :)
U Ciebie moze sie pojawiac jakis wewnetrzny blad w systrayu, ktory przy dwukrotnym odpaleniu kadu objawia sie tym, ze ikona kadu z znika, mimo, ze aplikacja jest aktywna (zreszta pisze, ze uruchomienie kolejnej sesji kadu jest niezalecane).

Sproboj wylaczyc kadu i zrestartowac GNOMA, zobacz co sie stanie. Potem zrestartuj GNOMA przy wlaczonym kadu. Zobacz czy cos sie zmienilo.

PS Gdy kadu jest wlaczone towrzy w katalogu domowym usera w podkatalogu .gg plik lock, ktory stanowi info ze jedna wersja kadu jest juz uruchomiona. Sprawdz czy po wylaczeniu kadu (X'ow) ten plik nadal istnieje. To powinno wykluczyc wine kadu, ze nie usuwa tego pliku przez co blokuje swoje ponowne uruchomienie (teoria, ale chyba wlasciwa :) ).

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Problem z Kadu
« Odpowiedź #6 dnia: 2005-05-25, 16:50:24 »
2005-05-25 10:22:34 Xax79 napisał:

> Prawdopodobnie twoj GNOME proboje dwa razy uruchomic kadu, pytanie tylko dlaczego.

Próbuje:)

> Czy nie dodawales gdzies przypadkiem opcji uruchamiania kadu przy starcie X'ow ?

Yyy, nie:) Po prostu zainstalowałem Kadu, gdy je odinstalowałem przez RPM -e wszystko było ok. Po ponownym zainstalowaniu znowu 2 razy się uruchamia (nawet na panelu na którym wyświetlają się ikony uruchamianych aplikacji podczas startu ikona Kadu jest pokazana dwa razy).


> Moze masz gdzies wymuszone otwarcie kadu.

Tego niestety nie wiem, nigdzie takiej opcji nie włączałem:(


 > Co sie dzieje gdy przy pytaniu o ponowne uruchomienie kadu nie wybierzesz opcji uruchom tylko porzuc ?
>  U Ciebie moze sie pojawiac jakis wewnetrzny blad w systrayu, ktory przy dwukrotnym odpaleniu. kadu objawia sie tym, ze ikona kadu z znika, mimo, ze aplikacja jest aktywna (zreszta pisze, ze uruchomienie kolejnej sesji kadu jest niezalecane).
> Sproboj wylaczyc kadu i zrestartowac GNOMA, zobacz co sie stanie. Potem zrestartuj GNOMA przy wlaczonym kadu. Zobacz czy cos sie zmienilo.

No właśnie. Gdy wybieram porzuć, Kadu działa w tle (bez ikony w systray'u, pojawiają się jedynie dymki gdy ktoś napisze wiadomość). Jeśli wybiorę uruchomienie pojawia mi się na pasku zadań 2 razy uruchomione Kadu - Kadu(2). Dopiero gdy wyłączę oba i uruchomię recznie Kadu działa normalnie.
 
 > PS Gdy kadu jest wlaczone towrzy w katalogu domowym usera w podkatalogu .gg plik lock, ktory stanowi info ze jedna wersja kadu jest juz uruchomiona. Sprawdz czy po wylaczeniu kadu (X'ow) ten plik nadal istnieje. To powinno wykluczyc wine kadu, ze nie usuwa tego pliku przez co blokuje swoje ponowne uruchomienie (teoria, ale chyba wlasciwa :) ).

Tego pliku szukam już od dłuższego czasu ale nie mogę go znaleźć:) Szukałem opcją "Wyszkuaj" i nic:) Kadu jest włączone. Szuakełm w /usr/ i nie ma nic. W katalogu użytkownika też. Nie wiem co na to poradzić. Czy w GNOME nie ma czegoś takiego jak Autostart albo Run w rejestrze jak w Windows? To by sprawę uprościło chyba:)