Nowe posty

Autor Wątek: [Debian] pendrive  (Przeczytany 4570 razy)

Offline Andzrej

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
[Debian] pendrive
« dnia: 2005-08-28, 16:46:39 »
przy instalacji xine wypluwa taki błąd:
color.c: In function \\'vscale_chroma_line\\':
color.c:498: error: invalid lvalue in increment
color.c:499: error: invalid lvalue in increment
make[2]: *** [color.lo] Błąd 1
make[2]: Leaving directory `/home/Wes-/Desktop/xine-lib-1-rc4a/src/xine-utils\\'
make[1]: *** [install-recursive] Błąd 1
make[1]: Leaving directory `/home/Wes-/Desktop/xine-lib-1-rc4a/src\\'
make: *** [install-recursive] Błąd 1

z reszta spotakłem sie z tym nie tylko przy instalacji tego programu, wie moze ktos co oznacza \\'błąd 1\\' ?

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #1 dnia: 2005-09-04, 14:40:08 »
A jaką masz wersje kompilatora? Ostatnio miałem okazję przekonać sie że niektóre źródła nie kompilują się pod gcc-4.0 a pod gcc-3.* jest ok

Offline Jacek Łuczak

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 437
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #2 dnia: 2005-09-04, 16:16:36 »
2005-09-04 14:40:08 killy9999 napisał:

> A jaką masz wersje kompilatora? Ostatnio miałem okazję przekonać sie że niektóre źródła nie
 > kompilują się pod gcc-4.0 a pod gcc-3.* jest ok

Dokladnie! Napisz jeszcze jaka masz wersje binutils. To tez jest wazne!

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #3 dnia: 2005-08-28, 15:40:01 »
Mam problem z montowaniem mojego pendrive'a (Kingston) pod Debianem 3.1. Przy próbie montowania nie rozpoznaje systemu plików (jest fat32 i pod windowsem działa).

Wszędzie znajduję informacje, że nie powinno być problemów, ale ja mam :(

Mój system to Debian 3.1 Sarge, kernel 2.6.8-2-686.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #4 dnia: 2005-08-28, 15:43:29 »
2005-08-28 15:40:01 miloszek napisał:

> Mam problem z montowaniem mojego pendrive'a (Kingston) pod Debianem 3.1. Przy próbie montowania
 > nie rozpoznaje systemu plików (jest fat32 i pod windowsem działa).
 >
 > Wszędzie znajduję informacje, że nie powinno być problemów, ale ja mam :(
 >
 > Mój system to Debian 3.1 Sarge, kernel 2.6.8-2-686.

Dodam że korzystam z Gnome'a 2.10, a pendrive to Kingston KUSBDTI/256

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #5 dnia: 2005-09-18, 18:30:12 »
Problem rozwiązany - pendrive'y Kingstone'a bnie działają z Debianem :(

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #6 dnia: 2005-09-18, 19:32:45 »
2005-09-18 18:30:12 miloszek napisał:

> Problem rozwiązany - pendrive'y Kingstone'a bnie działają z Debianem :(

Bzdura.

W Debianie sie da :-)

Przynajmniej w moim.

--
Maciek

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #7 dnia: 2005-09-18, 19:34:12 »
Moze jest problem w Gnome - HAL itp.

Zobacz dmesg, jak jadro wykrywa sprzet. fdisk -l jak wyglada uklad partycji itp.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #8 dnia: 2005-09-18, 19:42:56 »
2005-09-18 18:30:12 miloszek napisał:

> Problem rozwiązany - pendrive'y Kingstone'a bnie działają z Debianem :(

Guzik prawda! Działają bez problemów. Zamontuj /dev/sda np. na /floppy. O ile masz w komilowane wsparcie dla usb i scsi - musi działać.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #9 dnia: 2005-09-18, 22:20:54 »
Nie pamiętam w tej chwili jaki komunikat był wyrzucany, ale zasadniczo chodzi o to, że coś jest skopane z partycjami. Czytałem o tym na stronie jakiejś wrocławskiej uczelni...

A jaki model pendrive'a mają Ci, którym działa?

Przypomniałem sobei o co chodziło: źle jest podany typ partycji. Na moim kingstonie jest W95 FAT32, a powinno być FAT32 (tak na jakiejś innej stronie pisało - przepraszam za brak konkretów, ale to już jakiś czas temu było). I problem polega na tym, że fdisk nie ma możliwości ustawienia FAT32 (bez W95 na początku).

Jeżeli ktoś zna bezpieczny (dla pendrive'a) sposób na rozwiązanie tego problemu, będę wdzięczny za podanie...

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #10 dnia: 2005-09-18, 22:39:55 »
2005-09-18 22:20:54 miloszek napisał:

> Nie pamiętam w tej chwili jaki komunikat był wyrzucany, ale zasadniczo chodzi o to, że coś jest
 > skopane z partycjami. Czytałem o tym na stronie jakiejś wrocławskiej uczelni...
 >
 > A jaki model pendrive'a mają Ci, którym działa?
 >

Kingston (nie moj ale mialem okazje uzywac), PQI, i kilka no name.

 > Przypomniałem sobei o co chodziło: źle jest podany typ partycji. Na moim kingstonie jest W95
 > FAT32, a powinno być FAT32 (tak na jakiejś innej stronie pisało - przepraszam za brak
 > konkretów, ale to już jakiś czas temu było). I problem polega na tym, że fdisk nie ma
 > możliwości ustawienia FAT32 (bez W95 na początku).
 >

eeee, ma

 > Jeżeli ktoś zna bezpieczny (dla pendrive'a) sposób na rozwiązanie tego problemu, będę wdzięczny
 > za podanie...

Popelnilem kiedys art o pendrive'ach, wymaga aktualizacji, ale czasu brak:

http://www.unixy.pl/forum/art/pendrive.html

Czesc pendrive'ow jest sformatowana bez podzialow na partycje (bezposrednio na np. /dev/sda, formatuje sie go mkdosfs -I -F 16 /dev/sda). Niektore nie lubia formatowania w systemie innym niz FAT16, sa problemy pod Windowsem (nie mam pojecia czemu - szukam nadal informacji). Tych informacji brakuje w artykule.

--
Maciek

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #11 dnia: 2005-09-18, 22:57:23 »
2005-09-18 22:39:55 Maciek_Rutecki napisał:

 > Kingston (nie moj ale mialem okazje uzywac), PQI, i kilka no name.

Chodzi mi o dokładny model (mój umieściłem w drugim poście). Podobno motyw jest taki, że z wszystkimi innymi chodzi...

Może powinienem fdiska aktualizować ;) Pamiętam że tej opcji nie było. A mój ma FAT32 i tak powinno zostać (nie będę formatował na fat16)...

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #12 dnia: 2005-09-19, 08:50:49 »
2005-09-18 22:57:23 miloszek napisał:

 > Chodzi mi o dokładny model (mój umieściłem w drugim poście). Podobno motyw jest taki, że z
 > wszystkimi innymi chodzi...
 >
 > Może powinienem fdiska aktualizować ;) Pamiętam że tej opcji nie było. A mój ma FAT32 i tak
 > powinno zostać (nie będę formatował na fat16)...

Dokladnie Ci nie powiem, tyle ze mial 256MB.

--
Maciek

Offline Szymek W

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 350
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #13 dnia: 2005-09-19, 08:56:18 »
Czy masz zainstalowany Hardware Abstraction Layer?

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
[Debian] pendrive
« Odpowiedź #14 dnia: 2006-01-01, 11:59:35 »
Udało mi się uruchomić tego pendrive'a. Skasowaęłm partycję i sformatowałem go na nowo (korzystając z mechanizmu formatowania wbudowanego w windowsa). Kłopoty zaczęły się powtarzać, gdy nadałem (pod windowsem) dyskowi etykietę. Domyślam się, że to może być jedna z przyczyn całego problemu. Przy najbliższej okazji usunę etykietę i przeprowadzę ponowne testy współpracy :)