Nowe posty

Autor Wątek: Problem z RT2400 i slackware 12  (Przeczytany 5800 razy)

kacpers21

  • Gość
Problem z RT2400 i slackware 12
« dnia: 2008-02-03, 13:56:06 »
Witam. Mam problem z zainstalowaniem sterów do rt2400. Gdy spisuje make to pojawia się:
 CC [M]  /usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.o
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c:55: error: expected ')' before string constant
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c:59: error: expected ')' before string constant
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c: In function 'RT2400_probe':
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c:170: error: 'struct net_device' has no member named 'get_wireless_stats'
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c:190: warning: format '%lx' expects type 'long unsigned int', but argument 3 has type 'resource_size_t'
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c: In function 'RT2400_open':
/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.c:238: warning: passing argument 2 of 'request_irq' from incompatible pointer type
make[2]: *** [/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module/rtmp_main.o] Error 1
make[1]: *** [_module_/usr/src/linux-2.6.21.5/rt2400-1.2.2-b3/Module] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.21.5'
rt2400.ko failed to build!
make: *** [module] Error 1
Moj linux to slackware 12.0 kernel jego to:2.6.21.5

Nie wiem co robić:/ bo jak zainstalowałem sterowniki cvs to net bardzo wolno działa/. prawie że nie działa.

norbert_ramzes

  • Gość
Problem z RT2400 i slackware 12
« Odpowiedź #1 dnia: 2008-02-03, 15:22:54 »
2.6.24 posiada moduł (rt2400pci) do obsługi tej karty.

kacpers21

  • Gość
Problem z RT2400 i slackware 12
« Odpowiedź #2 dnia: 2008-02-03, 16:28:33 »
no a ja mam 2.6.21.5

chmooreck

  • Gość
Problem z RT2400 i slackware 12
« Odpowiedź #3 dnia: 2008-02-03, 16:47:37 »
To może rozważ przesiadkę na 2.6.24 ? ;-)

kacpers21

  • Gość
Problem z RT2400 i slackware 12
« Odpowiedź #4 dnia: 2008-02-04, 15:33:14 »
Tylko najpierw trzeba umieć zainstalować to jądro.

norbert_ramzes

  • Gość

krzychoo89

  • Gość
Problem z RT2400 i slackware 12
« Odpowiedź #6 dnia: 2008-02-10, 22:42:17 »
Miałem ten sam problem. Z mojego punktu widzenia wyglada to tak:

Problemy sa spowodowane jadrem 2.6 . Na 2.4 wszystko chodzilo bez wiekszego problemu. W wersji 12 jest juz 2.6...i albo nie chca sie instalowac albo net chodzi jak krew z nosa. Jest na to 1 rada: ndiswrapper i sterowniki spod windowsa ;)

zycze powodzenia, pozdrawiam