Nowe posty

Autor Wątek: Aterm+ekg2 (aterm niewyswietla wciskanych liter)  (Przeczytany 12022 razy)

norbert_ramzes

  • Gość
Aterm+ekg2 (aterm niewyswietla wciskanych liter)
« Odpowiedź #15 dnia: 2008-02-03, 19:43:36 »
Raczej to nie to...

cobaco

  • Gość
Aterm+ekg2 (aterm niewyswietla wciskanych liter)
« Odpowiedź #16 dnia: 2008-02-03, 20:50:32 »
zmusilem tilde do pseudo przezroczystosci sam niewm dlaczego to dziala pierwsza konsola ma problem z przezroczystoscia  natomiast juz kolejne wlaczone tildy dobrze z nia sobie radza jak dojde w czym tkwi      problem z atermem dam znac..;)

arctgx

  • Gość
Aterm+ekg2 (aterm niewyswietla wciskanych liter)
« Odpowiedź #17 dnia: 2008-02-04, 00:16:43 »
Szkoda że dopiero teraz wypatrzyłem ten wątek...

Sprawdź poleceniem locale czy masz UTF-8. Jeśli tak, to zamiast aterma proponuję rxvt-unicode (urxvt), który jest podobny w zachowaniu (sam nie przepadam za Xterm). Z tego co wiem, aterm nie obsługuje unikodu.

Czcionki dostarczane są do Xorg na kilka sposobów.

Ten klasyczny przerobiliście już wyżej w jakimś stopniu, choć ręcznie można dodawać je z poziomu użytkownika. Ponieważ zaproponuję co innego, poszukaj sam wg kluczy xset fp rehash, mkfontdir, mkfontscale.

Tu listę fontów wspierających UTF-8 (iso10646-1) wyświetlisz sobie poleceniem xlsfonts | grep 10646 lub używając xfontsel.

Sam używam w terminalu czcionki bitmapowej (czyli nieskalowalnej) Fixed 15 z paczki
xfonts-efont-unicode (w Debianie tak się zwie).

Drugi sposób dostarczania czcionek to fontconfig. Korzysta z niego większość współczesnych aplikacji w Xorg. Dostępne w ten sposób czcionki wyświetlasz poleceniem fc-list (z ew. parametrami). A urxvt dajesz parametr, przykładowo -fn "xft:Bitstream Vera Sans Mono:pixelsize=15".  Na razie nie znalazłem przyjemnych dla swojego oka czcionek z fontconfig.

cobaco

  • Gość
Aterm+ekg2 (aterm niewyswietla wciskanych liter)
« Odpowiedź #18 dnia: 2008-02-04, 15:22:17 »
sprawdze towoja wskazowke o ile wiem to nie mam UTF-8  dam znac ale dopiero za jakis dzien moze troszke wiecej urxvt mam juz w grane a problem jest taki jak w atermie   ( w tildzie wystarczylo zaznaczyc opcje 'Enable Double Buffering')