Nowe posty

Autor Wątek: Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf  (Przeczytany 9589 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Mam problem z plikiem xorg.conf w openSuSE 10.3. Korzystam z nietypowej rozdzielczości 1280x768. Po pierwszym uruchomieniu system ustawił mi "kosmiczną" rozdzielczość 800x600. Odpaliłem więc SaX-a, chcąc przestawić rozdzielczość na właściwą, jednak takiej tam nie znalazłem. Znalazłem wtedy w Internecie, że konieczna jest edycja pliku /etc/X11/xorg.conf. Do sekcji Mode dodałem linię Modelines wygenerowaną za pomocą komendy gtf oraz dodałem właściwy wpis w sekcji Screen. Po restarcie X-ów KDE już się nie uruchomiło (terminal wywalił po angielsku info o błędnej linii 100) i musiałem podmienić xorg.conf na kopię, zrobioną przed edycją.

Przy edycji xorg.conf pomagałem sobie tym postem (dotyczy on Mandrivy, ale w SuSE xorg jest bardzo podobny):
http://www.forum.zlotekrople.prh.pl/showthread.php?p=379815

Teraz moje pytanie:
Co mam zrobić, aby wreszcie KDE działało pod rozdzielczością 1280x768??

Mój xorg.conf:
# /.../
# SaX generated X11 config file
# Created on: 2008-01-28T18:11:56+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer , 2005
# Contact: SaX-User list
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "pl"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Elan Microelectronics PS/2+USB Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  DisplaySize  420 257
  HorizSync    30-50
  Identifier   "Monitor[0]"
  ModelName    "1280X768@60HZ"
  Option       "DPMS"
  VendorName   "--> LCD"
  VertRefresh  48-61
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline "1024x768" 65.26 1024 1080 1184 1344 768 769 772 796
  Modeline "1024x768" 56.00 1024 1072 1104 1184 768 771 775 790 +HSync -Vsync
  Modeline "800x600" 38.85 800 832 912 1024 600 601 604 622
  Modeline "800x600" 35.50 800 848 880 960 600 603 607 618 +HSync -Vsync
  Modeline "1440x900" 89 1440 1488 1520 1600 900 903 909 926 +hsync +vsync
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "800x600"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "RV280 5964"
  BusID        "1:0:0"
  Driver       "radeon"
  Identifier   "Device[0]"
  Option       "usevnc" "no"
  Option       "GARTSize" "32"
  Screen       0
  VendorName   "ATI"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection

Offline Łukasz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 285
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #1 dnia: 2008-01-29, 16:36:59 »
zainstalowałeś sterowniki od karty graficznej ? Jeśli nie to zrób to jako pierwsze

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #2 dnia: 2008-01-29, 18:36:59 »
Niestety nie mogę zainstalować sterowników karty graficznej. Plik sterownika jest w formacie *.run. Instalowałem go według tego opisu:
http://www.osiol.net/index.php?showtopic=22905&mode=threaded&pid=157042
jednak
Cytuj
Jeśli wszystko poszło dobrze w katalogu gdzie był plik instalacyjny powinien sie ukazać na rpm-em do instalacji juz samych sterowników.
nie pojawiła się na pulpicie paczka RPM.

Offline Norbert Kiszka

  • Users
  • Guru
  • *****
  • Wiadomości: 1846
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #3 dnia: 2008-01-29, 19:08:37 »
Wydaje mi się że znalazłeś kiepski poradnik. Sprawdź czy pojawiła się na pulpicie roota (/root/Desktop).
"Ostrzeżenie menedżera okien: Okno 0x3e00019 (MPlayer) ustawia atrybut MWM, określający, że jego rozmiar okna jest niezmienny, lecz jednocześnie ustawia minimalny rozmiar na 1 x 1, a maksymalny rozmiar na 440 x 120. To nie ma żadnego sensu."

http://lottalinuxlinks.com/files/linux_mobile.jpg

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #4 dnia: 2008-01-29, 20:28:24 »
Nie ma.

Offline Łukasz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 285
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #5 dnia: 2008-01-29, 20:35:33 »
Jak używałem Suse napisałem kiedyś poradnik instalacji ale już od wielu lat nie używam tej dystrybucji więc gdzieś zaginął ale znalazłem tutaj coś podobnego http://suse.ehelp.pl/modules/articles/article.php?id=79

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #6 dnia: 2008-01-30, 18:20:10 »
Coś nie wyszło:
JA:/tmp # sh /tmp/ati-driver-installer-8.28.8.run --buildpkg SuSE/SUSE103-IA-32
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: SuSE/SUSE103-IA-32
[b]Requested package is not supported.[/b]
Removing temporary directory: fglrx-install

Offline Norbert Kiszka

  • Users
  • Guru
  • *****
  • Wiadomości: 1846
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #7 dnia: 2008-01-30, 18:40:02 »
Cytat: Harry.Potter
ati-driver-installer-8.28.8.run
Dlaczego taki stary sterownik próbujesz zainstalować?
Spróbuj ten.
"Ostrzeżenie menedżera okien: Okno 0x3e00019 (MPlayer) ustawia atrybut MWM, określający, że jego rozmiar okna jest niezmienny, lecz jednocześnie ustawia minimalny rozmiar na 1 x 1, a maksymalny rozmiar na 440 x 120. To nie ma żadnego sensu."

http://lottalinuxlinks.com/files/linux_mobile.jpg

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #8 dnia: 2008-01-30, 18:49:22 »
Cytuj
Dlaczego taki stary sterownik próbujesz zainstalować?
Spróbuj ten.
Ten jest dla architektury 64bit, a ja mam jeszcze Pentium III ;-) .

Gdy instaluję wg oficjalnego tutoriala ATI, wychodzi coś takiego:
JA:/tmp # sh ./ati-driver-installer-8.28.8.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: Xorg 7.2.0

Detected version of X does not have a matching 'x720' directory
You may override the detected version using the following syntax:
     X_VERSION= ./ati-driver-installer--.run [--install]

The following values may be used for :
    x430        XFree86 4.3.x
    x430_64a    XFree86 4.3.x 64-bit
    x680        X.Org 6.8.x
    x680_64a    X.Org 6.8.x 64-bit
    x690        X.Org 6.9.x
    x690_64a    X.Org 6.9.x 64-bit
    x700        X.Org 7.0.x
    x700_64a    X.Org 7.0.x 64-bit
    x710        Unknown X Window
    x710_64a    Unknown X Window
Removing temporary directory: fglrx-install
Stery ściągam stąd:
http://ati.amd.com/support/drivers/linux/linux-radeon-prer200.html
Grafa to Radek 9200SE

EDIT:
Chyba znalazłem:
http://www.susek.info/article/ATI-3D-w-OpenSUSE-10.3.shtml


EDIT 2:
Niestety YaST wywalił, że brakuje mu zależności i nie może ich zainstalować.
Zapisałem raport:
Cytuj
#### YaST2 conflicts list - generated 2008-01-30 19:06:40 ####

x11-video-fglrxG01 nie mo?e zosta? zainstalowany z powodu brakuj?cych zale?no?ci
    Nie ma mo?liwych do instalacji dostawc�w ati-fglrxG01-kmp dla: x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository]
    === x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] ===
        x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] zostanie zainstalowany przez inn? aplikacj?. (ApplLow/ApplHigh)
        glibc-2.6.1-18.i686 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libc.so.6(GLIBC_2.0))
        libgcc42-4.2.1_20070724-17.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libgcc_s.so.1)
    12 wi?cej...
            xorg-x11-libXrender-7.2-65.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libXrender.so.1)
            xorg-x11-libX11-7.2-75.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libX11.so.6)
            xorg-x11-libXext-7.2-65.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libXext.so.6)
            xorg-x11-libs-7.2-103.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libXi.so.6)
            bash-3.2-61.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (/bin/sh)
            x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] jest wymagany przez  (libGL.so.1)
            freetype2-2.3.5-18.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libfreetype.so.6)
            fontconfig-2.4.2-43.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libfontconfig.so.1)
            xorg-x11-libSM-7.2-58.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libSM.so.6)
            xorg-x11-libICE-7.2-61.i586 jest wymagany przez x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository] (libICE.so.6)
            ati-fglrxG01-kmp-default-8.45.4_2.6.22.16_0.1-0.2.i586[ATI Repository] dostarcza ati-fglrxG01-kmp == 8.45.4_2.6.22.16_0.1, ale jest nie do odinstalowania. Nale?y spr�bowa? zainstalowa? go osobno, by uzyska? wi?cej informacji.
        (null)
    Rozwi?zanie konfliktu:
        ( ) nie instaluj x11-video-fglrxG01
            nie instaluj x11-video-fglrxG01-8.45.4-0.2.i586[ATI Repository]
        ( ) Zignoruj ten wym�g tylko tutaj

#### YaST2 conflicts list END ###

Offline Łukasz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 285
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #9 dnia: 2008-01-30, 22:48:25 »
sterowniki ściagnij z oficjalnej strony amd.ati wybierz linux x86 i swoją kartę graficzną

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #10 dnia: 2008-01-30, 22:56:16 »
Przecież tak zrobiłem.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #11 dnia: 2008-01-30, 22:56:37 »
To dziwne że nie masz wsparcia 3D dla Radeona 9200 SE skoro ja mam ten sam sprzęt, a wsparcie mam już zaraz po instalacji. Aha i też mam problem ze zmianą rozdzielczośći ;/

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #12 dnia: 2008-02-08, 11:37:48 »
Napisałem o tym na innym forum - wyszło, że oficjalne stery nie pasują do mojej karty, a stara wersja nie pasuje do najnowszego Xorga. Polecono mi uaktywnić z powrotem otwarte stery, lecz nie działała akceleracja 3D. Odwołano mnie do tego posta na forum SuSE, jednak wróciło

Cytuj
no screen found
Widzę, że fglrx jeszcze siedzi w Xorgu.

Mój xorg.conf

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Niestandardowa rozdzielczość w openSuSE - problem z xorg.conf
« Odpowiedź #13 dnia: 2008-02-11, 19:02:41 »
Wydałem komendę "sax2 -r -m 0=radeon" (tak mi kazali na innym forum) - fglrx-a już nie ma w xorgu, X-y startują, jednak wciąż nie mogę ustawić tej rozdzielczości i ciągle nie mam akceleracji 3D.

http://www.wklej.org/id/7375cce2cf = /etc/X11/xorg.conf