Nowe posty

xx Migracja GRUB2 (0)
Wczoraj o 12:30:46
xx Przydatne Linki (4)
2019-08-23, 14:13:00
xx Awstat (0)
2019-08-22, 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45

Autor Wątek: Problem z java v IceWeasel  (Przeczytany 10301 razy)

Offline Norbert Kiszka

  • Users
  • Guru
  • *****
  • Wiadomości: 1846
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #15 dnia: 2008-01-26, 23:12:57 »
Cytat: Isilbad
jęsli się nie mylę tona przykład strona:
http://www.mpk.lodz.pl/rozklady/start.jsp
również wymaga obsługi javy, a wszystko u mnie śmiga elegancko, natomiast test javy na stronie:
http://www.java.com/en/download/help/testvm.xml
czy czateria.pl nie chcą działać.
JSP (java Server Pages) to nie Java!!! jsp to jest skrypt wykonywany po stronie serwera, tak samo jak np php.

PS. apt-get install cośtam - to polecenie nie przeinstaluje niczego, to tylko instaluje/aktualizuje jeśli nie jest zainstalowane.

aptitude --help
"Ostrzeżenie menedżera okien: Okno 0x3e00019 (MPlayer) ustawia atrybut MWM, określający, że jego rozmiar okna jest niezmienny, lecz jednocześnie ustawia minimalny rozmiar na 1 x 1, a maksymalny rozmiar na 440 x 120. To nie ma żadnego sensu."

http://lottalinuxlinks.com/files/linux_mobile.jpg

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 63
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #16 dnia: 2008-01-26, 23:54:32 »
Dobra, to było tak:

aptitude reinstall java-gcj-compat-plugin libdom1-java sun-java5-jre sun-java5-bin sun-java5-plugin
[cała masa linijek - żadnych errorów]
cd /usr/lib/iceweasel/plugins
isilbad:/usr/lib/iceweasel/plugins# rm libjavaplugin_oji.so
isilbad:/usr/lib/iceweasel/plugins# ln /usr/lib/jvm/java-1.5.0-sun-1.5.0.10/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/iceweasel/plugins

żadnych pozytywnych efektów, czyli wciąż to:
http://www.widzew.net/~isilbad/zrzutekranu1.png

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 434
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #17 dnia: 2008-01-26, 23:59:14 »
heh,,,

po instalacji tych pakietów nie twórz żadnych dowiązań. Wszystko co potrzebne jest robione podczas instalacji pakietu. (modyfikując instalację programu możesz go tylko zepsuć...)

Jutro jeszcze sprawdzę dokładnie jakie pakiety powinny być zainstalowane (na systemie na którym java jest zainstalowana i działa - na tym z którego teraz piszę nie mam zainstalowanej javy).

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 63
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #18 dnia: 2008-01-27, 00:10:22 »
Ok, usunąłem stare dowiązanie i zrobiłem:

aptitude reinstall java-gcj-compat-plugin libdom1-java sun-java5-jre sun-java5-bin sun-java5-plugin

żadnych zmian, java nie działa.

Jeszcze jakieś pomysły?

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 434
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #19 dnia: 2008-01-27, 12:24:17 »
Jeśli już masz poprawnie zainstalowaną Javę, to podaj co ci się wyświetla w about:plugins, żeby sprawdzić, czy przeglądarka widzi wtyczkę.

Sprawdziłem te pakiety, jakie są potrzebne do działania wtyczki JAVA, i wystarczą trzy:
sun-javaX-bin, sun-javaX-jre oraz sun-javaX-plugin (X to numer wersji, np. 5, 6).
Może odinstaluj java-gcj-compat-plugin - może powoduje on konflikt z sun-java5-plugin?

Co do strony testowej na sun.com, mam problemy z wejściem na tą stronę - może coś jest z nią nie tak? Spróbuj przetestować Javę na innej stronie, na przykład:
http://www.javatester.org/
No i na jakimś portalu z czatem albo innym takim.

Jeśli to nie pomoże, to mam jeszcze jeden pomysł, ale może najpierw sprawdź to co napisałem powyżej

PS. Tak na przyszłość mała rada. Kiedy chcesz zainstalować jakiś program, to najpierw sprawdź, czy znajduje się w repozytorium twojej dystrybucji. Dopiero jeśli tam nie ma programu, to szukaj w internecie.
Kiedy instalujesz program z pakietu (z plików .deb, .rpm itp.), czy to z repozytorium, czy ze ściągniętych z internetu, to nigdy nie modyfikuj "ręcznie" tak zainstalowanych programów (nie usuwaj ani nie podmieniaj plików zainstalowanych w ten sposób w katalogach /usr i /etc). Programy tak zainstalowane także usuwaj przez menedżer pakietów (apt, aptitude, synaptic, czy inne, w zależności jaką dystrybucję używasz).

PS2. Zauważyłem, że używasz Debiana Etch. Możesz uaktualnić system do wersji Lenny. Jest to co prawda wersja testowa, ale i tak jest bardzo stabilna (sam używam na co dzień). W Lennym masz nowsze wersje programów (np. jest tam JAVA 6) - w Etchu są tylko uaktualnienia bezpieczeństwa (np. taki Iceweasel), a reszta programów jest w starych wersjach. Żeby zmienić wersję z Etch na Lenny, wystarczy, że w źródłach oprogramowania (sources.list) zmienisz wyrazy etch na lenny (albo na testing - jeśli wpiszesz testing, to gdy lenny stanie się stabilny, to automatycznie zaczniesz używać kolejnej testowej wersji), odświeżysz listę pakietów i będziesz mógł robić upgrade do Lennego.

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 63
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #20 dnia: 2008-01-27, 14:14:23 »
Odinstalowanie java-gcj-compat-plugin rozwiązało problem.

Dziękuję za zaangażowanie :)

Offline Norbert Kiszka

  • Users
  • Guru
  • *****
  • Wiadomości: 1846
    • Zobacz profil
Problem z java v IceWeasel
« Odpowiedź #21 dnia: 2008-01-27, 14:24:46 »
Ewentualnie sid (najnajnowszy soft, częste aktualizacje), ale z nim czasami są problemy.
"Ostrzeżenie menedżera okien: Okno 0x3e00019 (MPlayer) ustawia atrybut MWM, określający, że jego rozmiar okna jest niezmienny, lecz jednocześnie ustawia minimalny rozmiar na 1 x 1, a maksymalny rozmiar na 440 x 120. To nie ma żadnego sensu."

http://lottalinuxlinks.com/files/linux_mobile.jpg