Nowe posty

Autor Wątek: ACPI i "shutdown -h now"  (Przeczytany 5074 razy)

Orlando

  • Gość
ACPI i "shutdown -h now"
« dnia: 2008-01-24, 08:47:47 »
Vsem privet. Ja iz Ukrainy. Pishu na russkom. Ponimaju polskiy.
Installiroval Debian na ATX kompyuter i voznikla takaya problema, kazdiy raz kogda delayu "shutdown -h now" sistema dohodit do "flushing hdc hdd devices. Power down." i vse, to est kompyuter ne vyklyuchaetsya, tolko slyshno, kak ubralos pitanie s hdd (vinchester). Slyshal, chto eto svyazano s ACPI. Kto podskazet kak reshit dannuyu problemu, budu ochen blagodaren.

Hi all. I'm from Ukraine. I can understand Poland language, please write me in it if you can. I've installed Debian linux on my ATX desktop, but each time i'm trying to shutdown computer with "shutdown -h now" it goes till "Flushing hdc hdd devices. Power down" and that's all it really doesn't turn off power. It's only heard that hdd devices have their power off. I've heard the problem is in ACPI. Please I will be thankful if someone can help me with this problem.

darko

  • Gość
ACPI i "shutdown -h now"
« Odpowiedź #1 dnia: 2008-01-24, 09:54:25 »
Before

# shutdown -h now
try

# modprobe acpi
or

# modprobe apm

vaitek

  • Gość
ACPI i "shutdown -h now"
« Odpowiedź #2 dnia: 2008-01-24, 12:11:41 »
check these settings in your kernel config file - usually /usr/src/linux-*/.config

[...]
CONFIG_APM=m
[...]
CONFIG_APM_REAL_MODE_POWER_OFF=y
[...]

Regards
Vaitek

Offline Arkadiusz Bednarczyk

  • Linux.pl
  • Administrator
  • Guru
  • *****
  • Wiadomości: 646
    • Zobacz profil
    • Linux.pl
ACPI i "shutdown -h now"
« Odpowiedź #3 dnia: 2008-01-24, 12:59:03 »
Sometimes APM is disabled in BIOS. Check your settings in BIOS too :)
--
pozdrawiam
Arkadiusz Bednarczyk
email/jabber: arek@linux.pl

  • Gość
ACPI i "shutdown -h now"
« Odpowiedź #4 dnia: 2008-01-25, 15:20:53 »
Hi
Try
poweroff

norbert_ramzes

  • Gość
ACPI i "shutdown -h now"
« Odpowiedź #5 dnia: 2008-01-25, 19:53:00 »
Very helpful:

man halt

Orlando

  • Gość
ACPI i "shutdown -h now"
« Odpowiedź #6 dnia: 2008-01-30, 09:42:55 »
Thanks all. I tried "modprobe APM" and than "shutdown -h now" it helped - computer normally turns off.

norbert_ramzes

  • Gość
ACPI i "shutdown -h now"
« Odpowiedź #7 dnia: 2008-01-30, 12:20:08 »
Try put line:
apm
into file /etc/modules