Nowe posty

Autor Wątek: Słynny problem z kartą RT2400 (dziwny błąd)...  (Przeczytany 6891 razy)

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« dnia: 2005-08-21, 16:49:49 »
Witam!
mam pytanie odnosnie alsy. czy da sie odtwarzac dzwiek z dwocj zrodel jednoczesnie? czyli np. sluchajac piosenki w winampie i ogladajac film w mplayerze?
chodzi mi oczywiscie o dokonanie tego uzywajac alsy.
pytam gdyz przed chwila uruchomil mi sie standardowo noatun a ze bylo to podczas ogladania filmu myslalem ze nic z tego nie wyjdzie a ku memu zaskoczeniu mialem jednoczesnie dzwiek z filmu i piosenke.
czy takie cos da sie rowniez zrobic przy uzyciu alsy?

leiah

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #1 dnia: 2005-08-21, 17:36:33 »
2005-08-21 16:49:49 y_0rk3r napisał:

> Witam!
 > mam pytanie odnosnie alsy. czy da sie odtwarzac dzwiek z dwocj zrodel jednoczesnie? czyli np.
 > sluchajac piosenki w winampie i ogladajac film w mplayerze?
 > chodzi mi oczywiscie o dokonanie tego uzywajac alsy.
 > pytam gdyz przed chwila uruchomil mi sie standardowo noatun a ze bylo to podczas ogladania
 > filmu myslalem ze nic z tego nie wyjdzie a ku memu zaskoczeniu mialem jednoczesnie dzwiek z
 > filmu i piosenke.
 > czy takie cos da sie rowniez zrobic przy uzyciu alsy?

kiedyś ten problem był tu rozwiązany. jeśłi się nie mylę trzeba było zrobic wirtualne miksery i skierowac na nie dźwięk. nie pamiętam jak to sie robiło, bo wszędzie uzywam wyjścia \\"Arts\\", ale jak poszukasz na forum to znajdziesz.
Pozdrawiam i powodzenia

jk33

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #2 dnia: 2005-08-21, 20:15:11 »
To zalezy jaka masz karte.
Ja na przyklad mam zintegrowana
na plycie VIA i moge odtwarzac z 4
zrodel jednoczesnie.

jesli wydasz polecenie

cat /proc/asound/pcm
to bedzie cos w stylu:
00-00: VIA8235 : VIA8235 : playback 4 : capture 1
\\"playback n\\" oznacza ze moze
jednoczesnie odtwarzac n programow naraz.
(tu: 4)

Jasli masz playback 1 to zawsze mozesz
skorzystac, tak jak kolega napisal,
z esd albo arts.

pozdrawiam

wojtekm

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #3 dnia: 2005-08-21, 20:39:50 »
2005-08-21 16:49:49 y_0rk3r napisał:

 > czy takie cos da sie rowniez zrobic przy uzyciu alsy?

Tak, kwestia skonfigurowania mixera dmix (działa zawsze) lub posiadania karty w której alsa obsługuje sprzętowe miksowanie (wtedy nic nie trzeba, wszytsko działa od strzału).

Wojtek

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #4 dnia: 2005-08-27, 04:11:07 »
2005-08-21 20:39:50 wojtekm napisał:

> 2005-08-21 16:49:49 y_0rk3r napisał:
 >
 >  > czy takie cos da sie rowniez zrobic przy uzyciu alsy?
 >
 > Tak, kwestia skonfigurowania mixera dmix (działa zawsze) lub posiadania karty w której alsa
 > obsługuje sprzętowe miksowanie (wtedy nic nie trzeba, wszytsko działa od strzału).
 >
 > Wojtek
dobra dzieki bede cos probowal:) powinno sie udac
dzieki

Malutka Alutka

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #5 dnia: 2005-08-21, 11:39:44 »
Mój problemik polega na tym, iż po wpisaniu komendy make konsola wyświetla mi taki błąd:
 
[root@localhost Module]# make
make: *** /lib/modules/2.6.8.1-12mdksmp/build: No such file or directory. Stop.
rt2400.ko failed to build!

Nie mam pojęcia czemu ten błąd wyskakuje, bo mam źródełka w katalogu /usr/src/
Nie mam już pomysłów...
Proszę! Pomocy!

lesiu1111

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #6 dnia: 2005-08-21, 11:43:14 »
2005-08-21 11:39:44 Malutka Alutka napisał:

> Mój problemik polega na tym, iż po wpisaniu komendy make konsola wyświetla mi taki błąd:
 >  
 > [root@localhost Module]# make
 > make: *** /lib/modules/2.6.8.1-12mdksmp/build: No such file or directory. Stop.
 > rt2400.ko failed to build!
 >
 > Nie mam pojęcia czemu ten błąd wyskakuje, bo mam źródełka w katalogu /usr/src/
 > Nie mam już pomysłów...
 > Proszę! Pomocy!
 >

Żródła masz, ale nie masz w obecnie używanym kerneli skompilowanego takiego modułu, mianowicie odpowiedzialnego za kartę RT2400. Skompiluj kernel z tą obsługą i będzie oki.

Pozdrawiam.

Malutka Alutka

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #7 dnia: 2005-08-24, 23:25:02 »
Oki ten problemik już rozwiązałam, teraz pojawił się następny...
Sterowniki od karty skompilowałam, za pomocą komendy, make i zainstalowałam za pomocą komendy make install, jednak kiedy wpisuje komende modprobe rt2400 wyświetla mi się błąd, że nie ma takiego urządzenia... Proszę o pomoc!!!

chmooreck

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #8 dnia: 2005-08-25, 08:07:33 »
a jaka masz dokladnie karte ? jakie jadro ?

byc moze po prostu twoje jadro jeszcze nie zna identyfikatora twojej karty i nie wie co to wogole jest...

Malutka Alutka

  • Gość
Słynny problem z kartą RT2400 (dziwny błąd)...
« Odpowiedź #9 dnia: 2005-08-25, 09:42:43 »
2005-08-25 08:07:33 chmooreck napisał:

> a jaka masz dokladnie karte ? jakie jadro ?
 >
 > byc moze po prostu twoje jadro jeszcze nie zna identyfikatora twojej karty i nie wie co to
 > wogole jest...

Karta sieciowa Ralink RT2400, jądro 2.6.8.1-12, jądro rozpoznaje identyfikator karty, bo sprawdzałam. Ale tak jak piszę wyżej po skompilowaniu i zainstalowaniu sterowników i wpisaniu komendy modprobe rt2400 konsola odpowiada, że nie ma takiego urządzenia. Sprawdzałam także czy są sterowniki w katalogu /lib/modules/ i są tam, zainstalowały się.