Nowe posty

xx Repozytorium z czcionkami M$ (2)
Dzisiaj o 17:58:30
xx Pomoc w wyborze środowiska graficznego (11)
Wczoraj o 22:41:56
xx Usunąłem przez przypadek /bin co zrobić? (2)
Wczoraj o 21:36:24
xx Obrócony obraz lubuntu, xubuntu na lenovo Miix 320 (6)
Wczoraj o 11:56:25
xx Pierwsze kroki w Arch (9)
2022-05-22, 23:39:51
xx DBus (0)
2022-05-22, 12:47:35
xx Przedni panel (1)
2022-05-20, 01:34:35
xx Modem Medion S4222 jak zainstalować aplikację do jego obsługi? (52)
2022-05-18, 10:14:49
xx Strona o testach penetracyjnych, hackingu (33)
2022-05-18, 08:09:16
xx Nadawanie uprawnień przy kopiowaniu themes do katalogu (15)
2022-05-17, 21:18:16

Autor Wątek: karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1  (Przeczytany 28031 razy)

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #15 dnia: 2008-01-04, 16:13:26 »
Modem mam w sieci Vodafone.
Potrzebne mi jest: user name(użytkownik) i password(hasło),APN i DNS i chyba adres HOMEPAGE,no i nr .I tu mam pytanie odnośnie numeru,mam wpisać nr telefonu karty sim czy ten ciąg znaków *99***1# .Nie wiem gdzie w SuSE znaleźć konfigurator sieci czy połączenia internetowego.Jedyne co znalazłem to konfiguracja modemu lub karty sieciowej.Przy konfiguracji modemu jest pytanie odnośnie wdzwaniania połączenia co z tym zrobić,może pozostawić bez zmian.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #16 dnia: 2008-01-05, 01:45:59 »
Doinstalowałem plik bcm43xx i jeszcze raz sprawdziłem (dmseg) już nie ma tamtego komunikatu błędu,ale jest chyba kilka nieścisłości:
bcm43xx: Radio turned on
bcm43xx: Radio disabled by hardware
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1489:bcm43xx_find_lopair()
bcm43xx: WARNING: Writing invalid LOpair (low: -9, high: 0, index: 109)
 [] bcm43xx_phy_lo_adjust+0x1eb/0x20f [bcm43xx]

Nie wiem czy to coś ważnego czy nie i spróbowałem pójść dalej (sudo wvdialconf) i oto wynik:
sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: Scanning ttyUSB0 first, /dev/modem is a link to it.
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- Manufacturer: HUAWEI TECHNOLOGIES CO., LTD.
ttyUSB0<*1>: Speed 4800: AT -- OK
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Speed 19200: AT -- OK
ttyUSB0<*1>: Speed 38400: AT -- OK
ttyUSB0<*1>: Speed 57600: AT -- OK
ttyUSB0<*1>: Speed 115200: AT -- OK
ttyUSB0<*1>: Speed 230400: AT -- OK
ttyUSB0<*1>: Speed 460800: AT -- OK
ttyUSB0<*1>: Max speed is 460800; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
Modem Port Scan<*1>: S1   S2   S3
ttyS4: No such device or address
Modem Port Scan<*1>: S4
ttyS5: No such device or address
Modem Port Scan<*1>: S5
ttyS6: No such device or address
Modem Port Scan<*1>: S6
ttyS7: No such device or address
Modem Port Scan<*1>: S7
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem<*1>: Cannot get information for serial port.
ttyUSB2<*1>: ATQ0 V1 E1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB2<*1>: Modem Identifier: ATI -- Manufacturer: HUAWEI TECHNOLOGIES CO., LTD.
ttyUSB2<*1>: Speed 4800: AT -- OK
ttyUSB2<*1>: Speed 9600: AT -- OK
ttyUSB2<*1>: Speed 19200: AT -- OK
ttyUSB2<*1>: Speed 38400: AT -- OK
ttyUSB2<*1>: Speed 57600: AT -- OK
ttyUSB2<*1>: Speed 115200: AT -- OK
ttyUSB2<*1>: Speed 230400: AT -- OK
ttyUSB2<*1>: Speed 460800: AT -- OK
ttyUSB2<*1>: Max speed is 460800; that should be safe.
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttyUSB0, using link /dev/modem in config.
Modem configuration written to /etc/wvdial.conf.
ttyUSB0: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyUSB2: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
 
Chyba wszystko gra i mam pytanie A.B.,bo korzystam z twojego opisu dla blueconnecta  i trochę co innego mi pokazało się niż w twoim opisie.Więc co dalej mam z tym zrobić,sorry za te pytania,ale wciąż jeszcze jestem zielonym pingwinem.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #17 dnia: 2008-01-13, 15:52:48 »
Próbowałem konfigurować połączenie poprzez KPPP, ale pokazuje się komunikat że: Nie może utworzyć pliku blokowania modemu.I nie można się połączyć  z netem.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #18 dnia: 2008-01-21, 13:52:55 »
Jak widzę nikt nie wie co dalej z tym zrobić,więc próbowałem jeszcze raz z ze sterami od   operatora.I by rozwiązać problem z zależnościami ściągnąłem (win) ręcznie wszystkie 20 rpm-ów.Zainstalowałem je wszystkie i niestety porażka wywala cały czas błąd o niespełnionych zależnościach,sześć godzin szukania,ściągania i instalowania i nic.Wciąż jestem zmuszony na Winde gdzie białej gorączki dostaję,bo prawie przy co drugim włączeniu się zawiesza.Mam wrażenie że nie toleruje obecności Linuxa na dysku,bo po restarcie Windy jest komunikat o błędzie spójności dysku.Win sprawdza dysk i wtedy komunikat że jest ok. i dopiero Winda się dobrze uruchomi.Nie zmuszajcie mnie do Win-Męki.Poradźcie coś .

Offline Arkadiusz Bednarczyk

  • Linux.pl
  • Administrator
  • Guru
  • *****
  • Wiadomości: 646
    • Zobacz profil
    • Linux.pl
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #19 dnia: 2008-01-21, 14:15:27 »
Sam pisałeś:
Wynik skanowania przez wvdialconf:
Modem Port Scan<*1>: Scanning ttyUSB0 first, /dev/modem is a link to it.

Czyli klikasz sobie w jakiś konfigurator modemu, urządzenie dajesz /dev/modem, numer dokładnie nie wiem jaki jest w vodafone ale spróbowałbym z *99***1#, user i hasło musi Ci dostarczyć usługodawca. To wszystko - klikasz połącz i powinien się łączyć bez żadnych kombinacji.
--
pozdrawiam
Arkadiusz Bednarczyk
email/jabber: arek@linux.pl

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #20 dnia: 2008-01-21, 23:36:26 »
Zająłem się konfiguracją modemu,ale jak pisałem wcześniej przy próbie połaczenia pojawia się komunikat,że :nie można utworzyć pliku blokowania modemu,i nie ma połączenia.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #21 dnia: 2008-02-02, 14:16:22 »
Już prawie 24 godziny na necie w tym cała noc na szukaniu czegoś co by pomogło.Znalazłem plik nozomi ale nie wypał nie można wykonać make,make install i pojawia się komunikat że nie ma co wykonać.Więc czepiłem się znowu driever'ów od vodafone aby spełnić wszystkie zależności(ściągnąłem ręcznie 27 zależnych rpm'ów),no i powiedzmy że się udało zainstalowałem te driver'y.Po uruchomieniu tego powinno pojawić się okno konfiguracyjne vodafone i tak  się nie dzieje.Zaczyna ładować program pojawia się mała ikonka i tradycyjnie podskakuje w oczekiwaniu na uruchomienie i na tym się kończy.Jak sprawdzić co jest nie tak aby ten problem rozwiązać.
Jak jest ktoś zainteresowany sterownikami od vodafone to zajrzyj tutaj:https://forge.vodafonebetavine.net/frs/?group_id=12 są driver'y na różne dystrybucje.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #22 dnia: 2008-02-13, 22:30:57 »
Może komuś to pomoże, stery które dorwałem od operatora(ponoć bazują na "Nozomi")żeby je zainstalować musiałem ręczne ściągać i instalować każdy po kolei,więc jak masz kolegę z netem to lepiej z korzystać z tej opcji będzie szybciej.Ale jak masz pod górkę tak jak ja to może napiszę listę potrzebnych plików.bash,glibc,wvdial,libusb,dbus-1-python,gnome-python-desktop,python-serial,
python-twisted,python-notify,python-sqlite2,freetype,libpng,tcl,tk,python2.5.1,
python-gtk-2,python-numeric,libgfortran.so.0,coreutils,libblas.so.3,libgcc,pytz
(najtrudniej było mi go znaleźć,zamiast pytz pojawia się python-matplotlib ale się nie nadaje),python-numpy i ostani(phyton-configobj) którego nie znalazłem,ale instalacja poszła bez niego.To by było na tyle.

Ma ktoś może pomysł co zrobić żeby odpalić ten program od Vodafone.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #23 dnia: 2008-02-16, 18:19:17 »
Czy ktoś wie jak uruchomić ten program z konsoli,jaka komenda.Mało co wiem na temat używania konsoli jak chyba nie jeden zielony pingwin,więc jak ktoś ma jakiś pomysł to proszę o rady(tylko po polsku :-) jak można).Jak krowie na rowie-czyli prosto.

benyo

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #24 dnia: 2008-02-16, 20:10:23 »
Cytat: gery_gery
Chyba wszystko gra i mam pytanie A.B.,bo korzystam z twojego opisu dla blueconnecta  i trochę co innego mi pokazało się niż w twoim opisie.Więc co dalej mam z tym zrobić,sorry za te pytania,ale wciąż jeszcze jestem zielonym pingwinem.
Wykonaj wszystko tak jak jest to w opisie http://newbie.linux.pl/?id=article&show=378 zamiast /dev/ttyACM0 prawodopodobnie trzeba wpisac /dev/ttyUSB0, Nie korzystaj z programu kppp lecz wywolaj polaczenie poleceniem pppd call nazwapolaczenia i co wazne wykonaj to z poziomu root, bo czasem konfiguracja udeva w dystrybucji nie zezwala na korzystanie z modemu zwyklemu uzytkownikowi.
Jesli chodzi o numer dzwoniony nie ma znaczenia, probowalem na dowolnym i poszlo. Autoryzacja: w iplusie na ten przyklad nie wymagana jest autoryzacja wiec w pola uzytkownika oraz hasla nic nie nalezy wpisywac (w erze niby jest erainternet, ale ja sobie wpisywalem eragsm i tez poszlo wiec to nie ma znaczenia), sprobuj wiec nie wpisywac loginu ani hasla

TU masz parametry vodafone http://www.filesaveas.com/gprs.html

I napisz co wyrzuca ci konsola jest uzyjesz polecenia 'pppd call nazwapolaczenia'

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #25 dnia: 2008-02-17, 16:25:58 »
Przerobiłem cały artykuł i po użyciu komendy 'pppd...'pojawia się komunikat :Scrypt failed. Więc jeszcze spróbowałem tego:" cat /proc/bus/usb/devices " i komunikat iż taki katalog lub plik nie istnieje.I znowu du...a,coś nie tak.

benyo

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #26 dnia: 2008-02-17, 19:28:04 »
Cytat: gery_gery
Przerobiłem cały artykuł i po użyciu komendy 'pppd...'pojawia się komunikat :Scrypt failed. Więc jeszcze spróbowałem tego:" cat /proc/bus/usb/devices " i komunikat iż taki katalog lub plik nie istnieje.I znowu du...a,coś nie tak.
jesli pojawia sie scrypt failed tzn. ze zle cos napisales w skrypcie a nie ze skrypt jest zly. Ten skrypt na pewno dziala jesli poprawnie sie go przepisze, gdzies popelniasz blad trudno powiedziec gdzie.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #27 dnia: 2008-02-19, 12:35:02 »
Jak to ze skryptami bywa można zrobić bardzo dużo błędów,więc go na razie zostawiam.Wróciłem do Vodafone i tu napiszę trochę bardziej szczegółowo dla młodych pingwinów.Żeby uruchomić ten program w konsoli(powłoce,terminalu) wciskasz f4 lub w menu startu wybierasz terminal.Logujesz się jako administrator(su)w konsoli wpisz su i enter potem podajesz hasło(i enter),a następnie wpisujesz  pełną nazwę programu(to takie proste),można też podać pierwsze 3 litery i wciskasz Tab(klawisz nad Caps Lock-iem) i automatycznie uzupełni resztę nazwy.Tak też zrobiłem i okazało się,że brakuje modułu Pytz(który zainstalowałem wcześniej)więc zainstalowałem go ponownie(4 razy go instalowałem)i dla pewności restart systemu.Kolejna próba za piątym razem już nie pyta o Pytz,ale brakuje jeszcze jednego moduł (conch.manhole)python-twisted-conch.Kolejna próba brak python-crypto  instaluje i odpalam program .Pojawia  się okienko programu(initial setup) i w końcu uśmiech na twarzy,ale nie trwa on długo bo gdy pasek postępu dojdzie do końca nić się nie dzieje(zawiecha czy co).A i po za konsolą ten program nie chce wystartować.Tu jest zrzut ekranu:



Co można dalej z tym zrobić,bo jak konsola nie wyświetla już braków co trzeba,a startuje ten program to jak sprawdzić co jest dalej nie tak.

benyo

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #28 dnia: 2008-02-19, 13:09:19 »
Przyznam szczerze ze teraz to juz nie wiem co tak naprawde chcesz osiagnac?? chcesz sie polaczyc tym modemem czy chcesz uruchomic ten program z Vodafone i w jakim celu??

Sa prostsze sposoby na polaczenie sie z netem za pomoca modemu niz korzystanie z jakiegos programu do ktorego trzeba instalowac mnostwo dodatkowych pakietow dotyczacych Pythona.

gery_gery

  • Gość
karta Huawei E620,bcm4318 problem z konfiguracją SuSE10.1
« Odpowiedź #29 dnia: 2008-02-19, 17:19:00 »
Co chcę osiągnąć to proste połączenie internetowe i obojętnie,którą z dróg.Z vodafone wydaje mi się prostsza i późniejsza kontrola czy tez obsługa tego połączenia,gdyż będzie bardziej zautomatyzowane.Ponieważ program ten pozwala przede wszystkim kontrolę ilości ściąganych danych(gdyż jest limit od operatora)Nawiązanie i zerwanie połączenia w jednym kliknięciu.Wiem że używając skryptu można to zautomatyzować aby np. uruchamiał się przy starcie systemu,ale na tym mi nie zależy,bo limit niestety i liczy się każdy bajt.No i przy skrypcie błędem może być wszystko  jak sam pisałeś będzie o jedną gwiazdkę lub jakiś znak za dużo,błąd w nazwie lub jakaś spacja i nie będzie działać.Dlatego zależałoby mi na tym programie ale jak nie wypali to trzeba będzie się skryptem zająć.