Nowe posty

Autor Wątek: idealna kopia dysku  (Przeczytany 9438 razy)

Opol

  • Gość
idealna kopia dysku
« Odpowiedź #15 dnia: 2005-08-27, 16:11:44 »
Zmienilem log na wzor tego ktory dostalem i po zrestartowaniu systemu nie bylo juz polaczenia na eth0 (w opcji nowe polaczenie>adsl byla do wyboru tylko karta  FireWire-wczesniej jeszcze byla nVidia Ethernet Adpater)

bojleros

  • Gość
idealna kopia dysku
« Odpowiedź #16 dnia: 2005-08-28, 10:29:28 »
2005-08-27 16:11:44 Opol napisał:

> Zmienilem log ?

?????????????????????????????????????????????

To co dostałeś to pliki które siedzą u mnie w /etc/ppp , one stanowią konfiguracje rp-pppoe . Nie wiem coś zrobił jeszcze ze sie interfejs stracił ale napewnpo tak nie powinno być. Musisz cofnąć operacje które wykonałeś . Nie wieżę w to ze po zmianie wpisu w plikach w /etc/ppp stracił się interfejś eth. Może przestań wykonywać operacje przez jakieś konfiguratory graficzne tylko postaraj się o to żeby poprostu:

1. Skrypty startowe ładowały modół do kernela (sterownik karty sieciowej) , jak masz realteka to coś takiego pomoże :

lsmod |grep 8139too -sprawdz czy nie jest juz załadowany

Jezeli nie jest załadowany to : modprobe 8139too

2. Podnieś interfejs i nadaj adres ip :

ifconfig eth0 up
ifconfig eth0

3. Sprawdz czy masz ping do modemu , ppodejzewam ze powinien odpowiedzieć.

4. Sprawdz jeszcze raz konfigurację w /etc/ppp i spróbuj się połaczyć adsl-start i patrz co masz w logach /var/log/messages /var/log/debug i inne w których mozna sie takich informacji spodziewać.


leszekp

  • Gość
idealna kopia dysku
« Odpowiedź #17 dnia: 2005-08-24, 12:39:52 »
Witam! Chciałem przenieść system na nowy dysk bo stary mi się już zapełnił - tylko nie chciałem konfigurować wszystkie od początku tylko jakoś to skopiować. I teraz pytanie jak to zrobić?

Probówałem cp -a /* /mnt/hdb (przy wcześniejszym sformatowaniu i ustawieniu partycji - jednej), poźniej lilo -b /mnt/hdb i zmieniłem ustawienia w /etc/lilo.conf tak zeby było ok i jeszcze raz lilo -b /mnt/hdb i jak odpaliłem z tego drugiego dysku to przy bootowaniu wyskakuje error że zły parametr root - czy jakoś tak - lub błędne urządzenie blokowe :/

Nie wiem czy coś przypadkiem z partycjami nie tak zrobiłem - trzeba dokładnie takie same zrobić jak są na starym dysku? Najlepiej może jakiś tutek krok po kroku :-)

Z góry dzięki...

jk33

  • Gość
idealna kopia dysku
« Odpowiedź #18 dnia: 2005-08-24, 12:53:33 »
2005-08-24 12:39:52 leszekp napisał:

> Witam! Chciałem przenieść system na nowy dysk bo stary mi się już zapełnił - tylko nie chciałem
 > konfigurować wszystkie od początku tylko jakoś to skopiować. I teraz pytanie jak to zrobić?
 >
 > Probówałem cp -a /* /mnt/hdb (przy wcześniejszym sformatowaniu i ustawieniu partycji - jednej),
 > poźniej lilo -b /mnt/hdb i zmieniłem ustawienia w /etc/lilo.conf tak zeby było ok i jeszcze raz
 > lilo -b /mnt/hdb i jak odpaliłem z tego drugiego dysku to przy bootowaniu wyskakuje error że
 > zły parametr root - czy jakoś tak - lub błędne urządzenie blokowe :/
 >
 > Nie wiem czy coś przypadkiem z partycjami nie tak zrobiłem - trzeba dokładnie takie same zrobić
 > jak są na starym dysku? Najlepiej może jakiś tutek krok po kroku :-)
 >
 > Z góry dzięki...

W pliku lilo.conf jest taki wpis
root=/dev/hdXx
i wskazuje on gdzie znajduje się partycja /
jesli przeniosles system na np /dev/hdb1
to musisz zmienic wpis na root=/dev/hdb1

pozdrawiam

leszekp

  • Gość
idealna kopia dysku
« Odpowiedź #19 dnia: 2005-08-24, 14:45:23 »
> W pliku lilo.conf jest taki wpis
 > root=/dev/hdXx
 > i wskazuje on gdzie znajduje się partycja /
 > jesli przeniosles system na np /dev/hdb1
 > to musisz zmienic wpis na root=/dev/hdb1
 >
 > pozdrawiam
 >

hm... no niby tak ale ja chce te dyski zamienić (czyli zmienią się literki czyż nie?) Będzie bootowało z tego nowego dysku... mam ustawione:

# By default boot the pld entry
default=pld
# Wait 5 seconds for booting
timeout=50
# Default bootpartition
boot=/dev/hda
# well, we want to be asked...
prompt
# menu stuff ;)
menu-title = "PLD Linux"
menu-scheme = "wk:kc:ck:Ck"
read-only
# additional:
lba32
# Linux image
image=/boot/vmlinuz
        root=/dev/hda1
        label=pld
        initrd=/boot/initrd
# EOF

a partycje na dysku wyglądają tak:

Disk /dev/hdb: 20.0 GB, 20020396032 bytes
16 heads, 63 sectors/track, 38792 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1       38792    19551136+  83  Linux

jak mówie - chce zmienić miejsce dysku starego ktory teraz podpiety jest na IDE 0 / Primary na tego z hdb więc powinno działać :|

No ale w sumie nie powiedziałeś czy wystarczy to cp -a /* /mnt/hdb czy trzeba konfigurować jakoś te partycje bardziej?

xavery

  • Gość
idealna kopia dysku
« Odpowiedź #20 dnia: 2005-08-24, 14:51:34 »
> No ale w sumie nie powiedziałeś czy wystarczy to cp -a /* /mnt/hdb czy trzeba konfigurować
 > jakoś te partycje bardziej?
 >

Bardziej. Uaktualnij dodatkowo /etc/fstab