Nowe posty

xx Fedora xfce i flatpak oraz snap (1)
Dzisiaj o 06:59:46
xx Strona o testach penetracyjnych, hackingu (34)
2022-05-25, 11:40:38
xx Repozytorium z czcionkami M$ (2)
2022-05-24, 17:58:30
xx Pomoc w wyborze środowiska graficznego (11)
2022-05-23, 22:41:56
xx Usunąłem przez przypadek /bin co zrobić? (2)
2022-05-23, 21:36:24
xx Obrócony obraz lubuntu, xubuntu na lenovo Miix 320 (6)
2022-05-23, 11:56:25
xx Pierwsze kroki w Arch (9)
2022-05-22, 23:39:51
xx DBus (0)
2022-05-22, 12:47:35
xx Przedni panel (1)
2022-05-20, 01:34:35
xx Modem Medion S4222 jak zainstalować aplikację do jego obsługi? (52)
2022-05-18, 10:14:49

Autor Wątek: Nie można zainstalować Kadu - mile widziana łopatologia.  (Przeczytany 7298 razy)

Necro19

  • Gość
Mam problem ze skompilowaniem gliba. Kiedy wchodzę do katalogu gdzie jest rozpakowany, wpisuję ./configure  i pojawia mi się coś takiego:

[mateusz@localhost glib-1.2.10]$ ./configure
./configure: line 464: ./config.log: Permission denied
[mateusz@localhost glib-1.2.10]$ su
Password:
[root@localhost glib-1.2.10]# ./configure
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking host system type... configure: error: can not guess host type; you must specify one
[root@localhost glib-1.2.10]#
[root@localhost glib-1.2.10]#

Co mam robić, aby wszystko zadziałało?

xis

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #1 dnia: 2005-08-23, 21:32:22 »
2005-08-23 21:12:20 Necro19 napisał:

> Mam problem ze skompilowaniem gliba. Kiedy wchodzę do katalogu gdzie jest rozpakowany, wpisuję
 > ./configure  i pojawia mi się coś takiego:
 >
 > [mateusz@localhost glib-1.2.10]$ ./configure
 > ./configure: line 464: ./config.log: Permission denied
 > [mateusz@localhost glib-1.2.10]$ su
 > Password:
 > [root@localhost glib-1.2.10]# ./configure
 > loading cache ./config.cache
 > checking for a BSD compatible install... /usr/bin/install -c
 > checking whether build environment is sane... yes
 > checking whether make sets ${MAKE}... yes
 > checking for working aclocal... missing
 > checking for working autoconf... missing
 > checking for working automake... missing
 > checking for working autoheader... missing
 > checking for working makeinfo... missing
 > checking host system type... configure: error: can not guess host type; you must specify one
 > [root@localhost glib-1.2.10]#
 > [root@localhost glib-1.2.10]#
 >
 > Co mam robić, aby wszystko zadziałało?

Oo, kolego.
Nie za wcześnie na kompilowanie pakietów?
Może przećwicz jeszcze instalację binarek. Na http://rpm.pbone.net znajdziesz na pewno pakiet binarny glibc dla Twojej dystryubucji (jest tam opcja \\'Zaawansowane szukanie\\' pozwalająca na wybór dystrybucji).
Za kompilację się weź jak już obeznasz się lepiej ze swoim systemem i po tym jak przeczytasz artykuły na tej stronie.
Powodzenia

gure

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #2 dnia: 2005-08-24, 03:37:38 »
a jak juz musisz kompilowac to zazwyczaj dobrym pomyslem jest uwazne czytanie tego co kompilator wyrzuca i w miare rozsadne robienie tego o co prosi (jesli sam czego nie robi)

w twoim przypadku zgodze sie z przedmowca ze pakiety beda najprostrzym i najszybszym rozwiazaniem

a co do twojej kompilacji, to raczej nie zabardzo da sie skompilowac i zainstalowac glibca na uzyszkodniku, wiec slusznie zaczales robic to z root\\'a, a jak juz stwierdzil ze nie wie pod jaki host type ma kompilowac, to wklikaj #./conigure --help | less i sobie na spokojnie przejrzyj pomoc configuraci,bo a nuz sie da mu to wstukac recznie, co rozwiaze caly problem

ps. sprawdz tez czy masz wszystkie narzedzia wymagane do kompilacji

Necro19

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #3 dnia: 2005-08-24, 10:10:31 »
2005-08-24 03:37:38 gure napisał:

> a jak juz musisz kompilowac to zazwyczaj dobrym pomyslem jest uwazne czytanie tego co kompilator
 > wyrzuca i w miare rozsadne robienie tego o co prosi (jesli sam czego nie robi)
 >
 > w twoim przypadku zgodze sie z przedmowca ze pakiety beda najprostrzym i najszybszym
 > rozwiazaniem
 >
 > a co do twojej kompilacji, to raczej nie zabardzo da sie skompilowac i zainstalowac glibca na
 > uzyszkodniku, wiec slusznie zaczales robic to z root\\'a, a jak juz stwierdzil ze nie wie pod
 > jaki host type ma kompilowac, to wklikaj #./conigure --help | less i sobie na spokojnie
 > przejrzyj pomoc configuraci,bo a nuz sie da mu to wstukac recznie, co rozwiaze caly problem
 >
 > ps. sprawdz tez czy masz wszystkie narzedzia wymagane do kompilacji


jako root wpisałem ./configure --help | less no i nic. :(

niby już glibca zainstalowałem z pakietu, czy źródła są nadal potrzebne?

xis

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #4 dnia: 2005-08-24, 11:34:19 »
Po raz kolejny:
glibc to nie glib!
Rozróżniajcie te pakiety!

A jeśli zainstalujesz z pakietu to nie musisz już nic instalować ze źródeł.

xis

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #5 dnia: 2005-08-24, 12:05:21 »
>  > [root@localhost glib-1.2.10]#
 >  > [root@localhost glib-1.2.10]#
 >  >
-----------------------------
 > Na http://rpm.pbone.net znajdziesz na pewno pakiet
 > binarny glibc dla Twojej dystryubucji (jest tam opcja \\'Zaawansowane szukanie\\' pozwalająca na
 > wybór dystrybucji).

Ja tak pouczam, a sam się walnąłem :)
Sorry

Necro19

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #6 dnia: 2005-08-23, 17:08:53 »
Ściągnąłem Kadu 0.4.0-2 (ofcoz w RPM) i spróbowałem go zainstalować. System zwrócił coś takiego:
Niektóre z wybranych pakietów nie mogą zostać zainstalowane:
kadu-0.4.0-2.i586 (z powodu niesatysfakcjonującego pakietu libsndfile.so.1)

Mam Mandrivę 2005 LE (dawniej znaną jako Mandrake 10.2)

Xax79

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #7 dnia: 2005-08-23, 17:18:40 »
2005-08-23 17:08:53 Necro19 napisał:

> Ściągnąłem Kadu 0.4.0-2 (ofcoz w RPM) i spróbowałem go zainstalować. System zwrócił coś
 > takiego:
 > Niektóre z wybranych pakietów nie mogą zostać zainstalowane:
 > kadu-0.4.0-2.i586 (z powodu niesatysfakcjonującego pakietu libsndfile.so.1)
 >
 > Mam Mandrivę 2005 LE (dawniej znaną jako Mandrake 10.2)

libsndfile.so.1 nalezy do pakietu ... uwaga: libsndfile. A to niespodzianka.

Proponuje zainteresowac sie czy i jaka wersja jest zainstalowana i zainstalowac/uaktualnic.

Necro19

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #8 dnia: 2005-08-23, 17:22:36 »
2005-08-23 17:18:40 Xax79 napisał:

 > libsndfile.so.1 nalezy do pakietu ... uwaga: libsndfile. A to niespodzianka.
 >
 > Proponuje zainteresowac sie czy i jaka wersja jest zainstalowana i zainstalowac/uaktualnic.

Ale w jaki sposób? Bo ja totalny newbie jestem jeśli chodzi o linuxa :/

Aha, do tego dochodzi jeszcze pakiet libssl czy coś w ten deseń. Błąd pojawił się przy instalacji Balsy.

xis

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #9 dnia: 2005-08-23, 20:00:22 »
2005-08-23 17:08:53 Necro19 napisał:

 > Niektóre z wybranych pakietów nie mogą zostać zainstalowane:
 > kadu-0.4.0-2.i586 (z powodu niesatysfakcjonującego pakietu libsndfile.so.1)
 >

Dam Ci małą radę:
Jeśli następnym razem pojawi Ci się taki komunikat, to wejdź na http://rpm.pbone.net i wpisz tam nazwę szukanego pliku.
Dostaniesz w odpowiedzi nazwę pakietu, do którego plik należy.
Możesz wtedy ściągnąć porządany pakiet, albo (zalecane) poszukać takiego na płytkach instalacyjnych swojego systemu.

Innym sposobem jest konfiguracja URPMI, które same dba o spełnienie zależności (opis konfiguracji znajdziesz w artykułach na tej stronie).

Necro19

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #10 dnia: 2005-08-23, 20:15:23 »
2005-08-23 20:00:22 xis napisał:
 > Dam Ci małą radę:
 > Jeśli następnym razem pojawi Ci się taki komunikat, to wejdź na http://rpm.pbone.net i wpisz
 > tam nazwę szukanego pliku.
 > Dostaniesz w odpowiedzi nazwę pakietu, do którego plik należy.
 > Możesz wtedy ściągnąć porządany pakiet, albo (zalecane) poszukać takiego na płytkach
 > instalacyjnych swojego systemu.
 >
 > Innym sposobem jest konfiguracja URPMI, które same dba o spełnienie zależności (opis
 > konfiguracji znajdziesz w artykułach na tej stronie).
 >

No dobra, zainstalowałem Kadu, a teraz, jak dodać do niego skrót na pulpicie?

xis

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #11 dnia: 2005-08-23, 20:17:01 »
Użyj głowy :)
A później prawego klawisza myszy na pulpicie.

Necro19

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #12 dnia: 2005-08-23, 20:27:01 »
2005-08-23 20:17:01 xis napisał:

> Użyj głowy :)
 > A później prawego klawisza myszy na pulpicie.

Już rozwiązałem :D

Zaczynam coraz lepiej łapać tego Linuxa, dzięki za pomoc! U ROX!!

stonoga

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #13 dnia: 2005-08-28, 23:37:05 »
a jesli ktos niechce korzystac z rpm, mozecie podac nazwe biblioteki w ktorej znajduje sie "libssl", wolalbym sam kompilwac bo podobno jest lepsza wydajnosc i stabilnosc, ja takze jestem newbie, takze prosze o wyrozumialosc :P
Gdzies na forum znalazlem info ze to: openssl, ale instalacja nie pomogla, byc moze zle to skonfigurowalem, moze powinienem wpisac cos w stylu ./configure --prefix=/usr, a moze to nie te biblioteki, bede wdzieczny za wszelka konstruktywna krytyke, tylko nie jedzcie ze nma za bardzo :D

jcd

  • Gość
Nie można zainstalować Kadu - mile widziana łopatologia.
« Odpowiedź #14 dnia: 2005-08-29, 13:20:06 »
2005-08-28 23:37:05 stonoga napisał:

> a jesli ktos niechce korzystac z rpm, mozecie podac nazwe biblioteki w ktorej znajduje sie
 > "libssl"

libssl mozna znalezc w openssl (www.openssl.org)