Nowe posty

xx Program do obróbki zdjęć (14)
Dzisiaj o 08:33:11
xx Pomoc dla Lwa (kotka) (0)
Wczoraj o 10:42:59
xx Mulenie strony [Tylko informacja] (0)
2020-02-25, 16:36:43
xx Film Hakerzy dla wolności 2018 lektor (0)
2020-02-25, 08:47:38
xx Mageia instalacja (1)
2020-02-24, 14:43:32
xx Zlecę skrypt w bashu (0)
2020-02-19, 14:07:39
xx Nadawanie praw katalogom takich, jak nazwa usera (4)
2020-02-17, 14:15:18
xx Fedora na laptopie HP 15-bs152nw brak wifi (44)
2020-02-16, 12:17:18
xx Komputer do nauki linuxa (10)
2020-02-15, 07:03:28
xx Patronat serwisow internetowych. (1)
2020-02-13, 00:13:24

Autor Wątek: Problem z instalacją opery  (Przeczytany 4132 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Problem z instalacją opery
« dnia: 2007-12-12, 15:05:05 »
3 dni temu zainstalowałem u siebie openSUSE 10.3 i wkroczyłem po omacku w nieznany mi dotad świat linuxa.
jak dotąd z przesiadki jestem dość zadowolony jednak brak biegłej znajomości systemu powoduje pewne zgrzyty mianowicie:
Postanowiłem zainstalowac Opere, ze stronki pobrałem wersje dla linuxa w postaci pliku o formacie RPM.
Troche czasu zajeło mi dojście do tego jak ten plik zagryść.
Na chwile obecna wiem ze potrzeba mi do tego odpowiedniego polecenia w konsoli poleceń.
jednak próba instalacji kończy się następującym komunikatem w terminalu.
"trewor007@trewor007-linux-e6hw:~/RPM/RPMS> rpm -i opera.rpm
błąd: Niespełnione zależności:
        libqt-mt.so.3 jest wymagany przez opera-9.24-20071015.5.i386
trewor007@trewor007-linux-e6hw:~/RPM/RPMS> "

wyszukałem w google libqt-mt.so.3 i dostałem dzięki temu plik qt3-3.3.8-76.src.rpm
i błąd występuje nadal.
Plik z operą znajduje się w ścieżce /home/trewor007/RPM/RPMS czy mam go gdzieś przenieść czy coś w tym stylu.
Prosze o instrukcje co dalej zrobić lub jakiś link gdzie będzie to wyjaśnione w miare zrozumiały dla laika sposób.
Z góry dzięki.
Post na forum- stan umysłowo czasowy w którym umysł nie jest już w stanie stworzyć żadnego konstruktywnego rozwiązania problemu.

Czasami mam wrażenie że informatycy tylko czekają aż jakiś newbie napisze coś głupiego by wkleić jego text na bash.org

Offline

  • Users
  • Guru
  • *****
  • Wiadomości: 1403
    • Zobacz profil
Problem z instalacją opery
« Odpowiedź #1 dnia: 2007-12-12, 15:08:36 »
a kliknięcie myszką na rpm'ie i wpisanie hasła nie pomaga? Niemożliwe, aby tak szanująca się dystrybucja jak OpenSUSE nie miała prostego mechanizmu instalacji rpm'ów... Przynajmniej w innych dystrybucjach jak np. Ubuntu, instalowanie ściągniętych paczek odbywa się przez dwuklik na paczce i wpisaniu hasła...
:P

Offline Grzegorz Świtkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 516
    • Zobacz profil
Problem z instalacją opery
« Odpowiedź #2 dnia: 2007-12-12, 16:35:14 »
Cytat: trewor007
"trewor007@trewor007-linux-e6hw:~/RPM/RPMS> rpm -i opera.rpm
błąd: Niespełnione zależności:
        libqt-mt.so.3 jest wymagany przez opera-9.24-20071015.5.i386
trewor007@trewor007-linux-e6hw:~/RPM/RPMS> "

wyszukałem w google libqt-mt.so.3 i dostałem dzięki temu plik qt3-3.3.8-76.src.rpm
i błąd występuje nadal.
Literki src w nazwie pliku qt3-3.3.8-76.src.rpm oznaczają, że jest to pakiet ze źródłami a nie binariami. To po pierwsze. Po drugie - instalując pakiety musisz mieć prawa do zapisu do katalogów systemowych a więc polecenie rpm -i czy rpm -U należy wykonywać z konta root'a. A po trzecie to zamiast ściągać brakujące pakiety, skonfiguruj repozytoria SuSe i wtedy nie będziesz miał żadnych problemów z instalowaniem. Generalnie poczytaj o RPM (RedHat Package Manager) o zależnościach i o menadżerach pakietów.

Offline Tomasz Kułaga

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 29
    • Zobacz profil
Problem z instalacją opery
« Odpowiedź #3 dnia: 2007-12-12, 17:00:13 »
a dlaczego pobrałeś rpm'a?? nie ma czasem na stronie opery gotowej paczki dla openSUSE??

Offline

  • Users
  • Guru
  • *****
  • Wiadomości: 1403
    • Zobacz profil
Problem z instalacją opery
« Odpowiedź #4 dnia: 2007-12-12, 17:39:43 »
Cytat: LongeR89
a dlaczego pobrałeś rpm'a?? nie ma czasem na stronie opery gotowej paczki dla openSUSE??
RPM to co niby jak nie gotowa paczka? ;)
:P

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
Problem z instalacją opery
« Odpowiedź #5 dnia: 2007-12-13, 08:03:49 »
Obawiam się, że libqt-mt.so jest już na Twoim komputerze (bez niego nie 'poszłoby' np. KDE), tyle, że w innej wersji.
Instalacja pakietów 'zewnętrznych' tj. spoza dystrybucji jest ryzykowna, dlatego zawsze staraj się - w miarę możliwości - instalować pakiety z repozytoriów przygotowanych pod konkretną wersję swojej dystrybucji. W OpenSUSE robi się to z poziomu YAST'a.
Zerknij tu po więcej informacji: http://www.susek.info/article/Instalacja-pakietu-Opera.shtml
Everything should be made as simple as possible, but not simpler
-- Albert Einstein