Nowe posty

Autor Wątek: check.sh, xfree86, stery ATI cdn.  (Przeczytany 5702 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 26
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« dnia: 2005-08-23, 12:26:46 »
Witam,
jako że jestem świeżo upieczonym użytkownikiem Mandrake 10.0, mam dużo pytań
1. Chcę zainstalowac Tkabbera. Jak już napisałem \\"make install\\" wyskakuje mi:
mkdir -p //usr/local/share/tkabber
cp -r *.tcl aniemoteicons emoticons-tkabber ifaceck ifacetk plugins jabberlib-tclxml pixmaps sounds textundo msgs mclistbox-1.02 //usr/local/share/tkabber
mkdir -p //usr/local/share/doc/tkabber/
cp -r examples //usr/local/share/doc/tkabber
mkdir -p //usr/local/bin/
echo -e \\"#!/bin/shnexec wish /usr/local/share/tkabber/tkabber.tcl -name tkabber \\"$@\\"n\\" > //usr/local/bin/tkabber
chmod +x //usr/local/bin/tkabber

Sprawdziłem te dwa katalogi ale tylko w //usr/local/share/ jest katalog tkabber
Czytałem, że do uruchomienia tego programu trzeba wpisać w konsoli tkabber.tcl ale nic się nie dzieje pisze tylko że nie ma takiej komendy. Może trzeba coś dodać przed

2. Sięgnąłem do innego klienta jabbera Gajim ale ściągnełem plik \\"gajim-0.8-1.x86.package\\" jak mogę to rozpakować? zainstalować?

3. I jeszcze jedno. Chciałem zainstalowac xmms-a ale pisze że potrzeba lepszej wersji glib-a. Czytałem  na ten temat i wiem że najpierw trzeba odinstalować       starą bibliotekę. Ale czytałem gdzieś że lepiej nie odinstalowywać starej a po prostu zainstalować nową \\"z binarek?!\\" albo jako pakiet .rpm, którego jednak znaleźć nie mogę
                       Proszę o pomoc, z góry dziękuję..

Offline Mateusz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #1 dnia: 2005-08-23, 10:09:42 »
jestem szczesliwym (jak szczesliwym) posiadaczem Mandrakelinux 10.1 Community wersja Download. Mam problem z zainstalowaniem sterowników do ATI. Moja karta graficzna to Radeon 9200 SE. Już sam fakt ze jak odpalam plik check.sh pisze mi: =====================================================================
 ATI Technologies
=====================================================================
You are either not running this script from the console
or simply do not have console ownership.  Requirement failed.
Unable to determine XFree86 Version. Stopping now.

ale zakładając że mam wersje xfree86 tą samą co pod Mandrakelinux 10.0 sciagnalem sobie plik o nazwie fglrx_4_2_0-8.16.20-1.i386.rpm. Po odpaleniu tego pliku wyskakuje mi napis:
błąd: cannot open lock file ///var/lib/rpm/RPMLOCK in exclusive mode
błąd: nie można otworzyć bazy danych Packages w /var/lib/rpm

a ściągając wersje 4.3.0 napis głosi że nie mozna zainstalowac gdyz ma konflik z jakąś biblioteką lib.Gl.so czy coś takiego :/ w każdym razie ma napis z gl. Jak zainstaluje tą wersje xfree to później pójdzie jak z płatka tylko prosze teraz o pomoc.

Offline grzegorz s

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 234
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #2 dnia: 2005-08-24, 00:44:17 »
obstawiam, ze nie masz XFree tylko Xorg

Offline michu seishin

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 123
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #3 dnia: 2005-08-24, 03:48:45 »
2005-08-24 00:44:17 leiah napisał:

> obstawiam, ze nie masz XFree tylko Xorg

w mandarynce 10 bylo jednak (chyba) jeszcze xfree

a zreszta co za roznica?

osobiscie mam slck_current(recznie kompilowany xorg-6.8.2) z radkiem 9600 i jak instaluje fglrx to najpierw mi twierdzi ze wszystko git, potem ze nie byl w stanie ukonczyc kompilacji sterownika (mimo ze go skapilowal) i w efekcie wszystko dziala jak marzenie

Offline grzegorz s

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 234
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #4 dnia: 2005-08-24, 10:23:35 »
2005-08-24 03:48:45 gure napisał:

> 2005-08-24 00:44:17 leiah napisał:
 >
 > > obstawiam, ze nie masz XFree tylko Xorg
 >
 > w mandarynce 10 bylo jednak (chyba) jeszcze xfree
 >
 > a zreszta co za roznica?

ano taka, ze jeśli sie nie mylę check.sh odpowiada za rozpoznanie wersji X`ów i do niedawna miał powazne problemy z rozpoznaniem Xorg (czyt. nie rozpoznawał ich wogóle)

 >
 > osobiscie mam slck_current(recznie kompilowany xorg-6.8.2) z radkiem 9600 i jak instaluje fglrx
 > to najpierw mi twierdzi ze wszystko git, potem ze nie byl w stanie ukonczyc kompilacji
 > sterownika (mimo ze go skapilowal) i w efekcie wszystko dziala jak marzenie

swoją drogą sterownik ATi jest tak irracjonalny, że potrafi zaskakiwać niekonsekwencją (errory w logach u mnie tez sie pojawiają, tylko po to wy potem okazało się, że wszystko jest ok)

Offline grzegorz s

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 234
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #5 dnia: 2005-08-24, 10:24:31 »
a swoją drogą - odpalasz check.sh pod konsolą w trakcie pracy Xów?

Offline Mateusz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #6 dnia: 2005-08-24, 13:52:30 »
2005-08-24 10:24:31 leiah napisał:

> a swoją drogą - odpalasz check.sh pod konsolą w trakcie pracy Xów?

hmm chyba tak ^^ jestem troche lama w linuxie skoro X-y to system graficzny to tak :P ale odpalam w konsoli. a tak przy okazji cały tekst komunikatou podczas instalacji pakietu xfree86 4.2.0:  
file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx_4_2_0-8.16.20-1 conflicts with file from package libxorg-x11-6.7.0-2mdk

ale moze maci ei racje sproboje sciagnac xorg a jak nei bedzie dzialalo to dam znac

Offline grzegorz s

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 234
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #7 dnia: 2005-08-24, 18:32:30 »
odpalam w konsoli. a tak przy okazji cały tekst komunikatou podczas instalacji pakietu xfree86
 > 4.2.0:  
 > file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx_4_2_0-8.16.20-1 conflicts with file from
 > package libxorg-x11-6.7.0-2mdk
a jednak Xorg.
sterowniki ATi są chyba w wersjach dla XFree86 i Xorg?
pobierz sobie ze strony ATi sterownik w wersji z garaficznym instalatorem. zbudujesz sobie wtedy sterownik pod własną dystrybucję. powinno byc ok :-)

Offline Mateusz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #8 dnia: 2005-08-24, 22:09:40 »
hmm instaluje XOrg 6.2.0 oto jak wpisuje:

$ rpm -i fglrx_6_8_0-8.16.20-1.i386.rpm

i pokazuje mi sie napis:

błąd: cannot open lock file ///var/lib/rpm/RPMLOCK in exclusive mode
błąd: nie można otworzyć bazy danych Packages w /var/lib/rpm

Ja już nie wiem o co w tym chodzi :/ . Czy chodzi o to ze mam najpierw zainstalowac X-Server a potem sterowniki czy to albo to ? bo sam już nie wiem :/ a a jak wpisuje:

# ./ati-driver-installer-8.16.20-i386.run (graficzna wersaja instalacji sterownikow chyba)

pokazuje mi się to:

Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.16.20...............................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: unable to detect
Removing temporary directory: fglrx-install

nie wiem o co chodzi teraz już wogóle :/ ale na was można lioczyć i na pewno pomożecie ja to wiem ! :D


Offline grzegorz s

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 234
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #9 dnia: 2005-08-24, 22:26:43 »
2005-08-24 22:09:40 Other napisał:

> hmm instaluje XOrg 6.2.0 oto jak wpisuje:
 >
 > $ rpm -i fglrx_6_8_0-8.16.20-1.i386.rpm

tym poleceniem instalujesz stery, nie serwer X.
spróbuj przez URPMi zaktualizowac najpierw Xorg.
 
 
 > i pokazuje mi sie napis:
 >
 > błąd: cannot open lock file ///var/lib/rpm/RPMLOCK in exclusive mode
 > błąd: nie można otworzyć bazy danych Packages w /var/lib/rpm

czyzby sypnęła ci się baza danych zainstalowanych pakietów?
a może po prostu ostatnia instalacja zakończyła się niepowodzeniem i masz np. niespełnione zalezności między jakimiś paczkami - sorry, nie znam na tyle mdk (używam suse), żeby podpowiedzieć? spróbuj RPMDrake, czy jak to się tam zwie pogrzebać?

 >
 > Ja już nie wiem o co w tym chodzi :/ . Czy chodzi o to ze mam najpierw zainstalowac X-Server a
 > potem sterowniki czy to albo to ?
najpierw zainstaluj najnowszy serwer X, potem odpowiedniego fglrx`a i zrób moduły kernela

 bo sam już nie wiem :/ a a jak wpisuje:
 >
 > # ./ati-driver-installer-8.16.20-i386.run (graficzna wersaja instalacji sterownikow chyba)
 >
 > pokazuje mi się to:
 >
 > Creating directory fglrx-install
 > Verifying archive integrity... All good.
 > Uncompressing ATI Proprietary Linux
 > Driver-8.16.20. > ==================================================
 >  ATI Technologies Linux Driver Installer/Packager
 > ==================================================
 > Detected configuration:
 > Architecture: i686 (32-bit)
 > X Server: unable to detect
 > Removing temporary directory: fglrx-install
 >
odpalasz to bedąc w sesji X`ów zalogowanym jako root, czy jako użytkownik? u mine suse nie pozwoliło mi na otwarcie okna programu z uprawnieniami roota (uruchomionego spod konsoli), musiałem odpalac sesję X jako root. Wiem, że mozna jakos to obejść, ale sam niejestem zbyt dobry w te klocki.

Offline Mateusz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #10 dnia: 2005-08-25, 21:34:21 »
coś czuje że nie dam sobie rady z tymi sterownikami :/ robiłem reinstall systemu i to samo. A nie chcę wracać do windowsa :( jak ktoś jest zainteresowany żeby mi pomóc to pisać na gg: 7761415, na maila: other5@o2.pl albo umieszczac jakies konkretne porady czy tez pytanie pomogace udzielic odpowiedz w tym wątku na forum. Dziękuję...

Offline Franciszek Raś

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 213
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #11 dnia: 2005-08-25, 22:04:31 »
W Mdk 10.1 Official jest X11 6.7.0 i u Ciebie też się taki komunikat pojawił:
<... conflicts with file from package libxorg-x11-6.7.0-2mdk...>
Mam taką samą kartę lecz niczego dodatkowego nie instalowałem; działają mi sterowniki z płyty instalacyjnej.
Jako kartę podałem: Ati Radeon ( fglrx ).

Offline Remigiusz Witkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
check.sh, xfree86, stery ATI cdn.
« Odpowiedź #12 dnia: 2005-08-26, 09:27:12 »
2005-08-23 10:09:42 Other napisał:

> jestem szczesliwym (jak szczesliwym) posiadaczem Mandrakelinux 10.1 Community wersja Download.
 > Mam problem z zainstalowaniem sterowników do ATI. Moja karta graficzna to Radeon 9200 SE. Już
 > sam fakt ze jak odpalam plik check.sh pisze mi:
 > =====================================================================
 >  ATI Technologies
 > =====================================================================
 > You are either not running this script from the console
 > or simply do not have console ownership.  Requirement failed.
 > Unable to determine XFree86 Version. Stopping now.
 >
 > ale zakładając że mam wersje xfree86 tą samą co pod Mandrakelinux 10.0 sciagnalem sobie plik o
 > nazwie fglrx_4_2_0-8.16.20-1.i386.rpm. Po odpaleniu tego pliku wyskakuje mi napis:
 > błąd: cannot open lock file ///var/lib/rpm/RPMLOCK in exclusive mode
 > błąd: nie można otworzyć bazy danych Packages w /var/lib/rpm
 >
 > a ściągając wersje 4.3.0 napis głosi że nie mozna zainstalowac gdyz ma konflik z jakąś
 > biblioteką lib.Gl.so czy coś takiego :/ w każdym razie ma napis z gl. Jak zainstaluje tą wersje
 > xfree to później pójdzie jak z płatka tylko prosze teraz o pomoc.
 >

 Najpierw zainstaluj Xorg 6.8.x , np. z wersji LE 2005 (pakiety rpm ) , potem sterowniki , proponuje tradycyjnie bez graficznego instalatora  nastepnie fglrxconfig i cieszyć się nowymi sterami :)