Nowe posty

Autor Wątek: [gentoo] Zapychajacy sie RAM i procek przy kompilacji  (Przeczytany 6147 razy)

Nasser22

  • Gość
Witam
Mam serwer postawiony na gentoo, zrobiłem na nim logowanie za pomocą pary kluczy i chciałem wyłączyc logowanie hasłami dla bezpieczeństwa, jednak mam problem, w sshd_config wyłączam logowanie za pomocą haseł i pomimo restartu sshd nadal jest możliwość logowania na hasło, restartowałem nawet całey serwer i nic. Gdzie jest haczyk?
Pozdrawiam i proszę o odpowiedź

Xax79

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #1 dnia: 2005-08-23, 16:03:13 »
2005-08-22 23:01:05 Nasser22 napisał:

> Witam
 > Mam serwer postawiony na gentoo, zrobiłem na nim logowanie za pomocą pary kluczy i chciałem
 > wyłączyc logowanie hasłami dla bezpieczeństwa, jednak mam problem, w sshd_config wyłączam
 > logowanie za pomocą haseł i pomimo restartu sshd nadal jest możliwość logowania na hasło,
 > restartowałem nawet całey serwer i nic. Gdzie jest haczyk?
 > Pozdrawiam i proszę o odpowiedź

A ktora to opcja wylaczyles logowanie na haslo ?
Czy przypadkiem nie jest tak, ze logowanie za pomoca klucza nie do konca dziala tak jak powinno ?



Nasser22

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #2 dnia: 2005-08-24, 08:44:21 »
2005-08-23 16:03:13 Xax79 napisał:

> 2005-08-22 23:01:05 Nasser22 napisał:
 >
 > > Witam
 >  > Mam serwer postawiony na gentoo, zrobiłem na nim logowanie za pomocą pary kluczy i
 > chciałem
 >  > wyłączyc logowanie hasłami dla bezpieczeństwa, jednak mam problem, w sshd_config
 > wyłączam
 >  > logowanie za pomocą haseł i pomimo restartu sshd nadal jest możliwość logowania na
 > hasło,
 >  > restartowałem nawet całey serwer i nic. Gdzie jest haczyk?
 >  > Pozdrawiam i proszę o odpowiedź
 >
 > A ktora to opcja wylaczyles logowanie na haslo ?
 > Czy przypadkiem nie jest tak, ze logowanie za pomoca klucza nie do konca dziala tak jak powinno
 > ?
 >
 >
 >
Logowanie na klucze działa bez zarutu a co do opcji, którą wyłączyłem to w pliki sshd_config jest PasswordAuthentication no jak widać ustawiony parametr na \\"no\\" dodam, że mam drugi serwer w sieci na slacku postawiony, właściwie maszyna robocza :-) gdzie również jest logowanie na klucze i powyższa opcja tak samo ustawiona i działa bez zarzutu

Neonioo

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #3 dnia: 2005-08-22, 19:50:53 »
Witam.
Mam problem z moim gentoo, przy kompilacji niektórych programów np. wine, PyQt w pewnym momencie zapycha mi się RAM, zużycie procka skacze do 100% i już nic nie da się zrobić. Komputer staje i pomaga tylko twardy reset. W czym może leżeć problem?
Używam GCC 3.4.4
a tu mój make.conf:

CFLAGS="-O2 -fomit-frame-pointer -funroll-loops -ffast-math -mmmx -m3dnow -msse -msse2"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="-march=k8 -O2 -ffast-math -fomit-frame-pointer -funroll-loops -mmmx -m3dnow"
USE="X kde kdelibs multilib atm mppe-mppc activefilter 3dnow sse sse2 mmx linguas_pl v4l divx vidix vcd mmap aac aalib a52 win32codecs jack theora xine xinerama nas musicbrainz nptl nptlonly opengl asf swf wma mp3 kdeenablefinal fortran xmms tk tcl opengl"
ACCEPT_KEYWORDS="~amd64"
AUTOCLEAN="yes"
LINGUAS="pl en"
LANGUAGE=48
LC_ALL="pl_PL"
   

Procek to athlon64 3000+, a RAMu mam 512MB

Maciek_Rutecki

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #4 dnia: 2005-08-22, 20:39:17 »
2005-08-22 19:50:53 Neonioo napisał:

> Witam.
 > Mam problem z moim gentoo, przy kompilacji niektórych programów np. wine, PyQt w pewnym
 > momencie zapycha mi się RAM, zużycie procka skacze do 100% i już nic nie da się zrobić.
 > Komputer staje i pomaga tylko twardy reset. W czym może leżeć problem?
 > Używam GCC 3.4.4
 > a tu mój make.conf:
 >
 > CFLAGS="-O2 -fomit-frame-pointer -funroll-loops -ffast-math -mmmx -m3dnow -msse
 > -msse2"
 > CHOST="x86_64-pc-linux-gnu"
 > CXXFLAGS="-march=k8 -O2 -ffast-math -fomit-frame-pointer -funroll-loops -mmmx
 > -m3dnow"
 > USE="X kde kdelibs multilib atm mppe-mppc activefilter 3dnow sse sse2 mmx linguas_pl v4l
 > divx vidix vcd mmap aac aalib a52 win32codecs jack theora xine xinerama nas musicbrainz nptl
 > nptlonly opengl asf swf wma mp3 kdeenablefinal fortran xmms tk tcl opengl"
 > ACCEPT_KEYWORDS="~amd64"
 > AUTOCLEAN="yes"
 > LINGUAS="pl en"
 > LANGUAGE=48
 > LC_ALL="pl_PL"
 >    
 >
 > Procek to athlon64 3000+, a RAMu mam 512MB

Witam

Nie znam Gentoo, ale czesto problemy z kompilacja wiaza sie z wadliwym RAMem (lub niewlasciwymi flagami podczas kompilacji, ale tutaj niech gentoowcy sie wypowiedza).

--
Maciek

jk33

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #5 dnia: 2005-08-22, 21:26:50 »
na gentoo sie nie znam, ale moze pomoze usuniecie flagi -funroll-loops

pozdrawiam

Neonioo

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #6 dnia: 2005-08-22, 22:43:48 »
2005-08-22 21:26:50 jk33 napisał:

>
 > na gentoo sie nie znam, ale moze pomoze usuniecie flagi -funroll-loops
 >
 > pozdrawiam
 >
Nie pomogło, a RAM jest na 99% sprawny, bo pare dni temu był testowany memtestem przez 12h

xis

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #7 dnia: 2005-08-22, 23:47:48 »
Spróbuj wyrzucić fomit-frame-pointer z CXXFLAGS (w CFLAGS zostaw jak jest).

No i -ffast-math nie jest super korzystne, bo to tylko tricki i w niektórych programach może powodować błędy.

-mmmx i inne specyficzne dla procesora możesz wywalić, bo -march=k8 zawiera je w sobie.

Generalnie obstawiam fomit-frame-pointer w CXXFLAGS. Pod C++ ta opcja powoduje, że kod wynikowy potrafi się bardzo rozrosnąć. Dodatkowo, w połączeniu z faktem, że duże aplikacje zazwyczaj pisane są właśnie w C++ to ryzyko jest spore.



Neonioo

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #8 dnia: 2005-08-23, 00:26:52 »
2005-08-22 23:47:48 xis napisał:

> Spróbuj wyrzucić fomit-frame-pointer z CXXFLAGS (w CFLAGS zostaw jak jest).
 >
 > No i -ffast-math nie jest super korzystne, bo to tylko tricki i w niektórych programach może
 > powodować błędy.
 >
 > -mmmx i inne specyficzne dla procesora możesz wywalić, bo -march=k8 zawiera je w sobie.
 >
 > Generalnie obstawiam fomit-frame-pointer w CXXFLAGS. Pod C++ ta opcja powoduje, że kod wynikowy
 > potrafi się bardzo rozrosnąć. Dodatkowo, w połączeniu z faktem, że duże aplikacje zazwyczaj
 > pisane są właśnie w C++ to ryzyko jest spore.
 >
 >
 >
Niestety nie pomogło;/ po ok. 5min kompilacji wine ram sie całkowicie zapchał.

xis

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #9 dnia: 2005-08-23, 00:52:34 »
> Niestety nie pomogło;/ po ok. 5min kompilacji wine ram sie całkowicie zapchał.

Jeśli usunąłeś -fomit-frame-pointer, to w zasadzie używasz już bezpiecznych flag, więc nie powinno być kłopotu. Nie znam tej flagi -funroll-loops, domyślam się, że chodzi o rozwijanie pętli, ale nie wiem jaki ma ona wpływ na kod (całkiem możliwe, że jest bezpieczna, ale nie znam jej, więc się nie wypowiem).

Być może wina tkwi w źle skompilowanym... kompilatorze.
Czy do stworzenia podstawki używałeś tych samych flag?

Ja bym ustawił flagi kompilatora i zainstalował podstawkę (wraz z gcc) jeszcze raz. Niestety nie mam innych pomysłów.

Neonioo

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #10 dnia: 2005-08-23, 09:15:20 »
2005-08-23 00:52:34 xis napisał:

>  > Niestety nie pomogło;/ po ok. 5min kompilacji wine ram sie całkowicie zapchał.
 >
 > Jeśli usunąłeś -fomit-frame-pointer, to w zasadzie używasz już bezpiecznych flag, więc nie
 > powinno być kłopotu. Nie znam tej flagi -funroll-loops, domyślam się, że chodzi o rozwijanie
 > pętli, ale nie wiem jaki ma ona wpływ na kod (całkiem możliwe, że jest bezpieczna, ale nie znam
 > jej, więc się nie wypowiem).
 >
 > Być może wina tkwi w źle skompilowanym... kompilatorze.
 > Czy do stworzenia podstawki używałeś tych samych flag?
 >
 > Ja bym ustawił flagi kompilatora i zainstalował podstawkę (wraz z gcc) jeszcze raz. Niestety
 > nie mam innych pomysłów.

pomogła mi opcja PORTAGE_NICENESS="19" dopisana do make.conf

Xax79

  • Gość
[gentoo] Zapychajacy sie RAM i procek przy kompilacji
« Odpowiedź #11 dnia: 2005-08-23, 17:06:20 »
Jezeli moge sie wypowiedziec, to nie jest rozwiazanie problemu.
Opcja ta to nic innego jak priorytet z jakim portage wykonuje swoje procesy. Domyslnie portage ma NICE ustawione na 0 i odkad siedze na gentoo nie bylem zmuszony do zmieniania tej wartosci na stale.
Komputer moze kompilowac wiele godzin bez przerwy podczas gdy ja pracuje sobie najzwyczajniej na KDE (komputer to duron 850). Fakt faktem, ze praca wowczas do przyjemnosci nie nalezy i mozna sie pokusic o zmiane priorytetu na nieco wiekszy, ale nie doprowadzilem jeszcze systemu do takiego stanu, zebym go musial calego restartowac.

Proponowal bym poszukania przyczyn gdzie indziej.
1. Po pierwsze: w jaki sposob gentoo zostalo zainstalowane (z ktorego stage). Mogles podczas instalacji bazowego systemu ustawic zbyt agresywnie flagi kompilatora. Ja zawsze flagi ustawiam po bootstrapie.

2. Wersja kernela rowniez moze miec znaczenie. Ja uzywam gentoo-sources-2.6.8 (zawsze najaktualniejsze dostepne).

3. Widze, ze domyslnie instalujesz pakiety, ktorych nie mozna zaliczyc do stabilnych (ACCEPT_KEYWORDS="~amd64"). Moze stabilne beda dzialac inaczej.

4. Nie wiem czy opcja 'pipe' jest wlaczana przez -O2 czy nie, ale na wszelki wypadek proponuje ja dodac do CFLAGS.

5. Pogrzebac w logach systemowych, tam czasami mozna znalezc przeciekawe informacje.

PS Moze masz po prostu za szybki komputer i gcc za nim nie wyrabia albo w druga strone, procek tak zadymia, ze gcc produkuje tyle danych ze RAM sie zatyka :-)
Wowczas zmiana priorytetu jest wskazana :-)