Linux.pl  :   Newbie   Forum   Blog   Wiki   Hosting   Przeglądarka manuali
http://forum.linux.pl r e k l a m a
  Jesteś niezalogowany.
 Zaloguj się
 Zarejestruj się
 Zapomniałem hasła...
   piątek, 31 października 2014 r.   
   Start
 · Rozdajemy Linuksa!
 · Baza sprzętu

   Linux HowTo
Programowanie
Java - JComboBox podstawy obsługi komponentu
Administracja
phpMyBackupPro - backup baz MySQL łatwo i przyjemnie
Administracja
Cała prawda o backupie
Oprogramowanie
Unlock Root - Rootowanie Androida
Sprzęt
Tania chińska dźwiękówka USB 3D SOUND na tajwańskim chipie TP6911
Recenzje
Lekkie dystrybucje krótko i rzeczowo.
Administracja
Biblioteka popt

   Na forum
 · Wine - białe tło · [1]
 · Połączenie PPPoE w Fedorze · [3]
 · Problem "startx" · [8]
 · Linux na netbooka · [4]
 · Jak stworzyc bootowalnego pendrive na linuxie … · [1]
 · Instalacja Linux z Kopii zapasowej · [1]
 · [/dev/null] Problem "startx" · [1]
 · Sprzedam tablet Samsung Galaxy Tab 3 8.0 16GB … · [0]
 · Skrypt generujący plik i wysyłający go na serwer. · [1]
 · YUM - czy da się podpiąć skrypt BASH do YUM a … · [0]
 · Zepsuta karta graficzna? · [1]
 · Failed to enable AA podczas instalacji Fedory. · [1]
 · Distro na PC - coś pomiędzy Slackiem a Archem · [7]
 · LInux + win 7 · [9]
 · rdate pobiera różne czasy · [0]
 · Nie można zaimportować połączenia VPN · [10]
 · Instalacja sterowników nvidia na Y510p SLI · [2]
 · Inny serwer dhcp w sieci. · [2]
 · Problem/błąd w Torchlight · [1]
 · Lenovo IBM B590 · [7]
forum Linux.pl - RSS

UWAGA! Zanim zadasz pytanie na forum dotyczące jakiegoś problemu technicznego sprawdź koniecznie czy rozwiązanie tego problemu nie znajduje się już na tej stronie! Zapoznaj się również z artykułem Linuksowy savoir-vivre, czyli jak najlepiej otrzymać pomoc. To zaoszczędzi Twój czas, a nam ułatwi zadanie.

Prosimy o zachowanie kultury języka oraz ogólnie przyjętych norm etycznych. Zachowania niecenzuralne i uciążliwe dla innych użytkowników forum mogą spowodować usunięcie postów lub nawet zablokowanie możliwości korzystania z forum!

#1 2012-08-14 13:51:29

Opera/9.80 (Windows NT 5.1; U; pl) Presto/2.10.289 Version/12.01
Marfis
Nowy na forum
Posty: 2

grub- no such partition

Witam,
Mam Windows XP
AMD Duron 800MHz
384 MB RAM
HDD 40GB
Jako drugi system chce Linuksa wiec zainstalowałem Opensuse 12.1, zainstalował się ok, tylko ze miałem 10-17MB wolnego ramu, wiec odpada.
Instaluje od nowa XP przydzieliłem na c: 33500MB a reszte nie przydzielałem.
Instaluje linuxMint 12 LXDE, wybieram z menu aby był obok XP i automatycznie korzysta z partycji która wcześniej zostawiłem. Instalacja zakończona, przy uruchamianiu mam błąd grub rescue no such partition. Próbowałem programem Super GRUB2 Disk ale on wykrywa tylko XP.
efekt instalacji debiana 6 LXDE również jest taki sam.
Gdzie leży problem i jak go rozwiązać?

A teraz plan B:
Może pożegnać się z XP i zostawić Linuksa jako jedyny system i w razie potrzeby (MS PowerPoint itp.) korzystać z XP wirtualnie? Sprzęt da rade na taką emulacje? Która dystrybucja będzie na tyle lekka by działać możliwie na staruszku? No i czy to w ogóle będzie rozsądne?
Z góry dziękuje za odpowiedź.

Offline

 

#2 2012-08-14 15:06:52

Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
energizer
Stały bywalec
Posty: 266

Re: grub- no such partition

Wirtualne odpalenie XP to będzie mordęga. LXDE to dobry kompromis pomiędzy wygodą a lekkością oprogramowania.

Offline

 

#3 2012-08-15 22:02:30

Opera/9.80 (Windows NT 5.1; U; pl) Presto/2.10.289 Version/12.01
Marfis
Nowy na forum
Posty: 2

Re: grub- no such partition

Zainstalowałem mint jako jedyny system by sprawdzić czy warto się męczyć, jednak nie warto - za slaby sprzet.
Później zainstalowałem puppy który jako jedyny grub zainstalował się bez problemów obok windowsa.
Jednak nadal upieram się by przetestować debiana, przez te wszystkie nieudane próby na obecnej instalacji odłączyłem internet a instalacje grub2 anulowałem. Skorzystałem z puppy live cd i za pomocą grubconfig dodałem wpis.

Teraz włączam debiana wpisując w konsoli grub

Kod: (Pokaż/ukryj)

root (hd0,4)
kernel /vmlinuz root=/dev/sda5 
initrd /initrd.img
boot

(login)
(haslo)
startx

Mam kursor i po kliknieciu prawym przyciskiem myszy otwiera się menu. Rozumiem ze nie mam zainstalowanego środowiska graficznego i muszę go doinstalować?

Ostatnio edytowany przez Marfis (2012-08-16 15:26:35)

Offline

 

#4 2012-08-22 09:11:59

Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Anka1812
Nowy na forum
Posty: 3

Re: grub- no such partition

Tak, trzeba doinstalować.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
© Copyright 2007–2009 Paweł Smoliński & Linux.pl team

Copyright © 2003-2014  Linux.pl Created by

.