Nowe posty

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Pokaż wątki - 920806

Strony: [1] 2
1
Bash, skrypty powłoki / Odkrywanie adresu ip
« dnia: 2017-10-20, 18:01:22 »
Hej :) być może nie zrobię tego w bashu ,ale chce wiedzieć jak się za to zabrać. Chciał bym zrobić skrypt który po włączeniu pokazuje mój adres IP :) Macie jakiś pomysł?? próbowałem :

ifconfig |grep *.*.*.* 

ale to nie zadziałało w ogóle :(

za to:
 ifconfig |grep 10.0.0.* 


zadziałało ,ale minus tego jest taki ,że muszę znać adresacje :) a w skrypcie chodzi o to żeby jej nie znać :P

Jakiś pomysł ?;D

2
Czesc  :)

W ramach nauki c++ zacząłem pisać prosty komunikator w oparciu o winsock2, no i w sumie czy ktoś mi wyjaśni - bo nie do końca rozumiem  - jak to przesłać do innego komputera w innej sieci ?. 

Mam na myśli sytuacje taka ,że ja pisze z Warszawy do kolegi w Krakowie i na odwrotak, jak znaleźć jego adres w sieci?  Powinienem zadzwonić do jego ISP ? Czy poprosić o to żeby zapuścił tracert i powiedział przez jakie adresy przechodzi pakiet ? Z drugiej strony doskonale wiem że nie każdy router udostępnia swoje ip przez co tracert odpada.

Macie może jakieś doświadczenia ?:)

3
Sieć / Mała prędkość transferu - dysk NAS
« dnia: 2017-07-23, 18:45:58 »
Cześć :)

Mam pytanie , czy jest jakiś parametr odpowiadający za prędkość zapisywania danych na dysk NAS ?. Mam zasób udostępniony przez RPI 3(RIP :D),ale gdy przesyłam na niego jakiś projekt który waży ok ~1Gb przesyła mi go z prędkością ~370Kb/s.

RPI 3 połączone prze Wi-Fi do routera i jest w tej samej sieci co inne urządzenia , nie wiem co może powodować taki spadek prędkości myślicie ,że jednym z czynników mógłby być dysk podłączony do usb 2.0?

Oba dyski maja system plików NTFS

Server: SAMBA
System: Raspbian

4
Instalacja / Instalacja Arch Arm v8 na Raspberry Pi3
« dnia: 2017-07-18, 20:40:20 »
Hej , czy ktoś instalował Arch-linuxa vrm v8  na RB PI 3 ?? Robiłem wszystko zgodnie z tym o to tutaj filmikiem:
https://www.youtube.com/watch?v=28-oPIuz-G0&t=267s

Ale tylko straciłem czas...

I teraz tak.. Jak to jest  z tymi Raspberry?
Jak nie działa to ch**j trzeba wypalać obraz aż zadziała ?
Niestety nic innego nie przychodzi mi do głowy , skoro nie wyświetla mi się nawet obraz , a zielona dioda miga w tych samych odstępach , sprawdzałem pod monitorem od RB , no i zwykłym monitorze .. i NIC :P

[Edit]

Cel jaki chce osiągnąć to domowy NIDS, ale potem chciał bym spróbować przekształcić RB na router , wszystkie "projekty" mają służyć tak na prawdę celom edukacyjnym , chce się zaznajomić z konfiguracją zrobić jakąś swoją dokumentacje itd. Paweł kiedyś w jakimś poście wspominałeś o czymś co nazywało się XEN lub -jeśli nie mylę pojęć- Virtual Firewall Appilance :).

Jest sens to robić na RB?
[Edit]
Ostatnia rzecz ..
Gdy uzywam fdisk  na  Ubuntu wyświetla mi karte sd jako "MMCBLK01" zamisat "sdX"  czy uważacie ,ze ma to jakieś znaczenie ?

5
Witam,

Napisałem 2 skrypty przy pomocy modulu socket.
Jeden z nich pełni role serwera,a drugi klienta(wszystko na jednym komputerze).

Server nasłuchuję na porcie 8989,pod adresacja 127.0.0.1
Klient ma sie podłączyć pod ten adres, no i w sumie to robi.



Ale gdy chce zmienić adres ip server na np. 192.168.1.10 otrzymuje komunikat:
OSError: [Errno 99] Cannot assign requested adress.
Wszystkie skrypty odpalam przez python 3.5

Ostatecznie chciał bym osiągnąć komunikacje miedzy dwoma komputerami ..ale czy jak podam adres pętli zwrotnej na jednym komputerze to klient na drugim nie będzie próbował sie komunikować ze swoja własną pętlą? To bez sensu ,z drugiej strony jak wskazać serwer klientowi jeśli nie moge mu przypisać innej adresacji ..jesli trzeba udostępnię kod :)

6
Administracja / Pierwsze spotkanie z serverem
« dnia: 2016-10-12, 01:08:32 »
Witam :)

Post kieruje do p.administratorów :).
Dziś będę miał dostęp do swojego pierwszego prywatnego vps-a , nie przez jakąś firmę ale mam taką możliwość.

2 rdzenie proc,4gb ramu 25gb ssd

Myślę że chce zacząć od linuxa  ,zakłądam ze na start tyle wystarczy

Bardzo chciał bym wiedzieć :

*Co jako młody człowiek powinienem ćwiczyć mając do dyspozycji taką technologie ,
*Na czym powinienem się skupić

Chciał bym jakoś produktywnie wykorzystać to co mam , niestety dośw. zawodowe(raczej brak) nie pozwala mi dostać pracy więc muszę robić to  w taki nie inny sposób  .

Wiem, że tworzenie użytkownika i nadawanie im uprawnień to głupia praktyka ,ale nie znalazłem jeszcze w internecie czegoś w stylu " must know'. Może wy coś podpowiecie :)

7
Inne / mmls problem z odczytaniem informacjo o systemie pliko
« dnia: 2016-10-01, 18:34:24 »
Witam :)

Chciałem użyć komendy mmls , na ściągniętym wcześniej obrazie ntfs-img-kw-1.dd (zakładam ze system plikow jest  w ntfs-ie).
Obraz ściągnięty z tej str. [link]http://dftt.sourceforge.net/test3/index.html[link].

Tu jest ten problem ..coś ominąłem ale ..nie wiem co :( .

root@unrecord:/media/m92# mmls /home/m92/Pobrane/3-kwsrch-ntfs/ntfs-img-kw-1.dd
Cannot determine partition type


Polecenia tez nie wyssałem z palca ,robiłem je na podstawie książki i jak zwykle jakieś problemy :D

mount /home/m92/Pobrane/3-kwsrch-ntfs/ntfs-img-kw-1.dd -t ntfs /media/m92/
root@unrecord:~# cd /m
media/ mnt/   
root@unrecord:~# cd /media/
root@unrecord:/media# ls
cdrom  cdrom0  m92  root
root@unrecord:/media# cd m92/
root@unrecord:/media/m92# ls
dir-n-6  file-n-1.dat  file-n-4.dat  file-r-1.dat  System Volume Information
dir-r-4  file-n-3.dat  file-n-5.dat  file-r-3.dat

8
Sieć / alternatywna serwerownia
« dnia: 2016-09-26, 19:49:41 »
Witam,

Chciał bym nauczyć się podstaw administracji linuxem pod kątem serwerow .. Miałem ostatnio sporo rozmów no i często pytano o to ..z tego względu chciał bym się jakoś uatrakcyjnić i pójść o krok dalej..

Niestety jednak nie stać mnie na pełna serwerownie( mam tylko 42 portowy switch zarządzalny :D) . Wiec może podpowiecie jak podejść do sprawy i polecicie jakąś alternatywę ?

9
Sieć / routing/iptables/
« dnia: 2016-09-18, 12:43:43 »
Hej , znajdzie się jakiś specjalista który żyje z poleceniem  iptables za pan brat ;)??
Chce żeby moje 2 karty sieciowe się ze sobą komunikowały ,czy jest to mozliwe ?

root@unrecord:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:13:77:d0:9f:9d 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1440 (1.4 KiB)  TX bytes:1440 (1.4 KiB)

test      Link encap:Ethernet  HWaddr c2:5a:b8:4a:15:9b 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:21:5d:c4:ca:4a 
          inet addr:192.168.1.57  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::221:5dff:fec4:ca4a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:150868 errors:0 dropped:0 overruns:0 frame:0
          TX packets:93889 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:179679593 (171.3 MiB)  TX bytes:11540310 (11.0 MiB)

wlan1     Link encap:Ethernet  HWaddr 00:c0:ca:55:8c:8d 
          inet6 addr: fe80::2c0:caff:fe55:8c8d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:731 (731.0 B)  TX bytes:1353 (1.3 KiB)


założenie jest takie:

1.Chce zeby interface wlan0 otrzymywał/wysyłał pakiety z/do bramki domyślnej ,czyli żeby miał najzwyczajniej połączenie z routerem . Dalej chciał bym żeby wlan0 przesyłało pakiety do wlan1 (który jest w trybie AP).  Urządzenie końcowe(smartfon) łączy się z wlan1 w trybie AP i ma dostęp do internetu .


 Nie oczekuje gotowca , ale Ja chyba źle szukam w internecie .. wszędzie na YT tutorialne na wirtualnej maszynie itp. moze szukam nie możliwego

10
Sieć / konfiguracja DHCP
« dnia: 2016-09-11, 12:19:26 »
Dzien dobry ,

Mam pytanie , chciał bym skonfigurować połączenie w 2 komputerach . Komputer A łączy się z komputerem B, komputer B łączy się z routerem . W związku z tym mam 2 pytania:
1.Czy komputer B MOZE przekazywać ruch przez interface wifi? czy musi to być koniecznie przez kabel ethernet :)
2. Czy podpowiecie jak to zrobić w linuxie ?:)

11
Urządzenia sieciowe / Router/otwartyport/telnet
« dnia: 2016-08-29, 09:19:03 »
 Dzień dobry :)

Panowie mam pytanie .. Wisi mi otwarty port 23/telnet na routerze pirelli drg 223a. Nie ukrywam ,ze z czystej ciekawości chciałem tam spojrzeć natomiast przy logowaniu prosi mnie o hasło , na początku myślałem ze pewnie standardowe root/user/admin/empty. Ale nic z tych rzeczy , czy w usłudze telenet występują jakieś inne hasła niż standardowe ale tez regularne ,i Ja o tym nie wiem ..Czy czeka mnie zgadywanka ? .

12
Sieć / Karta sieciowa jedna bez drugiej niet
« dnia: 2016-08-24, 21:06:24 »
Hej ..wszystkim , dawno nie zaglądałem :)

Mam dość dziwny temat .. Jak to jest mozliwe ,ze przy włączonej karcie sieciowej wbudowanej nie mam problemu z drugą kartą .
Ale gdy wyłączę kartę wewnętrzną "ifconfig wlan0 down"  przestaje działać ta druga , choć dioda świeci ale w inny sposób . Czy jest to mozliwe ,ze działają na tym samym sterowniku ? mogę jakoś to sprawdzić ? Dodam ze karta sieciowa zewnętrzna to alfa awus036h tej drugiej nie pamiętam choć tez bym sobie przypomniał

Dodam , ze chce skanować swoją sieć . Jak sięgam pamięcią to przed aktualizacją dystrybucji nie miałem takich problemów . Przez ostatnie pół roku byłem po złej stronie mocy i teraz chcę sobie odświeżyć temat i o ...krzaki :>

13
/dev/null / najczęstsze problemy linux
« dnia: 2016-05-13, 16:22:48 »
Witam serdecznie, szanownych administratorów,forumowiczów...

Kieruje się do was z malą prośbą i jednocześnie pytaniem:) . Czy jesteście w stanie podzielić się swoim doświadczeniem w administrowaniu sieciami? Uchylić troszkę kulisy problemów jakie was spotykamy podczas pracy w firmach/korpo? :)

14
Wymiana doświadczeń / Najczęstsze problemy w firmie
« dnia: 2016-05-13, 13:41:05 »
Witam serdecznie :) Niebawem zacznę przygodę w IT prawdopodobne na razie będzie to przyuczenie do zawodu ,ale podejrzewam ze docelowo będzie to administrator siecie..Jako ze to mój start a jestem bardzo młodym człowiekiem , chciał bym zapytać was szanowni administratorzy :)

Jakie najczęstsze problemy mieliście w firmach z ludźmi/systemami/sprzętem ,każda odpowiedz jest dla mnie na wagę złota :)!!

15
Urządzenia sieciowe / [Debian]Problem z modułem bluetooth
« dnia: 2016-01-16, 20:50:00 »
Cześć wszystkim :)

Dawno nie pisałem ;) .
Dodam ,ze z  274 postów na temat bluetooth nie udało mi się znaleźć nic sensownego ... Postaram się być treściwy :D

A więc , mam moduł bluetooth na usb , gdy go wkładam  i wpisuje dmesg daje mi to :

Cytuj
[ 5667.870621] wlan0: associated
[ 5677.026163] VFS: busy inodes on changed media or resized disk sr0
[ 5924.900434] Bluetooth: RFCOMM TTY layer initialized
[ 5924.900443] Bluetooth: RFCOMM socket layer initialized
[ 5924.900449] Bluetooth: RFCOMM ver 1.11
[ 6933.008330] usb usb2-port1: disabled by hub (EMI?), re-enabling...
[ 6933.008347] usb 2-1: USB disconnect, device number 3
[ 6941.592087] usb 2-1: new full-speed USB device number 5 using uhci_hcd
[ 6941.739073] usb 2-1: device descriptor read/all, error -71
[ 6941.856091] usb 2-1: new full-speed USB device number 6 using uhci_hcd
[ 6942.015094] usb 2-1: New USB device found, idVendor=0a12, idProduct=0001
[ 6942.015099] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 6984.592109] usb 2-1: USB disconnect, device number 6
[ 6989.052088] usb 2-1: new full-speed USB device number 7 using uhci_hcd
[ 6989.200080] usb 2-1: device descriptor read/all, error -71
[ 6989.312092] usb 2-1: new full-speed USB device number 8 using uhci_hcd
[ 6989.467081] usb 2-1: New USB device found, idVendor=0a12, idProduct=0001
[ 6989.467087] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0

Tablet niby wykrywa , sparował się ale kiedy w menadżerze połączeń naciskam "przycisk" I/O ,niby próbuje nawiązać jakieś połączenie ale nic z tego nie wynika i się wyłącza ... Ciągle przeskakuje mi, z I na O.
 
Tu jeszcze daje wynik rfkill list

Cytuj
0: samsung-wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
3: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no

dodam jeszcze ,ze komendy wykonuje z poziomu roota , natomiast próby łączenia przez interface graficzny zwykłego użytkownika

Strony: [1] 2