Nowe posty

clip o JavaScrypt ... i zabezpieczeniu Autorstwa "obrazów" (3)
Wczoraj o 14:46:23
xx [solved]brak liblz4.so.1 (2)
2017-11-19, 06:57:15
xx Proszę o pomoc Jakiej komendy ls użyto? (1)
2017-11-18, 15:52:07
xx Rescuecd a macierz jak odczytac dane z dysku (1)
2017-11-16, 14:48:28
xx tomcat, serwlet, aplet - pytanie o wyświetlanie "obrazów" (3)
2017-11-15, 22:51:45
xx PHP nie raportuje błędów (2)
2017-11-15, 10:00:04
xx OPENSSL - problem z odszyfrowaniem pliku (5)
2017-11-15, 07:39:23
xx Brak Ubuntu w Uefi (7)
2017-11-14, 11:10:30
xx Jaka wersja linux pod ibm x40 (7)
2017-11-13, 18:30:06
xx Funkcja rekursywna (2)
2017-11-13, 16:00:54

Autor Wątek: Błędy zależności przy instalacji g++-2.95  (Przeczytany 3185 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Błędy zależności przy instalacji g++-2.95
« dnia: 2017-05-14, 08:23:34 »
Witam, mam problem z poprawnym zainstalowaniem kompilatora g++-2.95. Przy instalowaniu pakietów wyskakują błędy zależności



Potrzebuję tych pakietów do skompilowania jednej biblioteki. Bez nich to się nie uda, bo przy kompilacji wyskakuje błąd:

gcc-2.95: installation problem, cannot exec `cc1plus': No such file or directory

Dzięki za pomoc.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2266
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #1 dnia: 2017-05-14, 10:53:56 »
Jaka to aplikacja? Lepiej zmodyfikować ją, aby działała na nowych GCC (miłościwie nam panujące 6.x) niż rozwalić system instalując stare GCC. Ta wersja GCC ma 16 lat i generuje błędy podczas kompilacji - generalne GCC w wersjach starsze niż 3 to zuoTM.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy
Jeżeli uważasz, że warto: 1AfKbLX6nZSqv5DNhXMNLivc9fXwaHMd4Z

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #2 dnia: 2017-05-14, 13:49:25 »
Jaka to aplikacja? Lepiej zmodyfikować ją, aby działała na nowych GCC (miłościwie nam panujące 6.x) niż rozwalić system instalując stare GCC. Ta wersja GCC ma 16 lat i generuje błędy podczas kompilacji - generalne GCC w wersjach starsze niż 3 to zuoTM.

To biblioteka .so do pewnej starej gry. Chcę ją skompilować a później nieco przerobić, tak żeby zachować kompatybilność z samym silnikiem gry. Mam kody źródłowe i plik .so zbudowany właśnie na g++-2.95 z identycznego source code. Wrzucę source pliku, przez który próbuję skompilować kod:

http://wklej.to/bLPSn

Wykonanie tego kodu kończy się tym:

http://wklej.to/fevI5

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2266
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #3 dnia: 2017-05-14, 16:21:11 »
Najszybciej będzie ściągnąć z muzeum instalkę Debiana Woody'ego i odpalić ją pod wirtualką.

Przez zależności gcc-binutils-libc nie wydaje mi się, żeby dało się zainstalować w pełni działające GCC-2 na współczesnym systemie.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy
Jeżeli uważasz, że warto: 1AfKbLX6nZSqv5DNhXMNLivc9fXwaHMd4Z

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #4 dnia: 2017-05-14, 17:34:02 »
Najszybciej będzie ściągnąć z muzeum instalkę Debiana Woody'ego i odpalić ją pod wirtualką.

Przez zależności gcc-binutils-libc nie wydaje mi się, żeby dało się zainstalować w pełni działające GCC-2 na współczesnym systemie.

Faktycznie tak powinno być prościej, o dziwo instalacja samej gry nie sprawiła w ogóle problemów, nawet dźwięk jest. Dam znać jeśli pojawi się jakiś problem z kompilacją na tym starszym debianie.

Offline Filys

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #5 dnia: 2017-06-04, 12:43:59 »
Poprawienie paru pierdół i skompliowanie na nowej wersji powinno być proste.

Dziwi, że Kolega jednak wybrał katowanie się z wirtualną maszyną.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #6 dnia: 2017-06-16, 20:26:31 »
Poprawienie paru pierdół i skompliowanie na nowej wersji powinno być proste.

Dziwi, że Kolega jednak wybrał katowanie się z wirtualną maszyną.

Jeśli faktycznie to jest możliwe, to chętnie posłucham rad, które umożliwią zbudowanie takiej biblioteki na nowszym GCC, która będzie działać z grą zbudowaną na starszym GCC. Tutaj ważny cytat na ten temat:

Cytuj
Q: Is it possible to build native mods for Linux?
A: Yes, it is in fact possible but I strongly discourage you to do so unless you really know what you're doing. If you ABSOLUTELY need a native mod for Linux then here's what you need to keep in mind:

UT's native Linux client was compiled using the the ancient GCC 2.95.x compiler. Code generated by this compiler is binary incompatible with code that was generated by GCC 3.x or later. This is mainly due to a change in the C++ name mangling conventions. I do believe that there were some changes in the exception frame format and in the calling conventions as well but I never really checked this. In short, just install GCC 2.95.4...

--


Q: Which compiler flags do I need for GCC?
A: Here's a list:
Mandatory compiler flags: -D__USE_GNU -D_GNU_SOURCE -D_REENTRANT -D__LINUX_X86__ -fno-for-scope -fexceptions
Optional compiler flags: -O2 -fomit-frame-pointer
Mandatory linker flags: -Wl,--traditional-format -Wl,--eh-frame-hdr -shared -lm -ldl -lpthread

W razie czego jestem w stanie dostarczyć kod źródłowy do jednej biblioteki, która na GCC 2.95 bez problemu się kompiluje i bardzo dobrze współdziała z grą. Próbowałem zainstalować starszego Debiana na maszynie wirtualnej, ale problem z internetem na nim (brak możliwości przerzucenia plików) już zniechęcił. Po miesiącu próbuję jeszcze raz zainstalować.

Teraz pojawił się taki problem po instalacji


Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #7 dnia: 2017-06-22, 12:11:04 »
@odświeżam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #8 dnia: 2017-07-10, 22:48:29 »
@odświeżam

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 1756
  • 1709
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #9 dnia: 2017-07-11, 14:57:02 »
Cytuj
Próbowałem zainstalować starszego Debiana na maszynie wirtualnej, ale problem z internetem na nim (brak możliwości przerzucenia plików) już zniechęcił.
internet powinien działać od ręki ( ale mogę się mylić )
W virtualbox w zakładce Network spróbuj zmienic karte sieciową, może pomoże.
Jeśli użyłes  Qemu, to też mozesz zmienić karte sieciową i ponownie zainstalować system. ( jeśli bedzie system lagować to musisz znaleść optymalne opcje )

Zeby przenieść dane na maszyne virtualną, mozesz
- przez internet ( jak zacznie działać, internetu bedziesz potrzebowal takze do pobrania zaleznosci jesli repo dziala )
- przez pendriva USB ( bedzie potrzeba zainstalować Oracle VM VirtualBox Extension Pack ,
 jest na ona na stronie virtualboxa i różna w zaleznosci od wersji virtualboxa ) oraz użytkownik musi być chyba w grupie virtualbox
http://www.ubuntu-pomoc.org/virtualbox-obsluga-portow-usb/
- poprostu przeniesc ( i tu jest trudniej, na danej maszynie powinno sie pierw załadować sterownik czy coś tam, nie pamietam )

Skompilowanie starych zaleznosci na nowym systemie moze byc trudne, ale może możliwe.
Polega to na zainstalowaniu zależności w innym folderze tak aby nie kolidowały z pakietami domyslnymi i żeby sam system ich nie używał,
a tylko aplikacje które potrzebujesz.
Opcja --prefix  http://pclinuxoshelp.com/index.php/Installing_Software_without_Synaptic
http://www.liberainformatica.it/forum/showthread.php?tid=416

PS.
1. Wygasły zdjecia
2. Nie pomoge z kompilacją zabardzo, bo mam ważniejsze sprawy na głowie.
3. Staraj się żeby wszystkie pliki były w miare w 1 miescu i nie konfiktowaly np. w  katalogu /opt lub /usr/local/   ( nie polecam tutaj w /home/user/ )
( --prefix jest tylko 1 opcją, jest ich wiecej )
4. W miare mozliwosci uzywaj maszyny wirtualnej, kompilacja zawsze moze sie nie udac i uszkodzic system ( instalacja ).
5. Najlepiej jest paczkować pakiety, ale zakladam że nie potrafisz ...
w Debianie mozesz uzyc checkinstall , nie jest to zaawansowane, ani polecane, ale wystarczajace zeby najprosciej robic pakiety .deb
poradnik masz  tu https://telelinux.blogspot.com/2017/05/compile-gtkdialog-on-debian-88.html
i tu https://www.youtube.com/watch?v=uRQ4QBegur8
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #10 dnia: 2017-08-13, 18:04:44 »
Próbowałem dzisiaj jeszcze raz zainstalować Debiana Woody, ale znowu nie wykrywa karty sieciowej (zdjęcie w załączniku). Potrzebuję dostęp do internetu na maszynie wirtualnej, żeby sprawnie przerzucić np. gcc i pliki źródłowe do kompilacji, ale instalator coś nie chce wykryć karty sieciowej.

@edycja: Wybrałem dodatkowe rodzaje kart sieciowych (PCnet-PCI II i PCnet-FAST III) i wygląda na to, że je wykryło i będzie wszystko działać po instalacji


Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2266
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #11 dnia: 2017-08-13, 23:17:14 »
Może jak wybierzesz kartę sieciową, która istniała w czasach Woody'ego będzie łatwiej? Spróbowałbym pierwszej z listy, PCnet-PCI-II.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy
Jeżeli uważasz, że warto: 1AfKbLX6nZSqv5DNhXMNLivc9fXwaHMd4Z

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Błędy zależności przy instalacji g++-2.95
« Odpowiedź #12 dnia: 2017-08-15, 01:12:40 »
Może jak wybierzesz kartę sieciową, która istniała w czasach Woody'ego będzie łatwiej? Spróbowałbym pierwszej z listy, PCnet-PCI-II.

Zgadza się, wybrałem i wykryło, po dodaniu ścieżek do archiwalnych apt ściąga je poprawnie. Próbnie skompilowałem silnik gry i udało się. Spróbowałem skompilować jeszcze dodatkową bibliotekę, z nowszymi do tej gry nagłówkami .h, ale nie udało się, wyskakiwały różne błędy wskazujące na includy do tych nagłówków, tylko że zostały wydane przez samego producenta gry i wiele osób już na nich kompilowało biblioteki. Mam jeszcze kod źródłowy do innej biblioteki i błędy też występują. Spróbuję na innej wersji gcc o ile uda się zainstalować i dam znać (nowszej nie dało rady, bo potrzebuje nowszej wersji libc6).