Nowe posty

xx Problem z koszem po odpięciu dysku od Win 10 (2)
Dzisiaj o 13:56:45
xx Wirtualki - podział usług (0)
Wczoraj o 12:23:37
xx Dostęp do serwera DNS w innej podsieci (4)
Wczoraj o 11:06:11
xx Samba za NAT nie działa (5)
2017-05-24, 17:20:31
xx Skrypt- wyszukiwanie nazwy w tresci plikow (2)
2017-05-24, 16:46:33
xx Instalacja linux na pendriva (2)
2017-05-23, 11:04:27
xx Sprzedam książkę (1)
2017-05-19, 21:35:45
xx Bash, Unix - ściągawka (2)
2017-05-18, 08:54:50
xx Po aktualizacji Xubuntu nie działa wifi. (0)
2017-05-18, 01:43:56
sad Zlecę wykonanie skryptu (0)
2017-05-18, 00:22:32

Autor Wątek: Apache2 dziala z zewnatrz, PHPMYADMIN juz nie..  (Przeczytany 241 razy)

Offline norbertcz94

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Apache2 dziala z zewnatrz, PHPMYADMIN juz nie..
« dnia: 2017-05-08, 17:00:41 »
Witam!
Mam problem z baza danych mariadb. Zainstalowałem apache, php, mariadb i wszystko skonfigurowalem, aby moc zarządzać serwerem przez przeglądarkę.
Localhost działa super , jak wpisuje ip mojego komputera z innej sieci wifi tez wszystko się wyświetla. Z kolei jak wpisuje już www.mojeip/phpmyadmin to widzę nagłówek, chwile ladowania strony az w koncu biala strone ;/

Dlaczego tak się dzieje? Port 80 i 3606 mam przekierowane a mimo to  phpmyadmin śmiga tylko na localhost/phpmyadmin.
Opadłem z sil, bo na windowsie miałem to samo, dlatego zainstalowałem Ubuntu8. Ale problem nie zniknął.

Proszę o pomoc ;)


« Ostatnia zmiana: 2017-05-08, 17:03:36 wysłana przez norbertcz94 »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2155
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Apache2 dziala z zewnatrz, PHPMYADMIN juz nie..
« Odpowiedź #1 dnia: 2017-05-09, 11:22:47 »
Za przekierowanie portu bazodanowego powinieneś dostać prewencyjnego bana na oprzytomnienie (never EVER nie udostępniaj bezpośredniego dostępu do jakiegokolwiek serwera baz danych pod adresem zewnętrznym).

1. W apache'u masz taką śmieszną rzecz, jak logi. Zobacz tam, czy połączenie po nazwie domenowej w ogóle dochodzi i do którego serwera wirtualnego jest przydzielane.

2. Bardzo często router nie umożliwia połączenia z sieci lokalnej na adres publiczny routera, aby przekierowanie "zawinęło" połączenie z powrotem do sieci lokalnej (ta sytuacja, to tzw "hairpin NAT"). Przekierowanie działa tylko dla połączeń przychodzących z zewnątrz. Można to obejść używając proxy poza siecią lokalną - wtedy połączenie efektywnie przychodzi z zewnątrz i jest prawidłowo przekierowywane.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy
Jeżeli uważasz, że warto: 1AfKbLX6nZSqv5DNhXMNLivc9fXwaHMd4Z

Offline norbertcz94

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Odp: Apache2 dziala z zewnatrz, PHPMYADMIN juz nie..
« Odpowiedź #2 dnia: 2017-05-10, 10:56:04 »
Ok, mam przekierowany tylko port 80.
Po wejściu na mojeip/phpmyadmin pojawia się okno logowania i po wpisaniu jest biala strona a w apache mam nastepujace logi:

w logu access apache:
77.179.153.238|[10/May/2017:10:49:43 +0200]|GET /phpmyadmin/ HTTP/1.1|1098|-
77.179.153.238|[10/May/2017:10:49:52 +0200]|GET /phpmyadmin/themes/pmahomme/jquery/jquery-ui-1.8.16.custom.css HTTP/1.1|33434|-
77.179.153.238|[10/May/2017:10:49:52 +0200]|GET /phpmyadmin/print.css HTTP/1.1|1064|-
77.179.153.238|[10/May/2017:10:49:52 +0200]|GET /phpmyadmin/phpmyadmin.css.php?server=1&lang=pl&collation_connection=utf8_general_ci&token=7f1b20ee01aba1bbe36b35646b1bdecb&js_frame=right&nocache=4042821657 HTTP/1.1|82340|-
77.179.153.238|[10/May/2017:10:51:11 +0200]|GET /phpmyadmin/ HTTP/1.1|1045|-
77.179.153.238|[10/May/2017:10:51:16 +0200]|GET /phpmyadmin/ HTTP/1.1|2612|root
77.179.153.238|[10/May/2017:10:51:16 +0200]|GET /phpmyadmin/js/common.js?ts=1356012182 HTTP/1.1|4717|-
77.179.153.238|[10/May/2017:10:51:16 +0200]|GET /phpmyadmin/js/update-location.js?ts=1356012182 HTTP/1.1|758|-

a w pliku error:

[Wed May 10 10:49:28 2017] [notice] Apache/2.2.22 (Win32) PHP/5.4.10 configured -- resuming normal operations
[Wed May 10 10:49:28 2017] [notice] Server built: Feb 13 2012 12:13:59
[Wed May 10 10:49:28 2017] [notice] Parent: Created child process 3124
[Wed May 10 10:49:29 2017] [notice] Child 3124: Child process is running
[Wed May 10 10:49:29 2017] [notice] Child 3124: Acquired the start mutex.
[Wed May 10 10:49:29 2017] [notice] Child 3124: Starting 64 worker threads.
[Wed May 10 10:49:29 2017] [notice] Child 3124: Starting thread to listen on port 80.
[Wed May 10 10:49:29 2017] [notice] Child 3124: Starting thread to listen on port 80.